summaryrefslogtreecommitdiffstats
path: root/system/lirc/lirc.SlackBuild
diff options
context:
space:
mode:
author Murat D. Kadirov <banderols@gmail.com>2010-05-13 00:40:51 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:40:51 +0200
commit987400e2380babcbc118603fb2e7c98794d1d82a (patch)
tree070af29a2acabaeb2cb7fa825c9d03a64f803914 /system/lirc/lirc.SlackBuild
parent5431c4f00376ebd04b43aba92e930b1e9c5b0f65 (diff)
downloadslackbuilds-987400e2380babcbc118603fb2e7c98794d1d82a.tar.gz
slackbuilds-987400e2380babcbc118603fb2e7c98794d1d82a.tar.xz
system/lirc: Updated for version 0.8.6
Diffstat (limited to 'system/lirc/lirc.SlackBuild')
-rw-r--r--system/lirc/lirc.SlackBuild114
1 files changed, 59 insertions, 55 deletions
diff --git a/system/lirc/lirc.SlackBuild b/system/lirc/lirc.SlackBuild
index de644df718..363992bd4e 100644
--- a/system/lirc/lirc.SlackBuild
+++ b/system/lirc/lirc.SlackBuild
@@ -2,9 +2,7 @@
# Slackware build script for lirc
-# Copyright 2009 Johann Wilhelm <johann.wilhelm@9mal6.de>
-# Copyright 2007 David Somero <dsomero@hotmail.com>
-#
+# Copyright 2009 Murat D. Kadirov <banderols@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -13,50 +11,50 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lirc
-VERSION=0.8.4a
+VERSION=${VERSION:-0.8.6}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+KERNEL=${KERNEL:-$(uname -r)}
+PKG_VERS=${VERSION}_$(echo $KERNEL| tr - _)
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# Any of these can be changed by passing the desired value on command line
-# when executing the build script. For example:
-# IRQ=5 ./lirc.SlackBuild
-IRQ=${IRQ:-4}
-PORT=${PORT:-0x3f8}
-KERNEL=${KERNEL:-$(uname -r)}
-
-PKG_VERSION=${VERSION}_$(echo $KERNEL | tr '-' '_')
-
-if [ "${ARCH}" = "i486" ]; then
+if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "${ARCH}" = "i686" ]; then
+ LIBDIRSUFFIX=""
+ SRCARCH=x86
+elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+ SRCARCH=x86
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ SRCARCH=x86
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
+cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
@@ -67,59 +65,65 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch configure to not build a couple of things that either won't work
-# or will break compilation
-patch -p1 < $CWD/$PRGNAM-$VERSION.diff
+# Disabling lirc_gpio driver as it does no longer work with kernel 2.6.22+
+sed -i -e "s:lirc_gpio\.o::" drivers/lirc_gpio/Makefile.am || exit 1
+
+autoreconf
+libtoolize
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
- --mandir=/usr/man \
- --exec-prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
+ --mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-static \
--enable-sandboxed \
--with-driver=all \
--with-transmitter \
- --with-x \
- --with-major=61 \
- --with-port=$PORT \
- --with-irq=$IRQ \
- --with-moduledir=/lib/modules/$KERNEL/misc \
--build=$ARCH-slackware-linux
-make
+# Disable parallel and bt829 because of incompatibility with smp systems
+sed -i -e "s:lirc_parallel::" -e "s:lirc_bt829::" \
+ Makefile drivers/Makefile drivers/*/Makefile tools/Makefile
+
+make SRCARCH=$SRCARCH
make install DESTDIR=$PKG
-mkdir -p $PKG/usr/doc/$PRGNAM-$PKG_VERSION
-cp -a ANNOUNCE AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
- doc/lirc.hwdb contrib/lircrc $PKG/usr/doc/$PRGNAM-$PKG_VERSION
-install -m 0644 $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$PKG_VERSION
-install -m 0644 $CWD/README.SLACKWARE $PKG/usr/doc/$PRGNAM-$PKG_VERSION
+mkdir -p $PKG/usr/share/$PRGNAM
+cp -a remotes $PKG/usr/share/$PRGNAM
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+mkdir -p $PKG/lib/udev/rules.d
+cat contrib/lirc.rules > $PKG/lib/udev/rules.d/96-lirc.rules
+
+mkdir -p $PKG/etc/logrotate.d
+cat contrib/lircd.conf > $PKG/etc/lircd.conf.new
+cat contrib/lircmd.conf > $PKG/etc/lircmd.conf.new
+cat contrib/lircrc > $PKG/etc/lircrc.new
+cat $CWD/lirc.logrotate > $PKG/etc/logrotate.d/lirc.new
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
-install -D -m 0644 contrib/lircd.conf $PKG/etc/lircd.conf.new
-install -m 0644 contrib/lircmd.conf $PKG/etc/lircmd.conf.new
-install -m 0644 contrib/lircrc $PKG/etc/lircrc.new
-install -D -m 0644 contrib/lirc.rules $PKG/lib/udev/rules.d/96-lirc.rules
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
-rm -rf $PKG/dev # We don't need this
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ANNOUNCE AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
+ doc/{html,irxevent.keys,lirc.hwdb} $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
sed "s%@KERNEL@%$KERNEL%" $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$PKG_VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$PKG_VERS-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}