summaryrefslogtreecommitdiffstats
path: root/system/python-urwid
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-25 22:44:30 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-29 10:30:54 -0400
commitec48e88db5500748b73f0da3aa842ae3565d476f (patch)
treef8c955019c13956477b0fe12cbb200df58563f8d /system/python-urwid
parent4ffec93f486624f6ab21e868535842026915c4fc (diff)
downloadslackbuilds-ec48e88db5500748b73f0da3aa842ae3565d476f.tar.gz
slackbuilds-ec48e88db5500748b73f0da3aa842ae3565d476f.tar.xz
system/python-urwid: Strip binaries.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/python-urwid')
-rw-r--r--system/python-urwid/python-urwid.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/system/python-urwid/python-urwid.SlackBuild b/system/python-urwid/python-urwid.SlackBuild
index 3e252caff5..3d3bfff38c 100644
--- a/system/python-urwid/python-urwid.SlackBuild
+++ b/system/python-urwid/python-urwid.SlackBuild
@@ -21,12 +21,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220425 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - strip libraries.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-urwid
SRCNAM=urwid
VERSION=${VERSION:-2.1.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,13 +61,16 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README.rst docs examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild