summaryrefslogtreecommitdiffstats
path: root/system/python-urwid
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-04-20 08:23:19 +0000
committer Robby Workman <rworkman@slackbuilds.org>2021-04-20 17:53:22 -0500
commitd920f959cccd896d194292fa8a777af5944984ae (patch)
treeb6c36f4c4e334408e1af1f449c2c2be8c3053e3d /system/python-urwid
parent3d04318293bf747bc1dfe3d235cb6628c616dd43 (diff)
downloadslackbuilds-d920f959cccd896d194292fa8a777af5944984ae.tar.gz
slackbuilds-d920f959cccd896d194292fa8a777af5944984ae.tar.xz
system/python-urwid: Added (python console UI module)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'system/python-urwid')
-rw-r--r--system/python-urwid/README4
-rw-r--r--system/python-urwid/python-urwid.SlackBuild69
-rw-r--r--system/python-urwid/python-urwid.info10
-rw-r--r--system/python-urwid/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/system/python-urwid/README b/system/python-urwid/README
new file mode 100644
index 0000000000..3adc50eeca
--- /dev/null
+++ b/system/python-urwid/README
@@ -0,0 +1,4 @@
+Urwid is a console user interface library for Python. It is released
+under the GNU Lesser General Public License and includes many
+(too many to list) features useful for text console application
+developers. Urwid was written by Ian Ward.
diff --git a/system/python-urwid/python-urwid.SlackBuild b/system/python-urwid/python-urwid.SlackBuild
new file mode 100644
index 0000000000..006c1e1770
--- /dev/null
+++ b/system/python-urwid/python-urwid.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for python-urwid
+# Copyright 2017- Dave Woodfall <dave@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-urwid
+SRCNAM=urwid
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.rst docs examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/python-urwid/python-urwid.info b/system/python-urwid/python-urwid.info
new file mode 100644
index 0000000000..02fcdcc18f
--- /dev/null
+++ b/system/python-urwid/python-urwid.info
@@ -0,0 +1,10 @@
+PRGNAM="python-urwid"
+VERSION="2.0.1"
+HOMEPAGE="http://urwid.org"
+DOWNLOAD="https://pypi.org/packages/source/u/urwid/urwid-2.0.1.tar.gz"
+MD5SUM="c70a7016fa1ad2c2a979dbebd4de78c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dave Woodfall"
+EMAIL="dave@slackbuilds.org"
diff --git a/system/python-urwid/slack-desc b/system/python-urwid/slack-desc
new file mode 100644
index 0000000000..9fbeab90cb
--- /dev/null
+++ b/system/python-urwid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-urwid: python-urwid (python console UI module)
+python-urwid:
+python-urwid: Urwid is a console user interface library for Python. It is released
+python-urwid: under the GNU Lesser General Public License and includes many
+python-urwid: (too many to list) features useful for text console application
+python-urwid: developers.
+python-urwid:
+python-urwid: Urwid was written by Ian Ward.
+python-urwid:
+python-urwid: More info at: http://urwid.org
+python-urwid: