summaryrefslogtreecommitdiffstats
path: root/system/set_rlimits/Makefile.patch
diff options
context:
space:
mode:
author Paul Wisehart <wise@lupulin.net>2010-05-11 15:18:44 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 15:18:44 +0200
commit29d89a190908076312f0790d6eb28c5373df9ae0 (patch)
treee2b8d0d7417f64649560d19f3e22e0d313a4983d /system/set_rlimits/Makefile.patch
parent1b81462a76b1f3dcdbeec766b0f1a0c8e81d3665 (diff)
downloadslackbuilds-29d89a190908076312f0790d6eb28c5373df9ae0.tar.gz
slackbuilds-29d89a190908076312f0790d6eb28c5373df9ae0.tar.xz
system/set_rlimits: Initial import
Diffstat (limited to 'system/set_rlimits/Makefile.patch')
-rw-r--r--system/set_rlimits/Makefile.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/system/set_rlimits/Makefile.patch b/system/set_rlimits/Makefile.patch
new file mode 100644
index 0000000000..f0963dc62b
--- /dev/null
+++ b/system/set_rlimits/Makefile.patch
@@ -0,0 +1,29 @@
+--- Makefile 2007-04-22 14:18:21.000000000 -0400
++++ Makefile.new 2007-04-22 14:31:49.000000000 -0400
+@@ -12,16 +12,16 @@
+ gcc -Wall -g -o set_rlimits set_rlimits.c
+
+ install: set_rlimits
+- test -d $(PREFIX)/bin || mkdir -p $(PREFIX)/bin
+- test -d $(PREFIX)/man/man8 || mkdir -p $(PREFIX)/man/man8
+- test -d $(SYSCONFDIR) || mkdir -p $(SYSCONFDIR)
+- cp -p set_rlimits $(PREFIX)/bin/
+- chown root.root $(PREFIX)/bin/set_rlimits
+- chmod u+s $(PREFIX)/bin/set_rlimits
+- test -e $(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(SYSCONFDIR)/
+- chown root.root $(SYSCONFDIR)/set_rlimits.conf
+- cp -p set_rlimits.8 $(PREFIX)/man/man8/
+- chown root.root $(PREFIX)/man/man8/set_rlimits.8
++ test -d $(DESTDIR)$(PREFIX)/bin || mkdir -p $(DESTDIR)$(PREFIX)/bin
++ test -d $(DESTDIR)$(PREFIX)/man/man8 || mkdir -p $(DESTDIR)$(PREFIX)/man/man8
++ test -d $(DESTDIR)$(SYSCONFDIR) || mkdir -p $(DESTDIR)$(SYSCONFDIR)
++ cp -p set_rlimits $(DESTDIR)$(PREFIX)/bin/
++ chown root.root $(DESTDIR)$(PREFIX)/bin/set_rlimits
++ chmod u+s $(DESTDIR)$(PREFIX)/bin/set_rlimits
++ test -e $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(DESTDIR)$(SYSCONFDIR)/
++ chown root.root $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf
++ cp -p set_rlimits.8 $(DESTDIR)$(PREFIX)/man/man8/
++ chown root.root $(DESTDIR)$(PREFIX)/man/man8/set_rlimits.8
+
+ .PHONY: clean tidy
+