summaryrefslogtreecommitdiffstats
path: root/system/slpkg
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-05-14 17:29:59 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-05-14 17:29:59 +0700
commit74c0d2db4ddffbcae15389099f9e53575f033bf7 (patch)
tree3b368feeca048892dca63ad388203a6e400c64c8 /system/slpkg
parent641ac5e31c3ec46b5bf87e23063347abcfbf0b07 (diff)
downloadslackbuilds-74c0d2db4ddffbcae15389099f9e53575f033bf7.tar.gz
slackbuilds-74c0d2db4ddffbcae15389099f9e53575f033bf7.tar.xz
system/slpkg: Updated for version 1.1.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/slpkg')
-rw-r--r--system/slpkg/README6
-rw-r--r--system/slpkg/slack-desc2
-rw-r--r--system/slpkg/slpkg.SlackBuild11
-rw-r--r--system/slpkg/slpkg.info6
4 files changed, 15 insertions, 10 deletions
diff --git a/system/slpkg/README b/system/slpkg/README
index 7614d40ea3..3cda2a00d1 100644
--- a/system/slpkg/README
+++ b/system/slpkg/README
@@ -1,6 +1,4 @@
-Slpkg is a terminal tool , written in Python that allows the upgrade,
-remove, find and view Slackware packages contents.
+Slpkg is a terminal tool , written in Python that allows the
+build, upgrade, remove, find and view Slackware packages contents.
It's a quick and easy way to manage your packages in slackware
to a command.
-
-Note: the program is being developed.
diff --git a/system/slpkg/slack-desc b/system/slpkg/slack-desc
index 70f11a7240..fad35de19e 100644
--- a/system/slpkg/slack-desc
+++ b/system/slpkg/slack-desc
@@ -9,7 +9,7 @@
slpkg: slpkg (Slackware tool in Python)
slpkg:
slpkg: Slpkg is a terminal tool , written in Python that allows the
-slpkg: upgrade, remove, find and view Slackware packages contents.
+slpkg: build, upgrade, remove, find and view Slackware packages contents.
slpkg: It's a quick and easy way to manage your packages in slackware
slpkg: to a command.
slpkg:
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 0f29615f4f..bf3bb3deef 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=slpkg
-VERSION=${VERSION:-0.0.1}
+VERSION=${VERSION:-1.1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -69,11 +69,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# ignore pip install man page
+#sed -i 's/'install'//' setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/man/man8
+gzip -9 man/$PRGNAM.8
+install -D -m0644 man/$PRGNAM.8.gz $PKG/usr/man/man8/$PRGNAM.8.gz
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst CHANGELOG LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/system/slpkg/slpkg.info b/system/slpkg/slpkg.info
index 949c0b8d9d..a6f6cda81f 100644
--- a/system/slpkg/slpkg.info
+++ b/system/slpkg/slpkg.info
@@ -1,8 +1,8 @@
PRGNAM="slpkg"
-VERSION="0.0.1"
+VERSION="1.1.3"
HOMEPAGE="https://github.com/dslackw/slpkg"
-DOWNLOAD="https://github.com/dslackw/slpkg/archive/v0.0.1.tar.gz"
-MD5SUM="e3d9b7ccdef145b968bcc0693914d7cd"
+DOWNLOAD="https://github.com/dslackw/slpkg/archive/v1.1.3.tar.gz"
+MD5SUM="c7a3b83e63da736ea968e5ca9185656f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""