summaryrefslogtreecommitdiffstats
path: root/system/splix
diff options
context:
space:
mode:
author Iskar Enev <iskar.enev[@]gmail.com>2010-05-12 17:46:02 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:46:02 +0200
commitaf24e12ffc381cc670630ac5ed3d0437b3201f6f (patch)
treeeb6c72014dc8ebe3894847e9225344d1cdd83833 /system/splix
parent38ecf19e26be907e7205e22bd868723a48f9c9e1 (diff)
downloadslackbuilds-af24e12ffc381cc670630ac5ed3d0437b3201f6f.tar.gz
slackbuilds-af24e12ffc381cc670630ac5ed3d0437b3201f6f.tar.xz
system/splix: Updated for version 2.0.0
Diffstat (limited to 'system/splix')
-rw-r--r--system/splix/Makefile-DESTDIR.diff54
-rw-r--r--system/splix/README4
-rw-r--r--system/splix/splix.SlackBuild37
-rw-r--r--system/splix/splix.info6
4 files changed, 28 insertions, 73 deletions
diff --git a/system/splix/Makefile-DESTDIR.diff b/system/splix/Makefile-DESTDIR.diff
deleted file mode 100644
index c7bc3b98c5..0000000000
--- a/system/splix/Makefile-DESTDIR.diff
+++ /dev/null
@@ -1,54 +0,0 @@
-# This is an easy patch to add DESTDIR support to the Makefiles in splix
-# Written by Robby Workman - http://rlworkman.net
-# Permission is granted to use the patch as you see fit
-
-diff -Nur splix-1.1.1.orig/ppd/Makefile splix-1.1.1/ppd/Makefile
---- splix-1.1.0.orig/ppd/Makefile
-+++ splix-1.1.0/ppd/Makefile
-@@ -62,25 +62,25 @@
-
- .PHONY: install
- install:
-- install -d -m 755 ${CUPSPPD}/samsung
-+ install -d -m 755 $(DESTDIR)/${CUPSPPD}/samsung
- for filename in ${SAMSUNG}; do \
-- install -m 644 $$filename.${DRIVERSEXT} ${CUPSPPD}/samsung;\
-+ install -m 644 $$filename.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/samsung;\
- for lang in ${LANGUAGES}; do \
-- install -m 644 $$filename$$lang.${DRIVERSEXT} ${CUPSPPD}/samsung;\
-+ install -m 644 $$filename$$lang.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/samsung;\
- done; \
- done; \
-- install -d -m 755 ${CUPSPPD}/xerox
-+ install -d -m 755 $(DESTDIR)/${CUPSPPD}/xerox
- for filename in ${XEROX}; do \
-- install -m 644 $$filename.${DRIVERSEXT} ${CUPSPPD}/xerox;\
-+ install -m 644 $$filename.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/xerox;\
- for lang in ${LANGUAGES}; do \
-- install -m 644 $$filename$$lang.${DRIVERSEXT} ${CUPSPPD}/xerox;\
-+ install -m 644 $$filename$$lang.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/xerox;\
- done; \
- done; \
-- install -d -m 755 ${CUPSPPD}/dell
-+ install -d -m 755 $(DESTDIR)/${CUPSPPD}/dell
- for filename in ${DELL}; do \
-- install -m 644 $$filename.${DRIVERSEXT} ${CUPSPPD}/dell;\
-+ install -m 644 $$filename.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/dell;\
- for lang in ${LANGUAGES}; do \
-- install -m 644 $$filename$$lang.${DRIVERSEXT} ${CUPSPPD}/dell;\
-+ install -m 644 $$filename$$lang.${DRIVERSEXT} $(DESTDIR)/${CUPSPPD}/dell;\
- done; \
- done;
-
-diff -Nur splix-1.1.1.orig/src/Makefile splix-1.1.1/src/Makefile
---- splix-1.1.1.orig/src/Makefile
-+++ splix-1.1.1/src/Makefile
-@@ -30,7 +30,7 @@
- $(CXX) $(CXXFLAGS) -c $<
-
- install: rastertospl2
-- install -m 755 -s rastertospl2 ${CUPSFILTER}
-+ install -m 755 -s rastertospl2 $(DESTDIR)/${CUPSFILTER}
-
- .PHONY: clean distclean
- clean:
diff --git a/system/splix/README b/system/splix/README
index 5bdd9f945f..c2a30a3973 100644
--- a/system/splix/README
+++ b/system/splix/README
@@ -4,8 +4,7 @@ the tarball for supported models. Only SPL2 and SPLc printers are
currently supported; however, work is in progress to implement support
for other SPL printers.
-This requires cupsddk and jbigkit, both of which are available at
-SlackBuilds.org).
+This requires cupsddk and jbigkit.
IMPORTANT NOTICE:
If you are upgrading your current version, you MUST delete your printer
@@ -13,7 +12,6 @@ in the CUPS interface and install it again. This operation MUST be done
since CUPS caches a copy of the PPD file, so if the PPD changes from one
version of splix to the next, cups will still have the cached copy.
-
IMPORTANT NOTICE ABOUT THE JBIG ALGORITHM:
JBIG-KIT is an optional dependency for SpliX, but it seems that parts of this
algorithm was previously or is still patented. To disable the use of JBIG, add
diff --git a/system/splix/splix.SlackBuild b/system/splix/splix.SlackBuild
index 3bc19027b8..5672e06973 100644
--- a/system/splix/splix.SlackBuild
+++ b/system/splix/splix.SlackBuild
@@ -4,7 +4,7 @@
# Written by Iskar Enev <iskar.enev[@]gmail.com>
PRGNAM=splix
-VERSION=1.1.1
+VERSION=2.0.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -16,13 +16,16 @@ OUTPUT=${OUTPUT:-/tmp}
CUPSCFLAGS=$(cups-config --cflags)
CUPSLDFLAGS=$(cups-config --ldflags)
-CUPSFILTER=$(cups-config --serverbin)/filter
-CUPSMODEL=$(cups-config --datadir)/model
+CUPSLIBS=$(cups-config --libs)
+CUPSSERVERBIN=$(cups-config --serverbin)
+CUPSDATADIR=$(cups-config --datadir)
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
# Whether or not to use JBIG (see README)
@@ -40,21 +43,29 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Add DESTDIR support to the Makefile
-patch -p1 < $CWD/Makefile-DESTDIR.diff
+sed -i "s%\`cups-config --cflags\`%$CUPSCFLAGS%" module.mk
+sed -i "s%\`cups-config --ldflags\`%$CUPSLDFLAGS%" module.mk
+sed -i "s%\`cups-config --libs\`%$CUPSLIBS%" module.mk
+sed -i "s%\`cups-config --serverbin\`%$CUPSSERVERBIN%" module.mk
+sed -i "s%\`cups-config --datadir\`%$CUPSDATADIR%" module.mk
-sed -i "s%CXXFLAGS := -O2 \`cups-config --cflags\` %CXXFLAGS := $SLKCFLAGS $CUPSCFLAGS%" Makefile
-sed -i "s%LDFLAGS := \`cups-config --ldflags\`%LDFLAGS := $CUPSLDFLAGS%" Makefile
+make \
+ V=1 \
+ DISABLE_JBIG=$NO_JBIG \
+ OPTIM_CFLAGS="$SLKCFLAGS" \
+ OPTIM_CXXFLAGS="$SLKCFLAGS"
-mkdir -p $PKG$CUPSFILTER
-mkdir -p $PKG$CUPSMODEL
+mkdir -p ${PKG}${CUPSSERVERBIN}/filter ${PKG}${CUPSDATADIR}/model
-make DISABLE_JBIG=$NO_JBIG
-make install DISABLE_JBIG=$NO_JBIG DESTDIR=$PKG
+make install \
+ DISABLE_JBIG=$NO_JBIG \
+ DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/splix/splix.info b/system/splix/splix.info
index 6e00691e6d..4a2bf9d446 100644
--- a/system/splix/splix.info
+++ b/system/splix/splix.info
@@ -1,8 +1,8 @@
PRGNAM="splix"
-VERSION="1.1.1"
+VERSION="2.0.0"
HOMEPAGE="http://splix.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/splix/splix-1.1.1.tar.bz2"
-MD5SUM="13af25dd72aae68b39eaf557d62957a5"
+DOWNLOAD="http://downloads.sourceforge.net/splix/splix-2.0.0.tar.bz2"
+MD5SUM="f3aa735c22a926818b3d8b26c9964186"
MAINTAINER="Iskar Enev"
EMAIL="<iskar.enev[@]gmail.com>"
APPROVED="rworkman"