summaryrefslogtreecommitdiffstats
path: root/system/statifier/statifier.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2018-01-19 15:37:49 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-20 07:01:18 +0700
commit903aa21b7eb609f6478d49a8c2f3f5a8bee45ec7 (patch)
tree2b3dfe3384b62ecf0d841a1db50848258a10ddd8 /system/statifier/statifier.SlackBuild
parent1f8b511d1118e756b64765109aa8fe16dc2f8688 (diff)
downloadslackbuilds-903aa21b7eb609f6478d49a8c2f3f5a8bee45ec7.tar.gz
slackbuilds-903aa21b7eb609f6478d49a8c2f3f5a8bee45ec7.tar.xz
system/statifier: Updated for version 1.7.4, new maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/statifier/statifier.SlackBuild')
-rw-r--r--system/statifier/statifier.SlackBuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/system/statifier/statifier.SlackBuild b/system/statifier/statifier.SlackBuild
index af7b559276..3ce16e8914 100644
--- a/system/statifier/statifier.SlackBuild
+++ b/system/statifier/statifier.SlackBuild
@@ -2,12 +2,21 @@
# Slackware build script for statifier
-# Written by Niels Horn <niels.horn@gmail.com>
-# revision date: 2010/03/13
-# Updated by Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# Written by Niels Horn <email removed>, revision date: 2010/03/13
+# Updated by Willy Sudiarto Raharjo <email removed>
+# Updated again and now maintained by B. Watson <yalhcru@gmail.com>
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20180118 bkw:
+# - take over maintenance.
+# - update for v1.7.4.
+# - grammar nitpicks in README and slack-desc.
+# - add useful info to README, like how to actually get this to work.
+# - add patch to help the user remember to disable VDSO.
PRGNAM=statifier
-VERSION=${VERSION:-1.7.2}
+VERSION=${VERSION:-1.7.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -31,7 +40,6 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -46,14 +54,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
# We need to patch config.x86_64 because Slackware64 is not multi-lib and we
# only have the 32-bits libraries
patch -p1 < $CWD/64pure.patch
+# If VDSO is enabled, print a warning and directions on how to disable it.
+patch -p1 < $CWD/detect_vdso.diff
+
# "usr/lib/" is hardcoded in the Makefile...
sed -i "s,usr/lib/,usr/lib${LIBDIRSUFFIX}/," src/Makefile
# And in the startup script...
@@ -68,15 +79,13 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+gzip $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS ChangeLog FAQ INSTALL LICENSE NEWS README RELEASE THANKS \
- TODO VERSION doc $PKG/usr/doc/$PRGNAM-$VERSION
+ AUTHORS ChangeLog FAQ INSTALL LICENSE NEWS \
+ README RELEASE THANKS TODO VERSION doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install