summaryrefslogtreecommitdiffstats
path: root/system/steamos-xpad/Makefile
diff options
context:
space:
mode:
author Erik Hanson <erik@slackbuilds.org>2015-07-02 23:12:23 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-04 10:38:17 +0700
commit753344da68e5d7afa9890522d998ff9cb25a2de5 (patch)
tree732785cfe600fcd5eecb17b57106978e60862794 /system/steamos-xpad/Makefile
parente88d60dd24cebcabe5fc105090732875281ffc0a (diff)
downloadslackbuilds-753344da68e5d7afa9890522d998ff9cb25a2de5.tar.gz
slackbuilds-753344da68e5d7afa9890522d998ff9cb25a2de5.tar.xz
system/steamos-xpad: Added (SteamOS patched xpad kernel driver).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/steamos-xpad/Makefile')
-rw-r--r--system/steamos-xpad/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/system/steamos-xpad/Makefile b/system/steamos-xpad/Makefile
new file mode 100644
index 0000000000..97907b3967
--- /dev/null
+++ b/system/steamos-xpad/Makefile
@@ -0,0 +1,7 @@
+obj-m = steamos-xpad.o
+
+KVERSION = $(shell uname -r)
+all:
+ make -C /lib/modules/$(KVERSION)/build V=1 M=$(PWD) modules
+clean:
+ test ! -d /lib/modules/$(KVERSION) || make -C /lib/modules/$(KVERSION)/build V=1 M=$(PWD) clean