summaryrefslogtreecommitdiffstats
path: root/system/tabbed
diff options
context:
space:
mode:
author Nikolay Korotkiy <sikmir@gmail.com>2012-04-29 21:01:24 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-04-30 00:40:08 -0500
commit1be3caa035b386114a2c900edd544f0d5be674c1 (patch)
treea53c45113c5c6fc906ad2cfb55b1d36ff39efc93 /system/tabbed
parent2f5de6ed661967e599a63a476c90df1c9c6d4d4a (diff)
downloadslackbuilds-1be3caa035b386114a2c900edd544f0d5be674c1.tar.gz
slackbuilds-1be3caa035b386114a2c900edd544f0d5be674c1.tar.xz
system/tabbed: Added (simple Xembed container manager)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/tabbed')
-rw-r--r--system/tabbed/README2
-rw-r--r--system/tabbed/README.SBo21
-rw-r--r--system/tabbed/slack-desc19
-rw-r--r--system/tabbed/tabbed.SlackBuild107
-rw-r--r--system/tabbed/tabbed.info10
5 files changed, 159 insertions, 0 deletions
diff --git a/system/tabbed/README b/system/tabbed/README
new file mode 100644
index 0000000000..8c122a748b
--- /dev/null
+++ b/system/tabbed/README
@@ -0,0 +1,2 @@
+Simple generic tabbed fronted to xembed aware applications, originally designed
+for surf but also usable with many other application, i.e. uzbl, urxvt and xterm
diff --git a/system/tabbed/README.SBo b/system/tabbed/README.SBo
new file mode 100644
index 0000000000..4f75e19d11
--- /dev/null
+++ b/system/tabbed/README.SBo
@@ -0,0 +1,21 @@
+ CUSTOMIZATION
+-------------
+Place patches in patches/ . Any files in this directory will be
+applied before the build. If you wish to make changes to the default
+keybindings or other settings, produce a patch against config.h.
+config.h is a copy of config.def.h distributed with the source
+tarball.
+
+Place any patches in the patches/ directory before starting the
+SlackBuild script.
+
+Example:
+
+$ tar xvf tabbed-0.3.tar.gz
+$ cd tabbed-0.3
+$ cp config.def.h config.h
+$ vi config.h
+[make customizations]
+$ diff -u config.def.h config.h > ../patches/config.patch
+$ cd ..
+$ sh tabbed.SlackBuild
diff --git a/system/tabbed/slack-desc b/system/tabbed/slack-desc
new file mode 100644
index 0000000000..4a8ac09ede
--- /dev/null
+++ b/system/tabbed/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tabbed: tabbed (simple Xembed container manager)
+tabbed:
+tabbed: tabbed is a simple Xembed container manager based on Xlib.
+tabbed:
+tabbed: Homepage: http://tools.suckless.org/tabbed
+tabbed:
+tabbed:
+tabbed:
+tabbed:
+tabbed:
+tabbed:
diff --git a/system/tabbed/tabbed.SlackBuild b/system/tabbed/tabbed.SlackBuild
new file mode 100644
index 0000000000..74e5270ade
--- /dev/null
+++ b/system/tabbed/tabbed.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for tabbed
+
+# Copyright (c) 2012, Nikolay Korotkiy <sikmir@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY Tom Canich ''AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL Tom Canich BE LIABLE FOR
+# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+# IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tabbed
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Now apply any other patches that users might have added
+for i in $(ls $CWD/patches); do
+ echo "Applying patch $i"
+ patch -p0 < $CWD/patches/$i
+done
+
+sed \
+ -e 's|/usr/local|/usr|g' \
+ -e "s|^CFLAGS.*|CFLAGS += $SLKCFLAGS -std=c99 -pedantic -Wall \${INCS} \${CPPFLAGS}|g" \
+ -e 's|^LDFLAGS.*|LDFLAGS += ${LIBS}|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e 's|share/man|man|g' \
+ -e '/^CC/d' \
+ -i config.mk
+
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README.SBo > $PKG/usr/doc/$PRGNAM-$VERSION/README.SBo
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
+cp -r $CWD/patches $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/tabbed/tabbed.info b/system/tabbed/tabbed.info
new file mode 100644
index 0000000000..d3d37b3e09
--- /dev/null
+++ b/system/tabbed/tabbed.info
@@ -0,0 +1,10 @@
+PRGNAM="tabbed"
+VERSION="0.3"
+HOMEPAGE="http://tools.suckless.org/tabbed"
+DOWNLOAD="http://dl.suckless.org/tools/tabbed-0.3.tar.gz"
+MD5SUM="4a30458f9adc38db549f735b8fb6451b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Nikolay Korotkiy"
+EMAIL="sikmir@gmail.com"
+APPROVED="dsomero"