summaryrefslogtreecommitdiffstats
path: root/system/targetcli-fb
diff options
context:
space:
mode:
author Zach Lewis <koni@archlinux.us>2016-12-06 01:20:24 +0000
committer David Spencer <idlemoor@slackbuilds.org>2016-12-10 00:57:38 +0000
commitd68691ad6d68f7fa6a5cdb19a0013de985a71bc7 (patch)
tree8009f7da1d93965e86b788ac1b6792df9491eef2 /system/targetcli-fb
parent449c6489c099901df685b60a9852d24aa609edfe (diff)
downloadslackbuilds-d68691ad6d68f7fa6a5cdb19a0013de985a71bc7.tar.gz
slackbuilds-d68691ad6d68f7fa6a5cdb19a0013de985a71bc7.tar.xz
system/targetcli-fb: Added (Linux LIO kernel target shell).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/targetcli-fb')
-rw-r--r--system/targetcli-fb/README12
-rw-r--r--system/targetcli-fb/slack-desc19
-rw-r--r--system/targetcli-fb/targetcli-fb.SlackBuild110
-rw-r--r--system/targetcli-fb/targetcli-fb.info14
4 files changed, 155 insertions, 0 deletions
diff --git a/system/targetcli-fb/README b/system/targetcli-fb/README
new file mode 100644
index 0000000000..0aaaa8ca72
--- /dev/null
+++ b/system/targetcli-fb/README
@@ -0,0 +1,12 @@
+targetcli-fb is a command-line interface for configuring the LIO
+generic SCSI target, present in 3.x Linux kernel versions and up.
+
+This package is the community fork or "Free Branch" of the original
+Datera/RisingTide package. It installs two additional python libraries:
+configshell-fb and rtslib-fb.
+
+If you already have the Datera/RisingTide version installed, it will be
+overwritten. Please ensure you have a backup if you want to keep it.
+
+Ensure these kernel modules are loaded:
+ target_core_mod, iscsi_target_mod
diff --git a/system/targetcli-fb/slack-desc b/system/targetcli-fb/slack-desc
new file mode 100644
index 0000000000..d3968c5120
--- /dev/null
+++ b/system/targetcli-fb/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+targetcli-fb: targetcli-fb (Linux LIO kernel target shell)
+targetcli-fb:
+targetcli-fb: targetcli-fb is a command-line interface for configuring the LIO
+targetcli-fb: generic SCSI target, present in 3.x Linux kernel versions and up.
+targetcli-fb: This package installs two additional custom python libraries which
+targetcli-fb: are required: configshell-fb, rtslib-fb
+targetcli-fb:
+targetcli-fb:
+targetcli-fb: Github source: https://github.com/open-iscsi/targetcli-fb
+targetcli-fb:
+targetcli-fb:
diff --git a/system/targetcli-fb/targetcli-fb.SlackBuild b/system/targetcli-fb/targetcli-fb.SlackBuild
new file mode 100644
index 0000000000..0c6e63da01
--- /dev/null
+++ b/system/targetcli-fb/targetcli-fb.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/sh
+
+# Slackware build script for targetcli-fb
+
+# Copyright 2016 Zach Lewis koni@archlinux.us
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=targetcli-fb
+VERSION=${VERSION:-2.1.fb44}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Declaring for other rtslib and configshell
+RTSLIB=rtslib-fb-2.1.fb61
+CONFIGSHELL=configshell-fb-1.1.fb21
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+
+# Extract other python libs
+tar xvf $CWD/$RTSLIB.tar.gz
+tar xvf $CWD/$CONFIGSHELL.tar.gz
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# RTSLIB
+cd $TMP/$PRGNAM-$VERSION/$RTSLIB
+python setup.py install --root=$PKG
+
+# CONFIGSHELL
+cd $TMP/$PRGNAM-$VERSION/$CONFIGSHELL
+python setup.py install --root=$PKG
+
+# TARGETCLI-FB
+cd $TMP/$PRGNAM-$VERSION
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man/man{5,8}
+gzip < targetcli.8 > $PKG/usr/man/man8/targetcli.8.gz
+gzip < $RTSLIB/doc/saveconfig.json.5 > $PKG/usr/man/man5/saveconfig.json.5.gz
+gzip < $RTSLIB/doc/targetctl.8 > $PKG/usr/man/man8/targetctl.8.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md THANKS $RTSLIB/doc/getting_started.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/targetcli-fb/targetcli-fb.info b/system/targetcli-fb/targetcli-fb.info
new file mode 100644
index 0000000000..8131ad9860
--- /dev/null
+++ b/system/targetcli-fb/targetcli-fb.info
@@ -0,0 +1,14 @@
+PRGNAM="targetcli-fb"
+VERSION="2.1.fb44"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+DOWNLOAD="https://fedorahosted.org/releases/t/a/targetcli-fb/targetcli-fb-2.1.fb44.tar.gz \
+ https://fedorahosted.org/releases/t/a/targetcli-fb/rtslib-fb-2.1.fb61.tar.gz \
+ https://fedorahosted.org/releases/t/a/targetcli-fb/configshell-fb-1.1.fb21.tar.gz"
+MD5SUM="2f62037545947b20e1c2945b3860c9d6 \
+ 4182274dc9f4ad1215cea03ce29b6d1c \
+ d741142e288fe5769d05602bef1b8c76"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyudev pyparsing"
+MAINTAINER="Zach Lewis"
+EMAIL="koni@archlinux.us"