summaryrefslogtreecommitdiffstats
path: root/system/terminator
diff options
context:
space:
mode:
author Alan <alan@yggdrasil.net>2016-06-25 09:46:57 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-27 07:54:40 +0700
commit4f5c1d9e374dbee330d79688afa7441847d4d8b1 (patch)
tree5746a121ca521f9080063e863012a5ab68307b46 /system/terminator
parentd03a0469285ab992385b5ae92366cc2cf7488fbe (diff)
downloadslackbuilds-4f5c1d9e374dbee330d79688afa7441847d4d8b1.tar.gz
slackbuilds-4f5c1d9e374dbee330d79688afa7441847d4d8b1.tar.xz
system/terminator: Updated for version 0.98.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/terminator')
-rw-r--r--system/terminator/terminator.SlackBuild77
-rw-r--r--system/terminator/terminator.info6
2 files changed, 51 insertions, 32 deletions
diff --git a/system/terminator/terminator.SlackBuild b/system/terminator/terminator.SlackBuild
index 6a82f5677d..ddfa0e7a83 100644
--- a/system/terminator/terminator.SlackBuild
+++ b/system/terminator/terminator.SlackBuild
@@ -2,38 +2,36 @@
# Slackware build script for terminator
-# Copyright (c) 2009 Alan Alberghini <414N@slacky.it>
+# Copyright 2016 Alan Alberghini <414N@slacky.it>
# All rights reserved.
#
-# Permission to use, copy, modify, and distribute this software for
-# any purpose with or without fee is hereby granted, provided that
-# the above copyright notice and this permission notice appear in all
-# copies.
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
#
-# THIS SOFTWARE IS PROVIDED AS IS'' AND ANY EXPRESSED OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
-# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
-# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
-# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
-# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-# SUCH DAMAGE.
-# -----------------------------------------------------------------------------
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
# Build history:
#
# 1 - Initial release.
# 20120206 - Updated for version 0.96
# 20120916 - Removed icon-theme.cache from the package
# 20130530 - Updated for version 0.97
-
+# 20160625 - Updated for version 0.98 (thanks to Andrzej Telszewski)
PRGNAM=terminator
-VERSION=${VERSION:-0.97}
+VERSION=${VERSION:-0.98}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,7 +48,21 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="INSTALL README ChangeLog"
+DOCS="INSTALL COPYING RELEASING README ChangeLog"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
set -e
@@ -62,19 +74,26 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-./setup.py --without-icon-cache install --prefix=$PKG/usr -O2
+# Adjust doc location.
+sed -i "s|'share', 'doc', 'terminator'|'doc', '$PRGNAM-$VERSION'|g" setup.py
+sed -i "s|'share', 'doc', 'terminator'|'doc', '$PRGNAM-$VERSION'|g" terminatorlib/util.py
+# Adjust man location.
+sed -i "s|share/man|man|g" setup.py
+
+CFLAGS=$SLKCFLAGS \
+./setup.py --no-user-cfg --without-icon-cache install --prefix=/usr --root=$PKG
+
+rm $PKG/usr/doc/$PRGNAM-$VERSION/apidoc/.buildinfo
+rm $PKG/usr/doc/$PRGNAM-$VERSION/html/.buildinfo
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Need to adjust mandir location
-mv $PKG/usr/share/man $PKG/usr/man
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
diff --git a/system/terminator/terminator.info b/system/terminator/terminator.info
index c684ffed75..db3ac62b12 100644
--- a/system/terminator/terminator.info
+++ b/system/terminator/terminator.info
@@ -1,8 +1,8 @@
PRGNAM="terminator"
-VERSION="0.97"
+VERSION="0.98"
HOMEPAGE="https://launchpad.net/terminator/"
-DOWNLOAD="http://launchpad.net/terminator/trunk/0.97/+download/terminator-0.97.tar.gz"
-MD5SUM="2b32b59c0a5ed2bee45cc57cf861f4d8"
+DOWNLOAD="https://launchpad.net/terminator/trunk/0.98/+download/terminator-0.98.tar.gz"
+MD5SUM="241af292fe16bed290052b86adb30b80"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""