summaryrefslogtreecommitdiffstats
path: root/system/terminator
diff options
context:
space:
mode:
author Alan Alberghini <414N@slacky.it>2012-12-16 17:44:04 -0500
committer dsomero <xgizzmo@slackbuilds.org>2012-12-23 09:16:35 -0500
commit4fad2ddac03f43322130bbcada1222846f18f4cc (patch)
tree779b3ae2ded38a081d806fb89e3b9ee6b568259a /system/terminator
parent6039876007b05e3a38274517db05628f65d30793 (diff)
downloadslackbuilds-4fad2ddac03f43322130bbcada1222846f18f4cc.tar.gz
slackbuilds-4fad2ddac03f43322130bbcada1222846f18f4cc.tar.xz
system/terminator: Don't include icon-theme.cache files.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/terminator')
-rw-r--r--system/terminator/README2
-rw-r--r--system/terminator/terminator.SlackBuild11
2 files changed, 7 insertions, 6 deletions
diff --git a/system/terminator/README b/system/terminator/README
index 03ab11616f..5a7a022fe2 100644
--- a/system/terminator/README
+++ b/system/terminator/README
@@ -2,3 +2,5 @@ The goal of this project is to produce a useful tool for arranging terminals.
It is inspired by programs such as gnome-multi-term, quadkonsole, etc. in that
the main focus is arranging terminals in grids (tabs is the most common default
method, which Terminator also supports).
+
+Optionally requires keybinder, which is available on SBo
diff --git a/system/terminator/terminator.SlackBuild b/system/terminator/terminator.SlackBuild
index 60944da9fe..1961d69169 100644
--- a/system/terminator/terminator.SlackBuild
+++ b/system/terminator/terminator.SlackBuild
@@ -28,6 +28,7 @@
#
# 1 - Initial release.
# 20120206 - Updated for version 0.96
+# 20120916 - Removed icon-theme.cache from the package
PRGNAM=terminator
VERSION=${VERSION:-0.96}
@@ -64,18 +65,16 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-./setup.py install --prefix=$PKG/usr -O2
+./setup.py --without-icon-cache install --prefix=$PKG/usr -O2
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Need to adjust mandir location
mv $PKG/usr/share/man $PKG/usr/man
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION