summaryrefslogtreecommitdiffstats
path: root/system/xen/patches
diff options
context:
space:
mode:
author Mario Preksavec <mario@slackware.hr>2015-03-15 23:10:28 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-22 15:33:25 +0700
commitb7b30fc19a3678820cf38eeffa8e5aac37149594 (patch)
treec78dbc6328bca1c2976ebf548bfc04eea9d2a623 /system/xen/patches
parent1e301e41ee5c82fda47438d878b48c3af4691985 (diff)
downloadslackbuilds-b7b30fc19a3678820cf38eeffa8e5aac37149594.tar.gz
slackbuilds-b7b30fc19a3678820cf38eeffa8e5aac37149594.tar.xz
system/xen: Updated for version 4.5.0 and more.
Diffstat (limited to 'system/xen/patches')
-rw-r--r--system/xen/patches/configuration_goes_to_system_etc.diff10
-rw-r--r--system/xen/patches/disable_git_checkout.diff42
-rw-r--r--system/xen/patches/libcacard_fix_parallel_compile.patch13
-rw-r--r--system/xen/patches/local_attach_support_for_phy.patch14
-rw-r--r--system/xen/patches/qemu_configure_options.diff12
-rw-r--r--system/xen/patches/remove_obsolete_udev_rules.diff10
-rw-r--r--system/xen/patches/use_already_present_seabios.diff11
-rw-r--r--system/xen/patches/xsa119-unstable.patch99
8 files changed, 173 insertions, 38 deletions
diff --git a/system/xen/patches/configuration_goes_to_system_etc.diff b/system/xen/patches/configuration_goes_to_system_etc.diff
deleted file mode 100644
index 07e673d195..0000000000
--- a/system/xen/patches/configuration_goes_to_system_etc.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- xen-4.2.0/tools/Makefile.ORIG 2012-09-17 12:21:18.000000000 +0200
-+++ xen-4.2.0/tools/Makefile 2012-09-18 13:37:55.410462850 +0200
-@@ -200,6 +200,7 @@
- --datadir=$(SHAREDIR)/qemu-xen \
- --disable-kvm \
- --python=$(PYTHON) \
-+ --sysconfdir=/etc \
- $(IOEMU_CONFIGURE_CROSS); \
- $(MAKE) all
-
diff --git a/system/xen/patches/disable_git_checkout.diff b/system/xen/patches/disable_git_checkout.diff
new file mode 100644
index 0000000000..54738c348d
--- /dev/null
+++ b/system/xen/patches/disable_git_checkout.diff
@@ -0,0 +1,42 @@
+--- xen-4.5.0/tools/Makefile.orig 2015-01-12 17:53:24.000000000 +0100
++++ xen-4.5.0/tools/Makefile 2015-02-16 10:12:09.487338727 +0100
+@@ -134,17 +134,17 @@
+ set -ex; \
+ if test -d $(QEMU_TRADITIONAL_LOC); then \
+ mkdir -p qemu-xen-traditional-dir; \
+- else \
+- export GIT=$(GIT); \
+- $(XEN_ROOT)/scripts/git-checkout.sh $(QEMU_TRADITIONAL_LOC) $(QEMU_TRADITIONAL_REVISION) qemu-xen-traditional-dir; \
++# else \
++# export GIT=$(GIT); \
++# $(XEN_ROOT)/scripts/git-checkout.sh $(QEMU_TRADITIONAL_LOC) $(QEMU_TRADITIONAL_REVISION) qemu-xen-traditional-dir; \
+ fi
+
+ qemu-xen-dir-find:
+ if test -d $(QEMU_UPSTREAM_LOC) ; then \
+ mkdir -p qemu-xen-dir; \
+- else \
+- export GIT=$(GIT); \
+- $(XEN_ROOT)/scripts/git-checkout.sh $(QEMU_UPSTREAM_LOC) $(QEMU_UPSTREAM_REVISION) qemu-xen-dir ; \
++# else \
++# export GIT=$(GIT); \
++# $(XEN_ROOT)/scripts/git-checkout.sh $(QEMU_UPSTREAM_LOC) $(QEMU_UPSTREAM_REVISION) qemu-xen-dir ; \
+ fi
+
+ .PHONY: qemu-xen-traditional-dir-force-update
+--- xen-4.5.0/tools/firmware/Makefile.orig 2015-01-12 17:53:24.000000000 +0100
++++ xen-4.5.0/tools/firmware/Makefile 2015-02-16 10:12:27.276869964 +0100
+@@ -20,11 +20,11 @@
+ LD32BIT-$(CONFIG_FreeBSD) := LD32BIT_FLAG=-melf_i386_fbsd
+
+ ovmf-dir:
+- GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(OVMF_UPSTREAM_URL) $(OVMF_UPSTREAM_REVISION) ovmf-dir
++# GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(OVMF_UPSTREAM_URL) $(OVMF_UPSTREAM_REVISION) ovmf-dir
+ cp ovmf-makefile ovmf-dir/Makefile;
+
+ seabios-dir:
+- GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_REVISION) seabios-dir
++# GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_REVISION) seabios-dir
+ $(MAKE) -C seabios-dir defconfig
+
+ .PHONY: all
diff --git a/system/xen/patches/libcacard_fix_parallel_compile.patch b/system/xen/patches/libcacard_fix_parallel_compile.patch
new file mode 100644
index 0000000000..1dfd044518
--- /dev/null
+++ b/system/xen/patches/libcacard_fix_parallel_compile.patch
@@ -0,0 +1,13 @@
+--- xen-4.5.0/tools/qemu-xen/libcacard/Makefile.orig 2014-12-02 11:41:02.000000000 +0100
++++ xen-4.5.0/tools/qemu-xen/libcacard/Makefile 2015-03-14 21:05:54.361325689 +0100
+@@ -26,8 +26,8 @@
+ libcacard.la: LDFLAGS += -rpath $(libdir) -no-undefined \
+ -export-syms $(SRC_PATH)/libcacard/libcacard.syms
+ libcacard.la: LIBS = $(libcacard_libs)
+-libcacard.la: $(libcacard-lobj-y)
+- $(call LINK,$^)
++libcacard.la: $(libcacard-obj-y)
++ $(call LINK,$(libcacard-lobj-y))
+
+ libcacard.pc: $(SRC_PATH)/libcacard/libcacard.pc.in
+ $(call quiet-command,sed -e 's|@LIBDIR@|$(libdir)|' \
diff --git a/system/xen/patches/local_attach_support_for_phy.patch b/system/xen/patches/local_attach_support_for_phy.patch
index 41fe639845..5dd402d364 100644
--- a/system/xen/patches/local_attach_support_for_phy.patch
+++ b/system/xen/patches/local_attach_support_for_phy.patch
@@ -10,11 +10,11 @@ Date: Wed Feb 12 11:15:17 2014 +0100
Suggested-by: Ian Campbell <ian.campbell@xxxxxxxxxx>
-Index: xen-4.3.2-testing/tools/libxl/libxl.c
+Index: xen-4.5.0-testing/tools/libxl/libxl.c
===================================================================
---- xen-4.3.2-testing.orig/tools/libxl/libxl.c
-+++ xen-4.3.2-testing/tools/libxl/libxl.c
-@@ -2604,6 +2604,16 @@ void libxl__device_disk_local_initiate_a
+--- xen-4.5.0-testing.orig/tools/libxl/libxl.c
++++ xen-4.5.0-testing/tools/libxl/libxl.c
+@@ -3006,6 +3006,16 @@ void libxl__device_disk_local_initiate_a
switch (disk->backend) {
case LIBXL_DISK_BACKEND_PHY:
@@ -31,7 +31,7 @@ Index: xen-4.3.2-testing/tools/libxl/libxl.c
LIBXL__LOG(ctx, LIBXL__LOG_DEBUG, "locally attaching PHY disk %s",
disk->pdev_path);
dev = disk->pdev_path;
-@@ -2683,7 +2693,7 @@ static void local_device_attach_cb(libxl
+@@ -3085,7 +3095,7 @@ static void local_device_attach_cb(libxl
}
dev = GCSPRINTF("/dev/%s", disk->vdev);
@@ -40,7 +40,7 @@ Index: xen-4.3.2-testing/tools/libxl/libxl.c
rc = libxl__device_from_disk(gc, LIBXL_TOOLSTACK_DOMID, disk, &device);
if (rc < 0)
-@@ -2723,6 +2733,7 @@ void libxl__device_disk_local_initiate_d
+@@ -3125,6 +3135,7 @@ void libxl__device_disk_local_initiate_d
if (!dls->diskpath) goto out;
switch (disk->backend) {
@@ -48,7 +48,7 @@ Index: xen-4.3.2-testing/tools/libxl/libxl.c
case LIBXL_DISK_BACKEND_QDISK:
if (disk->vdev != NULL) {
GCNEW(device);
-@@ -2740,7 +2751,6 @@ void libxl__device_disk_local_initiate_d
+@@ -3142,7 +3153,6 @@ void libxl__device_disk_local_initiate_d
/* disk->vdev == NULL; fall through */
default:
/*
diff --git a/system/xen/patches/qemu_configure_options.diff b/system/xen/patches/qemu_configure_options.diff
new file mode 100644
index 0000000000..f15cd5bfa7
--- /dev/null
+++ b/system/xen/patches/qemu_configure_options.diff
@@ -0,0 +1,12 @@
+--- xen-4.5.0/tools/Makefile.orig 2015-01-12 17:53:24.000000000 +0100
++++ xen-4.5.0/tools/Makefile 2015-02-16 09:19:18.999816844 +0100
+@@ -225,6 +225,9 @@
+ --disable-docs \
+ --disable-guest-agent \
+ --python=$(PYTHON) \
++ --sysconfdir=/etc \
++ --@@LIBSSH2@@able-libssh2 \
++ --@@BLUEZ@@able-bluez \
+ $(CONFIG_QEMUU_EXTRA_ARGS) \
+ --cpu=$(IOEMU_CPU_ARCH) \
+ $(IOEMU_CONFIGURE_CROSS); \
diff --git a/system/xen/patches/remove_obsolete_udev_rules.diff b/system/xen/patches/remove_obsolete_udev_rules.diff
deleted file mode 100644
index f439183131..0000000000
--- a/system/xen/patches/remove_obsolete_udev_rules.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- xen-4.2.1/tools/hotplug/Linux/xend.rules.ORIG 2012-12-17 16:00:35.000000000 +0100
-+++ xen-4.2.1/tools/hotplug/Linux/xend.rules 2013-03-01 04:26:34.247176457 +0100
-@@ -1,4 +1,4 @@
--SUBSYSTEM=="pci", RUN+="socket:/org/xen/xend/udev_event"
--SUBSYSTEM=="scsi", RUN+="socket:/org/xen/xend/udev_event"
--SUBSYSTEM=="usb", RUN+="socket:/org/xen/xend/udev_event"
-+#SUBSYSTEM=="pci", RUN+="socket:/org/xen/xend/udev_event"
-+#SUBSYSTEM=="scsi", RUN+="socket:/org/xen/xend/udev_event"
-+#SUBSYSTEM=="usb", RUN+="socket:/org/xen/xend/udev_event"
- #SUBSYSTEM=="net", KERNEL!="vif[0-9]*.[0-9]*|tap[0-9]*.[0-9]*", RUN+="socket:/org/xen/xend/udev_event"
diff --git a/system/xen/patches/use_already_present_seabios.diff b/system/xen/patches/use_already_present_seabios.diff
deleted file mode 100644
index a73dba9f02..0000000000
--- a/system/xen/patches/use_already_present_seabios.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- xen-4.3.1/tools/firmware/Makefile.ORIG 2013-10-30 09:18:28.000000000 +0100
-+++ xen-4.3.1/tools/firmware/Makefile 2013-11-04 12:28:10.056796654 +0100
-@@ -18,7 +18,7 @@
- cp ovmf-makefile ovmf/Makefile;
-
- seabios-dir:
-- GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_TAG) seabios-dir
-+# GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_TAG) seabios-dir
- cp seabios-config seabios-dir/.config;
-
- .PHONY: all
diff --git a/system/xen/patches/xsa119-unstable.patch b/system/xen/patches/xsa119-unstable.patch
new file mode 100644
index 0000000000..f696eb5b6e
--- /dev/null
+++ b/system/xen/patches/xsa119-unstable.patch
@@ -0,0 +1,99 @@
+From f433bfafbaf7d8a41c4c27aa3e8e78b1ab900b69 Mon Sep 17 00:00:00 2001
+From: Ian Campbell <ian.campbell@citrix.com>
+Date: Fri, 20 Feb 2015 14:41:09 +0000
+Subject: [PATCH] tools: libxl: Explicitly disable graphics backends on qemu
+ cmdline
+
+By default qemu will try to create some sort of backend for the
+emulated VGA device, either SDL or VNC.
+
+However when the user specifies sdl=0 and vnc=0 in their configuration
+libxl was not explicitly disabling either backend, which could lead to
+one unexpectedly running.
+
+If either sdl=1 or vnc=1 is configured then both before and after this
+change only the backends which are explicitly enabled are configured,
+i.e. this issue only occurs when all backends are supposed to have
+been disabled.
+
+This affects qemu-xen and qemu-xen-traditional differently.
+
+If qemu-xen was compiled with SDL support then this would result in an
+SDL window being opened if $DISPLAY is valid, or a failure to start
+the guest if not. Passing "-display none" to qemu before any further
+-sdl options disables this default behaviour and ensures that SDL is
+only started if the libxl configuration demands it.
+
+If qemu-xen was compiled without SDL support then qemu would instead
+start a VNC server listening on ::1 (IPv6 localhost) or 127.0.0.1
+(IPv4 localhost) with IPv6 preferred if available. Explicitly pass
+"-vnc none" when vnc is not enabled in the libxl configuration to
+remove this possibility.
+
+qemu-xen-traditional would never start a vnc backend unless asked.
+However by default it will start an SDL backend, the way to disable
+this is to pass a -vnc option. In other words passing "-vnc none" will
+disable both vnc and sdl by default. sdl can then be reenabled if
+configured by subsequent use of the -sdl option.
+
+Tested with both qemu-xen and qemu-xen-traditional built with SDL
+support and:
+ xl cr # defaults
+ xl cr sdl=0 vnc=0
+ xl cr sdl=1 vnc=0
+ xl cr sdl=0 vnc=1
+ xl cr sdl=0 vnc=0 vga=\"none\"
+ xl cr sdl=0 vnc=0 nographic=1
+with both valid and invalid $DISPLAY.
+
+This is XSA-119.
+
+Reported-by: Sander Eikelenboom <linux@eikelenboom.it>
+Signed-off-by: Ian Campbell <ian.campbell@citrix.com>
+Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
+---
+ tools/libxl/libxl_dm.c | 21 +++++++++++++++++++--
+ 1 file changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/tools/libxl/libxl_dm.c b/tools/libxl/libxl_dm.c
+index 8599a6a..3b918c6 100644
+--- a/tools/libxl/libxl_dm.c
++++ b/tools/libxl/libxl_dm.c
+@@ -180,7 +180,14 @@ static char ** libxl__build_device_model_args_old(libxl__gc *gc,
+ if (libxl_defbool_val(vnc->findunused)) {
+ flexarray_append(dm_args, "-vncunused");
+ }
+- }
++ } else
++ /*
++ * VNC is not enabled by default by qemu-xen-traditional,
++ * however passing -vnc none causes SDL to not be
++ * (unexpectedly) enabled by default. This is overridden by
++ * explicitly passing -sdl below as required.
++ */
++ flexarray_append_pair(dm_args, "-vnc", "none");
+
+ if (sdl) {
+ flexarray_append(dm_args, "-sdl");
+@@ -522,7 +529,17 @@ static char ** libxl__build_device_model_args_new(libxl__gc *gc,
+ }
+
+ flexarray_append(dm_args, vncarg);
+- }
++ } else
++ /*
++ * Ensure that by default no vnc server is created.
++ */
++ flexarray_append_pair(dm_args, "-vnc", "none");
++
++ /*
++ * Ensure that by default no display backend is created. Further
++ * options given below might then enable more.
++ */
++ flexarray_append_pair(dm_args, "-display", "none");
+
+ if (sdl) {
+ flexarray_append(dm_args, "-sdl");
+--
+2.1.4
+