summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Alan Alberghini <414N@slacky.it>2010-04-16 22:13:08 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-15 10:38:12 +0200
commit07997e1b7c261b244517a5d96bb3f8fc2caec3a4 (patch)
tree02c245c616ea24e7513b236505448233e0713095 /system
parentca3ad7aae610924fc2de2c746ca6a9d2e31167ab (diff)
downloadslackbuilds-07997e1b7c261b244517a5d96bb3f8fc2caec3a4.tar.gz
slackbuilds-07997e1b7c261b244517a5d96bb3f8fc2caec3a4.tar.xz
system/terminator: Added (useful tool for arranging terminals)
Diffstat (limited to 'system')
-rw-r--r--system/terminator/README4
-rw-r--r--system/terminator/slack-desc19
-rw-r--r--system/terminator/terminator.SlackBuild80
-rw-r--r--system/terminator/terminator.info10
4 files changed, 113 insertions, 0 deletions
diff --git a/system/terminator/README b/system/terminator/README
new file mode 100644
index 0000000000..cb220042a7
--- /dev/null
+++ b/system/terminator/README
@@ -0,0 +1,4 @@
+The goal of this project is to produce a useful tool for arranging terminals.
+
+All you need to use terminator is a Python 2.x installation.
+Tested with the one shipped in Slackware 13.0.
diff --git a/system/terminator/slack-desc b/system/terminator/slack-desc
new file mode 100644
index 0000000000..b0bafe303e
--- /dev/null
+++ b/system/terminator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |----handy-ruler--------------------------------------------------------|
+terminator: terminator (useful tool for arranging terminals)
+terminator:
+terminator: The goal of this project is to produce a useful tool for arranging
+terminator: terminals.
+terminator:
+terminator: Homepage: http://www.tenshu.net/terminator/
+terminator:
+terminator:
+terminator:
+terminator:
+terminator:
diff --git a/system/terminator/terminator.SlackBuild b/system/terminator/terminator.SlackBuild
new file mode 100644
index 0000000000..32d79e028c
--- /dev/null
+++ b/system/terminator/terminator.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for terminator
+
+# Copyright (c) 2009 Alan Alberghini <414N@slacky.it>
+# All rights reserved.
+#
+# Permission to use, copy, modify, and distribute this software for
+# any purpose with or without fee is hereby granted, provided that
+# the above copyright notice and this permission notice appear in all
+# copies.
+#
+# THIS SOFTWARE IS PROVIDED AS IS'' AND ANY EXPRESSED OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+# -----------------------------------------------------------------------------
+#
+# Build history:
+#
+# 1 - Initial release.
+
+PRGNAM=terminator
+VERSION=${VERSION:-0.92}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="INSTALL README ChangeLog"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+./setup.py install --prefix=$PKG/usr -O2
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Need to adjust mandir location
+mv $PKG/usr/share/man $PKG/usr/man
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/terminator/terminator.info b/system/terminator/terminator.info
new file mode 100644
index 0000000000..b3e3b8895a
--- /dev/null
+++ b/system/terminator/terminator.info
@@ -0,0 +1,10 @@
+PRGNAM="terminator"
+VERSION="0.92"
+HOMEPAGE="http://www.tenshu.net/terminator/"
+DOWNLOAD="http://launchpad.net/terminator/trunk/0.92/+download/terminator-0.92.tar.gz"
+MD5SUM="b3bbd041623cad9536ed5ef76aac85f2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Alan Alberghini"
+EMAIL="414N@slacky.it"
+APPROVED="dsomero"