summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Paul Wisehart <wise@lupulin.net>2010-05-11 15:18:44 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 15:18:44 +0200
commit728f17945e7363d9d693f76753598f355c91167e (patch)
tree467518079f4c2a51280982f834f005215047bd0d /system
parent3a93d214a76c222e7287774b16a1a86dfa29f787 (diff)
downloadslackbuilds-728f17945e7363d9d693f76753598f355c91167e.tar.gz
slackbuilds-728f17945e7363d9d693f76753598f355c91167e.tar.xz
system/rdiff-backup: Initial import
Diffstat (limited to 'system')
-rw-r--r--system/rdiff-backup/README16
-rw-r--r--system/rdiff-backup/rdiff-backup.SlackBuild75
-rw-r--r--system/rdiff-backup/rdiff-backup.info8
-rw-r--r--system/rdiff-backup/slack-desc11
4 files changed, 110 insertions, 0 deletions
diff --git a/system/rdiff-backup/README b/system/rdiff-backup/README
new file mode 100644
index 0000000000..0e78f2aadb
--- /dev/null
+++ b/system/rdiff-backup/README
@@ -0,0 +1,16 @@
+rdiff-backup backs up one directory to another, possibly over a
+network. The target directory ends up a copy of the source directory,
+but extra reverse diffs are stored in a special subdirectory of that
+target directory, so you can still recover files lost some time
+ago. The idea is to combine the best features of a mirror and an
+incremental backup. rdiff-backup also preserves subdirectories, hard
+links, dev files, permissions, uid/gid ownership, modification times,
+extended attributes, acls, and resource forks. Also, rdiff-backup
+can operate in a bandwidth efficient manner over a pipe, like
+rsync. Thus you can use rdiff-backup and ssh to securely back a
+hard drive up to a remote location, and only the differences will
+be transmitted. Finally, rdiff-backup is easy to use and settings
+have sensical defaults.
+
+Dependencies: librsync (from slackbuilds.org)
+
diff --git a/system/rdiff-backup/rdiff-backup.SlackBuild b/system/rdiff-backup/rdiff-backup.SlackBuild
new file mode 100644
index 0000000000..b929dcf195
--- /dev/null
+++ b/system/rdiff-backup/rdiff-backup.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for rdiff-backup
+# Copyright (C) 2007 paul wisehart wise@lupulin.net
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+
+PKGNAME=rdiff-backup
+VERSION=1.0.5
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+TMP=${TMP:-/tmp/SBo}
+CWD=$(pwd)
+PKG=$TMP/package-$PKGNAME
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PKGNAME-$VERSION
+tar -xvzf $CWD/$PKGNAME-$VERSION.tar.gz || exit 1
+tar xvzf $CWD/$PKGNAME-$VERSION.tar.gz || exit 1
+cd $PKGNAME-$VERSION || exit 1
+chown -R root:root .
+chmod -R a-s,u+rw,go-w+r .
+
+sed -i 's|share/man/|man/|g' setup.py
+
+python setup.py build
+python setup.py install --prefix=/usr --root=$PKG
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/$PKGNAME-$VERSION $PKG/usr/doc
+cp -a examples.html $PKG/usr/doc/$PKGNAME-$VERSION
+cat $CWD/$PKGNAME.SlackBuild > $PKG/usr/doc/$PKGNAME-$VERSION/$PKGNAME.SlackBuild
+rm -rf $PKG/usr/share
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/rdiff-backup/rdiff-backup.info b/system/rdiff-backup/rdiff-backup.info
new file mode 100644
index 0000000000..af58ae618e
--- /dev/null
+++ b/system/rdiff-backup/rdiff-backup.info
@@ -0,0 +1,8 @@
+PRGNAM="rdiff-backup"
+VERSION="1.0.5"
+HOMEPAGE="http://rdiff-backup.nongnu.org/"
+DOWNLOAD="http://savannah.nongnu.org/download/rdiff-backup/rdiff-backup-1.0.5.tar.gz"
+MD5SUM="fa2a165fa07a94be52c52e3545bc7758"
+MAINTAINER="paul wisehart"
+EMAIL="wise@lupulin.net"
+APPROVED="robw810"
diff --git a/system/rdiff-backup/slack-desc b/system/rdiff-backup/slack-desc
new file mode 100644
index 0000000000..e6bfcc9d63
--- /dev/null
+++ b/system/rdiff-backup/slack-desc
@@ -0,0 +1,11 @@
+rdiff-backup: rdiff-backup
+rdiff-backup:
+rdiff-backup: rdiff-backup backs up one directory to another, possibly over a
+rdiff-backup: network. The target directory ends up a copy of the source
+rdiff-backup: directory, but extra reverse diffs are stored in a special
+rdiff-backup: subdirectory of that target directory, so you can still recover
+rdiff-backup: files lost some time ago. The idea is to combine the best
+rdiff-backup: features of a mirror and an incremental backup.
+rdiff-backup:
+rdiff-backup:
+rdiff-backup: