summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author pyllyukko <pyllyukko AT maimed dot org>2013-06-05 12:03:18 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-06-05 12:03:18 -0400
commit52ef78e897bb46d93458d88762773384a5aa986e (patch)
tree54c12369337f1a3ed1edd80d30f4a3f226000d29 /system
parentc515acb0700c884d6e53d0b20ae186842728f821 (diff)
downloadslackbuilds-52ef78e897bb46d93458d88762773384a5aa986e.tar.gz
slackbuilds-52ef78e897bb46d93458d88762773384a5aa986e.tar.xz
system/tiger: Updated with a few bug fixing patches.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/tiger/README.SLACKWARE24
-rw-r--r--system/tiger/patches/9a030129ceceba715dff801f8229e66de62a8083.patch13
-rw-r--r--system/tiger/patches/check_signatures.patch12
-rw-r--r--system/tiger/patches/mkfilelst.patch12
-rw-r--r--system/tiger/patches/tiger-aide.patch30
-rw-r--r--system/tiger/patches/tiger-makefile.patch25
-rw-r--r--system/tiger/patches/tiger-sha512-1.patch34
-rw-r--r--system/tiger/patches/zappasswd-3.2.3.patch38
-rw-r--r--system/tiger/patches/zappasswd.patch40
-rw-r--r--system/tiger/slack-desc10
-rw-r--r--system/tiger/tiger.SlackBuild21
11 files changed, 251 insertions, 8 deletions
diff --git a/system/tiger/README.SLACKWARE b/system/tiger/README.SLACKWARE
new file mode 100644
index 0000000000..88705325fe
--- /dev/null
+++ b/system/tiger/README.SLACKWARE
@@ -0,0 +1,24 @@
+In order for the Tiger_Check_PERMS and Tiger_Check_SIGNATURES checks to work
+correctly, you need to generate a Slackware specific baseline for them. You can
+use the 'mkfilelst' and 'mksig' tools under the util/ directory to generates
+these baselines. After you have generated these files, you need to move them to
+the proper directory (/usr/libexec/tiger/systems/Linux/...).
+
+For more information, read the README.signatures file.
+
+To create a working Slackware baseline to be used with Tiger, run the following commands:
+
+ export TIGERHOMEDIR="/usr/libexec/tiger"
+ export ARCH=$( uname -m )
+ export LINUX_VER=$( uname -r )
+ export TIGERHOMESUBDIR="${TIGERHOMEDIR}/systems/Linux/`echo "${LINUX_VER}" | cut -d '.' -f 1`/${LINUX_VER}/${ARCH}"
+ mkdir -pv ${TIGERHOMESUBDIR}
+ cp -v ${TIGERHOMEDIR}/systems/Linux/2/* ${TIGERHOMESUBDIR}
+ cd ${TIGERHOMESUBDIR}
+ ${TIGERHOMEDIR}/util/mksig
+ mv -v "signatures.Linux-${LINUX_VER}-${ARCH}" signatures
+ ${TIGERHOMEDIR}/util/mkfilelst
+ mv -v "file_access_list.Linux-${LINUX_VER}-${ARCH}" file_access_list
+ ./read_services.sh 1>services
+ find / -type f -perm -04000 1>suid_list
+ find / -type f -perm -02000 1>sgid_list
diff --git a/system/tiger/patches/9a030129ceceba715dff801f8229e66de62a8083.patch b/system/tiger/patches/9a030129ceceba715dff801f8229e66de62a8083.patch
new file mode 100644
index 0000000000..a1069e2645
--- /dev/null
+++ b/system/tiger/patches/9a030129ceceba715dff801f8229e66de62a8083.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/check_rootdir b/scripts/check_rootdir
+index a34eb2a..5f55159 100755
+--- a/scripts/check_rootdir
++++ b/scripts/check_rootdir
+@@ -90,7 +90,7 @@ haveallvars TESTLINK HOSTNAME || exit 1
+ # Checking to see if the root directory is on the correct INODE number
+ inode=`$LS -di / | $AWK '{print $1}'`
+ fstype=`$GETFS | $GREP " / " | $AWK -F " " '{ print $5;}'`
+-[ $inode != 2 ] && [ "$fstype" = "ext2" -o "$fstype" = "ext3" ] &&
++[ $inode != 2 ] && [ "$fstype" = "ext2" -o "$fstype" = "ext3" -o "$fstype" = "ext4" ] &&
+ message FAIL rootdir001f "" "Root directory on incorrect inode"
+
+
diff --git a/system/tiger/patches/check_signatures.patch b/system/tiger/patches/check_signatures.patch
new file mode 100644
index 0000000000..5264ad57e3
--- /dev/null
+++ b/system/tiger/patches/check_signatures.patch
@@ -0,0 +1,12 @@
+diff -urpN tiger-3.2.3.orig/scripts/check_signatures tiger-3.2.3/scripts/check_signatures
+--- tiger-3.2.3.orig/scripts/check_signatures 2011-08-14 05:44:29.474729020 +0000
++++ tiger-3.2.3/scripts/check_signatures 2011-08-14 05:46:36.840361481 +0000
+@@ -91,7 +91,7 @@ do
+ *[!0-9a-f]*) {
+ std_signature="$p1"
+ comment="$p2 $p3 $p4 $p5 $p6 $p7 $p8 $comment"
+- [ -n "$MD5" ] && loc_signature="`$MD5 < $file`"
++ [ -n "$MD5" ] && loc_signature="`$MD5 < $file | $AWK '{print $1}'`"
+ }
+ ;;
+ *) {
diff --git a/system/tiger/patches/mkfilelst.patch b/system/tiger/patches/mkfilelst.patch
new file mode 100644
index 0000000000..b3d5c678c1
--- /dev/null
+++ b/system/tiger/patches/mkfilelst.patch
@@ -0,0 +1,12 @@
+diff -urpN tiger-3.2.3.orig/util/mkfilelst tiger-3.2.3/util/mkfilelst
+--- tiger-3.2.3.orig/util/mkfilelst 2011-08-07 21:16:16.361620719 +0000
++++ tiger-3.2.3/util/mkfilelst 2011-08-07 21:18:30.710039906 +0000
+@@ -138,7 +138,7 @@ do
+ if [ $glob -lt 2 ] ; then
+ [ -f "$file" -o -d "$file" ] && \
+ getpermit $file |
+- while read _file owner group ur uw ux gr gw gx or ow ox stk suid sgid stk
++ while read _file owner group ur uw ux gr gw gx or ow ox suid sgid stk
+ do
+ echo "$file $owner $group $suid $sgid $ur $uw $ux $gr $gw $gx $or $ow $ox $lvl $ownmid $grpmid $prmmid"
+ done
diff --git a/system/tiger/patches/tiger-aide.patch b/system/tiger/patches/tiger-aide.patch
new file mode 100644
index 0000000000..0d8c359698
--- /dev/null
+++ b/system/tiger/patches/tiger-aide.patch
@@ -0,0 +1,30 @@
+From c0815d8bd760a3b5b62d6caa452b1ae1430040f9 Mon Sep 17 00:00:00 2001
+From: pyllyukko <pyllyukko@maimed.org>
+Date: Sat, 6 Oct 2012 23:18:03 +0300
+Subject: Fixed the aide_run script to support Aide 0.15.1 reports
+
+---
+ scripts/aide_run | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/aide_run b/scripts/aide_run
+index 363ef10..b776589 100755
+--- a/scripts/aide_run
++++ b/scripts/aide_run
+@@ -152,11 +152,11 @@ $AIDE --check --config=${AIDE_CFG} --report=stdout ${AIDE_DB} \
+ # i.e. check $? and determine what happened
+
+ # Check temporary report for the changes signal:
+-$GREP ${AIDE_RPT} -qe "AIDE found differences"
++$GREP ${AIDE_RPT} -qe "AIDE \([0-9.]\+ \)\?found differences"
+
+ case "$?" in
+ 0) # Summary
+- AIDE_SUMMARY=`$GREP ${AIDE_RPT} -e "^Total number"`
++ AIDE_SUMMARY=`$GREP ${AIDE_RPT} -e "^ *Total number"`
+ message INFO aide003i "" "Summary: ${AIDE_SUMMARY}"
+ # Differentiate between added, changed and removed files
+ for status in changed removed detected; do
+--
+1.7.4.4
+
diff --git a/system/tiger/patches/tiger-makefile.patch b/system/tiger/patches/tiger-makefile.patch
new file mode 100644
index 0000000000..39a2571e3d
--- /dev/null
+++ b/system/tiger/patches/tiger-makefile.patch
@@ -0,0 +1,25 @@
+From 160ba685d08651d1cc755d2bb0167dc7170f8e2b Mon Sep 17 00:00:00 2001
+From: pyllyukko <pyllyukko@maimed.org>
+Date: Sat, 6 Oct 2012 23:43:07 +0300
+Subject: Added facl.{tmpl|list} to Makefile.in.
+
+---
+ Makefile.in | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 9d6eab8..86ab714 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -167,6 +167,8 @@ MISCFILES=./initdefs \
+ ./util/mksig \
+ ./util/setsh \
+ ./util/sgrep \
++ ./util/facl.lst \
++ ./util/facl.tmpl \
+ ./doc/explain.idx
+
+ MISCDIRS=./bin \
+--
+1.7.4.4
+
diff --git a/system/tiger/patches/tiger-sha512-1.patch b/system/tiger/patches/tiger-sha512-1.patch
new file mode 100644
index 0000000000..70e087686a
--- /dev/null
+++ b/system/tiger/patches/tiger-sha512-1.patch
@@ -0,0 +1,34 @@
+Index: scripts/check_passwd
+===================================================================
+RCS file: /sources/tiger/tiger/scripts/check_passwd,v
+retrieving revision 1.24
+diff -u -r1.24 check_passwd
+--- scripts/check_passwd 27 Aug 2007 18:30:44 -0000 1.24
++++ scripts/check_passwd 12 May 2010 06:23:57 -0000
+@@ -129,7 +129,7 @@
+ do
+
+ # Check the password hash.
+- [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|xxxxxxxxxxxxx'
++ [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|sha512|xxxxxxxxxxxxx'
+ eval "case \"$hash\" in
+ \"\")
+ message FAIL pass011f \"\" \"Username \\\`$login' has an empty password field.\"
+Index: systems/Linux/2/gen_passwd_sets
+===================================================================
+RCS file: /sources/tiger/tiger/systems/Linux/2/gen_passwd_sets,v
+retrieving revision 1.16
+diff -u -r1.16 gen_passwd_sets
+--- systems/Linux/2/gen_passwd_sets 4 Aug 2005 08:48:15 -0000 1.16
++++ systems/Linux/2/gen_passwd_sets 12 May 2010 06:23:57 -0000
+@@ -96,6 +96,10 @@
+ \$1\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./]\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./])
+ passwd="md5"
+ ;;
++# For SHA512 passwds (98 chars) starting with $6$ (Linux)
++ \$6\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./])
++ passwd="md5"
++ ;;
+ " ") passwd=""
+ ;;
+ *|!!)
diff --git a/system/tiger/patches/zappasswd-3.2.3.patch b/system/tiger/patches/zappasswd-3.2.3.patch
new file mode 100644
index 0000000000..403ff6244c
--- /dev/null
+++ b/system/tiger/patches/zappasswd-3.2.3.patch
@@ -0,0 +1,38 @@
+diff --git a/scripts/check_passwd b/scripts/check_passwd
+index 4a52092..8cb69be 100755
+--- a/scripts/check_passwd
++++ b/scripts/check_passwd
+@@ -129,7 +129,7 @@ check_passwd_entries()
+ do
+
+ # Check the password hash.
+- [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|xxxxxxxxxxxxx'
++ [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|blowfish|sha256|sha512|xxxxxxxxxxxxx'
+ eval "case \"$hash\" in
+ \"\")
+ message FAIL pass011f \"\" \"Username \\\`$login' has an empty password field.\"
+diff --git a/systems/Linux/2/gen_passwd_sets b/systems/Linux/2/gen_passwd_sets
+index ec48944..26d73f0 100755
+--- a/systems/Linux/2/gen_passwd_sets
++++ b/systems/Linux/2/gen_passwd_sets
+@@ -96,9 +96,19 @@ zappasswd()
+ \$1\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./]\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./])
+ passwd="md5"
+ ;;
++ \$2a\$*)
++ passwd="blowfish"
++ ;;
++ \$5\$*)
++ passwd="sha256"
++ ;;
++# For SHA512 passwds starting with $6$ (Linux)
++ \$6\$*)
++ passwd="sha512"
++ ;;
+ " ") passwd=""
+ ;;
+- *|!!)
++ *|!!|!\*)
+ passwd="*"
+ ;;
+ esac
diff --git a/system/tiger/patches/zappasswd.patch b/system/tiger/patches/zappasswd.patch
new file mode 100644
index 0000000000..fdfabf8b00
--- /dev/null
+++ b/system/tiger/patches/zappasswd.patch
@@ -0,0 +1,40 @@
+diff --git a/scripts/check_passwd b/scripts/check_passwd
+index 9b58e72..8cb69be 100755
+--- a/scripts/check_passwd
++++ b/scripts/check_passwd
+@@ -129,7 +129,7 @@ check_passwd_entries()
+ do
+
+ # Check the password hash.
+- [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|sha512|xxxxxxxxxxxxx'
++ [ -z "$Tiger_Passwd_Hashes" ] && Tiger_Passwd_Hashes='crypt3|md5|blowfish|sha256|sha512|xxxxxxxxxxxxx'
+ eval "case \"$hash\" in
+ \"\")
+ message FAIL pass011f \"\" \"Username \\\`$login' has an empty password field.\"
+diff --git a/systems/Linux/2/gen_passwd_sets b/systems/Linux/2/gen_passwd_sets
+index 908897c..f67ceef 100755
+--- a/systems/Linux/2/gen_passwd_sets
++++ b/systems/Linux/2/gen_passwd_sets
+@@ -100,13 +100,19 @@ zappasswd()
+ \$1\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./]\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./])
+ passwd="md5"
+ ;;
+-# For SHA512 passwds (98 chars) starting with $6$ (Linux)
+- \$6\$[a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./][a-zA-Z0-9\./])
++ \$2a\$*)
++ passwd="blowfish"
++ ;;
++ \$5\$*)
++ passwd="sha256"
++ ;;
++# For SHA512 passwds starting with $6$ (Linux)
++ \$6\$*)
+ passwd="sha512"
+ ;;
+ " ") passwd=""
+ ;;
+- *|!!)
++ *|!!|!\*)
+ passwd="*"
+ ;;
+ esac
diff --git a/system/tiger/slack-desc b/system/tiger/slack-desc
index e1c51f7e84..637d99e506 100644
--- a/system/tiger/slack-desc
+++ b/system/tiger/slack-desc
@@ -1,9 +1,9 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
tiger: tiger (Report system security vulnerabilities)
diff --git a/system/tiger/tiger.SlackBuild b/system/tiger/tiger.SlackBuild
index a5db73dcbe..19639e24c8 100644
--- a/system/tiger/tiger.SlackBuild
+++ b/system/tiger/tiger.SlackBuild
@@ -11,7 +11,7 @@
PRGNAM=tiger
VERSION=${VERSION:-3.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,7 +41,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -79,6 +79,20 @@ find . \
# The build errs on this
# see http://cvs.savannah.gnu.org/viewvc/tiger/tiger/util/genmsgidx?r1=1.6&r2=1.7
patch --verbose -p1 < $CWD/patches/tiger-3.2.3-build-fix.diff
+# fix bug #7186 & #7675
+# see https://savannah.nongnu.org/patch/?7675
+patch --verbose -p1 < $CWD/patches/zappasswd-3.2.3.patch
+# fix bug #33969
+patch --verbose -p1 < $CWD/patches/mkfilelst.patch
+# fix bug #34028
+patch --verbose -p1 < $CWD/patches/check_signatures.patch
+# see https://savannah.nongnu.org/patch/index.php?7859
+patch --verbose -p1 < $CWD/patches/tiger-aide.patch
+# fix bug #37517
+patch --verbose -p1 < $CWD/patches/tiger-makefile.patch
+# add support for ext4 in the check_rootdir script
+# see http://git.savannah.gnu.org/cgit/tiger.git/commit/?id=9a030129ceceba715dff801f8229e66de62a8083
+patch --verbose -p1 < $CWD/patches/9a030129ceceba715dff801f8229e66de62a8083.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS"
@@ -104,7 +118,7 @@ install -D -m 0640 $CWD/config/tiger.ignore $PKG/etc/tiger/tiger.ignore.new
install -D -m 0640 $CWD/config/tiger.default $PKG/etc/default/tiger.new
# From the .spec: 3.- This should be done by the Makefile, grumble...
-install -D -m 0644 version.h $PKG/usr/lib/tiger/version.h
+install -D -m 0644 version.h $PKG/usr/libexec/tiger/version.h
# Remove unnecesary stuff
( cd $PKG
@@ -127,6 +141,7 @@ cp -a [A-Z][A-Z]* site-* tigerrc* \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a other/cert-usc20.txt contrib/fix_tiger_GROUPS.sh audit \
$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
cp $PKG/usr/libexec/tiger/html/*.html $PKG/usr/doc/$PRGNAM-$VERSION/html