summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2010-05-23 01:18:59 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-23 23:21:44 -0500
commit0b5ae144f1d30116524d26483d18b8f53cf7117b (patch)
treef5e9ea2a19930195839b6041ebb899876ee6d0e9 /system
parentc821f1be3d8a1b6eac4e45a10d45c046495ed287 (diff)
downloadslackbuilds-0b5ae144f1d30116524d26483d18b8f53cf7117b.tar.gz
slackbuilds-0b5ae144f1d30116524d26483d18b8f53cf7117b.tar.xz
system/ink: Removed (unmaintained)
I don't see much need for this these days, but if someone else does, feel free to resurrect it :-)
Diffstat (limited to 'system')
-rw-r--r--system/ink/README3
-rw-r--r--system/ink/ink-0.5.0-Makefile.patch11
-rw-r--r--system/ink/ink.SlackBuild78
-rw-r--r--system/ink/ink.info10
-rw-r--r--system/ink/slack-desc19
5 files changed, 0 insertions, 121 deletions
diff --git a/system/ink/README b/system/ink/README
deleted file mode 100644
index 50e4511e16..0000000000
--- a/system/ink/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Ink is a command line tool for checking the ink level of your printer
-on a system which runs Linux. It makes use of libinklevel. As such,
-you must have libinklevel installed in order to build the ink package.
diff --git a/system/ink/ink-0.5.0-Makefile.patch b/system/ink/ink-0.5.0-Makefile.patch
deleted file mode 100644
index 3179b24474..0000000000
--- a/system/ink/ink-0.5.0-Makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nur ink-0.5.0.orig/Makefile ink-0.5.0/Makefile
---- ink-0.5.0.orig/Makefile 2009-01-24 08:42:14.000000000 -0600
-+++ ink-0.5.0/Makefile 2009-06-27 00:15:12.457466539 -0500
-@@ -1,6 +1,6 @@
- DESTDIR =
- PREFIX = /usr/local/
--CFLAGS += -Wall -O2 -linklevel
-+CFLAGS += -Wall $(EXTRA_CFLAGS) -linklevel
- CC = gcc
- OS=linux
-
diff --git a/system/ink/ink.SlackBuild b/system/ink/ink.SlackBuild
deleted file mode 100644
index 6717239423..0000000000
--- a/system/ink/ink.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ink
-
-# Copyright 2006-2009 Robby Workman (http://rlworkman.net)
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ink
-VERSION=0.5.0
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch -p1 < $CWD/ink-0.5.0-Makefile.patch
-make EXTRA_CFLAGS="$SLKCFLAGS"
-make PREFIX=/usr DESTDIR=$PKG install
-
-strip --strip-unneeded $PKG/usr/bin/ink
-
-# No man pages
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ink/ink.info b/system/ink/ink.info
deleted file mode 100644
index 0a6de6937b..0000000000
--- a/system/ink/ink.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ink"
-VERSION="0.5.0"
-HOMEPAGE="http://ink.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/ink/ink-0.5.0.tar.gz"
-MD5SUM="ddbbc4164384fc7185bc07b7602e4a8d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Robby Workman"
-EMAIL="rw@rlworkman.net"
-APPROVED="BP{k}"
diff --git a/system/ink/slack-desc b/system/ink/slack-desc
deleted file mode 100644
index 7e2b16ce0b..0000000000
--- a/system/ink/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-ink: ink (printer ink level monitor)
-ink:
-ink: Ink is a command line tool for checking the ink level of your printer
-ink: on a system which runs Linux. It makes use of libinklevel.
-ink:
-ink: Homepage: http://ink.sourceforge.net/
-ink:
-ink:
-ink:
-ink:
-ink: