summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dugan Chen <thedoogster [at] gmail [dot] com>2015-07-02 21:57:16 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-04 10:38:16 +0700
commitb7ef32891c6c20f91bdccaa3cbabff9d0fde2aa2 (patch)
treea1855e1d139224759ffdff3184468b50f73e0226 /system
parent68f900667b25135d374bcdeccc10333d975c8b80 (diff)
downloadslackbuilds-b7ef32891c6c20f91bdccaa3cbabff9d0fde2aa2.tar.gz
slackbuilds-b7ef32891c6c20f91bdccaa3cbabff9d0fde2aa2.tar.xz
system/ds4drv: Added (Sony DualShock 4 userspace driver).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/ds4drv/50-ds4drv.rules3
-rw-r--r--system/ds4drv/README3
-rw-r--r--system/ds4drv/doinst.sh18
-rw-r--r--system/ds4drv/ds4drv.SlackBuild92
-rw-r--r--system/ds4drv/ds4drv.info10
-rw-r--r--system/ds4drv/slack-desc19
6 files changed, 145 insertions, 0 deletions
diff --git a/system/ds4drv/50-ds4drv.rules b/system/ds4drv/50-ds4drv.rules
new file mode 100644
index 0000000000..4dc0ffb8ce
--- /dev/null
+++ b/system/ds4drv/50-ds4drv.rules
@@ -0,0 +1,3 @@
+KERNEL=="uinput", MODE="0666"
+KERNEL=="hidraw*", SUBSYSTEM=="hidraw", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="05c4", MODE="0666"
+KERNEL=="hidraw*", SUBSYSTEM=="hidraw", KERNELS=="0005:054C:05C4.*", MODE="0666"
diff --git a/system/ds4drv/README b/system/ds4drv/README
new file mode 100644
index 0000000000..73cb4b8ec0
--- /dev/null
+++ b/system/ds4drv/README
@@ -0,0 +1,3 @@
+ds4drv is a Sony Dualshock 4 userspace driver for Linux.
+
+It supports both Bluez 4 (which Slackware has) and Bluez 5.
diff --git a/system/ds4drv/doinst.sh b/system/ds4drv/doinst.sh
new file mode 100644
index 0000000000..27e70f0b6c
--- /dev/null
+++ b/system/ds4drv/doinst.sh
@@ -0,0 +1,18 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/ds4drv.conf.new
+
+if [ -x /sbin/udevadm ]; then
+ /sbin/udevadm control --reload-rules 2>&1
+fi
diff --git a/system/ds4drv/ds4drv.SlackBuild b/system/ds4drv/ds4drv.SlackBuild
new file mode 100644
index 0000000000..5a69df1f47
--- /dev/null
+++ b/system/ds4drv/ds4drv.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for ds4drv
+
+# Copyright 2015 Dugan Chen Canada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ds4drv
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/etc
+cat ds4drv.conf > $PKG/etc/ds4drv.conf.new
+
+mkdir -p $PKG/lib/udev/rules.d
+cat $CWD/50-ds4drv.rules > $PKG/lib/udev/rules.d/50-ds4drv.rules
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a HISTORY.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ds4drv/ds4drv.info b/system/ds4drv/ds4drv.info
new file mode 100644
index 0000000000..e55f01ed87
--- /dev/null
+++ b/system/ds4drv/ds4drv.info
@@ -0,0 +1,10 @@
+PRGNAM="ds4drv"
+VERSION="0.5.0"
+HOMEPAGE="https://github.com/chrippa/ds4drv"
+DOWNLOAD="https://pypi.python.org/packages/source/d/ds4drv/ds4drv-0.5.0.tar.gz"
+MD5SUM="705d48f45634f9dbd3f40c8876fb2c96"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyudev python-evdev"
+MAINTAINER="Dugan Chen"
+EMAIL="thedoogster [at] gmail [dot] com"
diff --git a/system/ds4drv/slack-desc b/system/ds4drv/slack-desc
new file mode 100644
index 0000000000..6e072f4f36
--- /dev/null
+++ b/system/ds4drv/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ds4drv: ds4drv (Sony DualShock 4 userspace driver)
+ds4drv:
+ds4drv: ds4drv is a Sony DualShock 4 userspace driver for Linux.
+ds4drv:
+ds4drv:
+ds4drv:
+ds4drv:
+ds4drv:
+ds4drv:
+ds4drv:
+ds4drv: