summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Pragmatic Cypher <slackbuilds@server.ky>2016-11-20 20:51:49 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-11-26 11:47:24 +0700
commit106a4ec9c91ab079ea086ab7745030554cce5506 (patch)
treecbb8d2bc44cf8cd679f2cbd58722c11ddba1886e /system
parent379e0016752c6a561ac6625e387265e3afb20189 (diff)
downloadslackbuilds-106a4ec9c91ab079ea086ab7745030554cce5506.tar.gz
slackbuilds-106a4ec9c91ab079ea086ab7745030554cce5506.tar.xz
system/nix: Updated for version 1.11.4.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/nix/README20
-rw-r--r--system/nix/nix.SlackBuild10
-rw-r--r--system/nix/nix.info6
-rw-r--r--system/nix/rc.nix (renamed from system/nix/config/rc.nix)10
4 files changed, 20 insertions, 26 deletions
diff --git a/system/nix/README b/system/nix/README
index a741331aae..1da6a2ec68 100644
--- a/system/nix/README
+++ b/system/nix/README
@@ -1,5 +1,3 @@
-nix (functional package manager)
-
Nix is a purely functional package manager. This means that it treats
packages like values in purely functional programming languages such as
Haskell -- they are built by functions that don't have side-effects,
@@ -9,9 +7,9 @@ has its own unique subdirectory such as
/nix/store/b6gvzjyb2pg0kjfwrjmg1vfhh54ad73z-firefox-33.1/
-where b6gvzjyb2pg0... is a unique identifier for the package that captures all
-its dependencies (it's a cryptographic hash of the package's build dependency
-graph).
+where b6gvzjyb2pg0... is a unique identifier for the package that
+captures all its dependencies (it's a cryptographic hash of the
+package's build dependency graph).
Nix may be run in single or multi-user mode (which requires the
nix-daemon). To have the nix daemon start and stop with your host,
@@ -35,14 +33,18 @@ be added under the 'nixbld' group.
-d /var/empty -g nixbld -G nixbld -M -N -r -s "$(which nologin)" \
nixbld$n; done
-Restricting access to the daemon is acheived by setting file permissions
-for the daemon's socket's folder.
+Restricting access to the daemon is acheived by setting file
+permissions for the daemon's socket's folder.
chgrp nix-users /nix/var/nix/daemon-socket
chmod ug=rwx,o= /nix/var/nix/daemon-socket
-Correct permissions must also be set for the following profile directories
-to give users access.
+Correct permissions must also be set for the following profile
+directories to give users access.
/nix/var/nix/profiles
/var/nix/profiles
+
+If you have patches email me, or send a pull request via github:
+
+ https://github.com/PragmaticCypher/slackbuilds
diff --git a/system/nix/nix.SlackBuild b/system/nix/nix.SlackBuild
index 3a3a4569e6..6820ea808c 100644
--- a/system/nix/nix.SlackBuild
+++ b/system/nix/nix.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nix
-VERSION=${VERSION:-1.11.2}
+VERSION=${VERSION:-1.11.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -82,7 +82,7 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-install -D --mode 0755 $CWD/config/rc.nix $PKG/etc/rc.d/rc.nix.new
+install -D --mode 0755 $CWD/rc.nix $PKG/etc/rc.d/rc.nix.new
mkdir -p $PKG/nix
mkdir -p $PKG/var/nix/profiles
mkdir -p $PKG/nix/var/nix/profiles
diff --git a/system/nix/nix.info b/system/nix/nix.info
index 03af577e6c..b17c8383a8 100644
--- a/system/nix/nix.info
+++ b/system/nix/nix.info
@@ -1,8 +1,8 @@
PRGNAM="nix"
-VERSION="1.11.2"
+VERSION="1.11.4"
HOMEPAGE="http://nixos.org/nix"
-DOWNLOAD="http://nixos.org/releases/nix/nix-1.11.2/nix-1.11.2.tar.xz"
-MD5SUM="7257cf8ea7b5db7ca42165f6dbf17fb7"
+DOWNLOAD="http://nixos.org/releases/nix/nix-1.11.4/nix-1.11.4.tar.xz"
+MD5SUM="5e74997665df456ea3ac379a2cbfa4af"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="perl-DBD-SQLite perl-WWW-Curl"
diff --git a/system/nix/config/rc.nix b/system/nix/rc.nix
index 82852934af..86f54a25ea 100644
--- a/system/nix/config/rc.nix
+++ b/system/nix/rc.nix
@@ -1,13 +1,5 @@
#!/bin/sh
-# Short-Description: Create lightweight, portable, self-sufficient containers.
-# Description:
-# Docker is an open-source project to easily create lightweight, portable,
-# self-sufficient containers from any application. The same container that a
-# developer builds and tests on a laptop can run at scale, in production, on
-# VMs, bare metal, OpenStack clusters, public clouds and more.
-
-
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin
BASE=nix-daemon
@@ -53,7 +45,7 @@ nix_stop() {
rm -f ${NIX_PIDFILE}
}
-# Restart docker:
+# Restart nix:
nix_restart() {
nix_stop
nix_start