summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-08-29 07:52:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-29 07:20:11 +0700
commit450c1a11ef38249bd97d7d14204a752553ca090f (patch)
tree97df7b17fbde612f3fbd85edf523dde1a5283c18 /system
parent0b8428fc482e2333ae40610eace1855c4647a589 (diff)
downloadslackbuilds-450c1a11ef38249bd97d7d14204a752553ca090f.tar.gz
slackbuilds-450c1a11ef38249bd97d7d14204a752553ca090f.tar.xz
system/salt: Added (configuration management engine).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/salt/README19
-rw-r--r--system/salt/salt.SlackBuild91
-rw-r--r--system/salt/salt.info10
-rw-r--r--system/salt/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/system/salt/README b/system/salt/README
new file mode 100644
index 0000000000..68aa92a08b
--- /dev/null
+++ b/system/salt/README
@@ -0,0 +1,19 @@
+SaltStack or Salt is a Python-based open source configuration management and
+remote execution engine.
+
+At this time, there is no support for minions running Slackware.
+
+Optional dependencies include:
+ python-ldap
+ Mako
+ libvirt
+ pyOpenSSL
+ CherryPy
+ pymongo
+ python-keyring
+ MySQL-python
+ redis-py
+ python-gnupg
+
+For configuration details, please see:
+ https://docs.saltstack.com/en/latest/ref/configuration/index.html
diff --git a/system/salt/salt.SlackBuild b/system/salt/salt.SlackBuild
new file mode 100644
index 0000000000..b64fd66a36
--- /dev/null
+++ b/system/salt/salt.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for salt aka saltstack
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=salt
+VERSION=${VERSION:-2016.3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir --ignore-fail-on-non-empty $PKG/usr/share
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS HACKING.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/salt/salt.info b/system/salt/salt.info
new file mode 100644
index 0000000000..d3604cb97f
--- /dev/null
+++ b/system/salt/salt.info
@@ -0,0 +1,10 @@
+PRGNAM="salt"
+VERSION="2016.3.2"
+HOMEPAGE="https://saltstack.com/community/"
+DOWNLOAD="https://github.com/saltstack/salt/releases/download/v2016.3.2/salt-2016.3.2.tar.gz"
+MD5SUM="27a9bb34c205ffe07e95b316e2131177"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="msgpack-python PyYAML Jinja2 MarkupSafe python-requests tornado futures zeromq pyzmq pycrypto"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/system/salt/slack-desc b/system/salt/slack-desc
new file mode 100644
index 0000000000..8841b7023e
--- /dev/null
+++ b/system/salt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+salt: salt (configuration management engine)
+salt:
+salt: SaltStack or Salt is a Python-based open source configuration
+salt: management and remote execution engine.
+salt:
+salt: Note: At this time there is no support for minions running Slackware.
+salt:
+salt: https://saltstack.com/community/
+salt:
+salt:
+salt: