summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2015-10-29 07:56:27 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-10-29 19:37:23 +0700
commit89bbad9cc65bd26f5c5465fc6aa52f39f45e1edb (patch)
tree9e3a7a6ef71283a51c0b971c7501595238d8b020 /system
parent72b2520f45333621c2b60a8699c697bb8df9cb83 (diff)
downloadslackbuilds-89bbad9cc65bd26f5c5465fc6aa52f39f45e1edb.tar.gz
slackbuilds-89bbad9cc65bd26f5c5465fc6aa52f39f45e1edb.tar.xz
system/logtool: Added (log analyzer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/logtool/README13
-rw-r--r--system/logtool/logtool.SlackBuild105
-rw-r--r--system/logtool/logtool.info10
-rw-r--r--system/logtool/logtool_1.2.8-8.diff.gzbin0 -> 41603 bytes
-rw-r--r--system/logtool/slack-desc19
5 files changed, 147 insertions, 0 deletions
diff --git a/system/logtool/README b/system/logtool/README
new file mode 100644
index 0000000000..5a24f3c387
--- /dev/null
+++ b/system/logtool/README
@@ -0,0 +1,13 @@
+logtool (log analyzer)
+
+Logtool is a command line program that will parse ASCII logfiles into
+a more palatable format. It will take anything resembling a syslog
+or multilog file (this includes syslog-ng, and probably most of the
+other variants out there), and crunch it into one of the following
+formats for your viewing pleasure:
+
+ * ANSI (colorized for easy "at a glance" viewing)
+ * ASCII (for e-mail'ed reports, and term's that don't support color)
+ * CSV (for importing into your favorite spreadsheet/database)
+ * HTML (for generating web pages)
+ * RAW (for no good reason)
diff --git a/system/logtool/logtool.SlackBuild b/system/logtool/logtool.SlackBuild
new file mode 100644
index 0000000000..7c14c06b94
--- /dev/null
+++ b/system/logtool/logtool.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+#
+# Slackware build script for logtool.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=logtool
+VERSION=${VERSION:-1.2.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+rm -rf debian
+gzip -dc $CWD/logtool_1.2.8-8.diff.gz | patch -p1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc/logtool \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+DOCS="CHANGES-1.2 CHANGES.history COPYING CREDITS INSTALL README TODO USAGE"
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION/ChangeLog
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/logtool/logtool.info b/system/logtool/logtool.info
new file mode 100644
index 0000000000..795b7eaa32
--- /dev/null
+++ b/system/logtool/logtool.info
@@ -0,0 +1,10 @@
+PRGNAM="logtool"
+VERSION="1.2.8"
+HOMEPAGE="http://xjack.org/logtool/"
+DOWNLOAD="http://xjack.org/logtool/download/logtool-1.2.8.tar.gz"
+MD5SUM="f596fd2057fe5f3293ca054dd14a3c10"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/system/logtool/logtool_1.2.8-8.diff.gz b/system/logtool/logtool_1.2.8-8.diff.gz
new file mode 100644
index 0000000000..3dcc3d286b
--- /dev/null
+++ b/system/logtool/logtool_1.2.8-8.diff.gz
Binary files differ
diff --git a/system/logtool/slack-desc b/system/logtool/slack-desc
new file mode 100644
index 0000000000..6555a1d61c
--- /dev/null
+++ b/system/logtool/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+logtool: logtool (log analyzer)
+logtool:
+logtool: Logtool is a command line program that will parse ASCII logfiles into
+logtool: a more palatable format.
+logtool:
+logtool: Homepage: http://xjack.org/logtool/
+logtool:
+logtool:
+logtool:
+logtool:
+logtool: