summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Chris Abela <kristofru@gmail.com>2011-10-31 18:25:50 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2011-11-04 22:02:25 -0200
commitb843c43a2f9a3e9dabdbbc00fb91c945dcaeb335 (patch)
tree0545f7ed7bef74f0088955226bb30803ff272829 /system
parentc6c1945a5ea18be6c9d3239933976a807d44bead (diff)
downloadslackbuilds-b843c43a2f9a3e9dabdbbc00fb91c945dcaeb335.tar.gz
slackbuilds-b843c43a2f9a3e9dabdbbc00fb91c945dcaeb335.tar.xz
system/burp: Added (backup and restore program)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/burp/README5
-rw-r--r--system/burp/README.SBo19
-rw-r--r--system/burp/burp.SlackBuild111
-rw-r--r--system/burp/burp.info10
-rw-r--r--system/burp/doinst.sh30
-rw-r--r--system/burp/rc.burp59
-rw-r--r--system/burp/slack-desc19
7 files changed, 253 insertions, 0 deletions
diff --git a/system/burp/README b/system/burp/README
new file mode 100644
index 0000000000..03e6fac190
--- /dev/null
+++ b/system/burp/README
@@ -0,0 +1,5 @@
+Burp is a backup and restore program. It uses librsync in order to save on the
+amount of space that is used by each backup. It also uses VSS (Volume Shadow
+Copy Service) to make snapshots when backing up Windows computers.
+
+This needs librsync
diff --git a/system/burp/README.SBo b/system/burp/README.SBo
new file mode 100644
index 0000000000..d86b102ddf
--- /dev/null
+++ b/system/burp/README.SBo
@@ -0,0 +1,19 @@
+To start the burp server run:
+
+/etc/rc.d/rc.burp start
+
+To start burp automatically on boot up, add these lines to /etc/rc.d/rc.local
+
+# Start burp
+if [ -x /etc/rc.d/rc.burp ]; then
+ /etc/rc.d/rc.burp start
+fi
+
+and the following lines in /etc/rc.d/rc.local_shutdown to stop burp on shutdown
+
+# Stop burp
+if [ -x /etc/rc.d/rc.burp ]; then
+ /etc/rc.d/rc.burp stop
+fi
+
+Naturally, ensure that all these scripts have executable permissions.
diff --git a/system/burp/burp.SlackBuild b/system/burp/burp.SlackBuild
new file mode 100644
index 0000000000..16029cb47a
--- /dev/null
+++ b/system/burp/burp.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/sh
+
+# Slackware build script for burp
+
+# Copyright 2011 Chris Abela, Malta
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIE
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=burp
+VERSION=${VERSION:-1.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Maximum compression for the man files
+sed -i 's/gzip/gzip -9/1' manpages/Makefile*
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc/$PRGNAM \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Install the handy rc script
+install -D -m 755 -o root -g root $CWD/rc.burp $PKG/etc/rc.d/rc.burp
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG CONTRIBUTORS LICENSE README TODO UPGRADING docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# Rename the config files
+for FILE in $(find $PKG/etc/ -type f); do
+ mv $FILE $FILE.new
+done
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/burp/burp.info b/system/burp/burp.info
new file mode 100644
index 0000000000..3be52802b3
--- /dev/null
+++ b/system/burp/burp.info
@@ -0,0 +1,10 @@
+PRGNAM="burp"
+VERSION="1.2.2"
+HOMEPAGE="http://burp.grke.net"
+DOWNLOAD="http://downloads.sourceforge.net/burp/burp-1.2.2/burp-1.2.2.tar.bz2"
+MD5SUM="876677bb5c960b4807e53b7731e7adcc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Chris Abela"
+EMAIL="kristofru@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/system/burp/doinst.sh b/system/burp/doinst.sh
new file mode 100644
index 0000000000..4f774318fd
--- /dev/null
+++ b/system/burp/doinst.sh
@@ -0,0 +1,30 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ rm $NEW
+ fi
+}
+preserve_perms() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+ fi
+ config $NEW
+}
+config etc/burp/ssl_cert-client.pem.new
+config etc/burp/clientconfdir/testclient.new
+config etc/burp/dhfile.pem.new
+config etc/burp/ssl_cert_ca.pem.new
+config etc/burp/ssl_cert-server.pem.new
+config etc/burp/burp.conf.new
+config etc/burp/burp-server.conf.new
+preserve_perms etc/rc.d/rc.burp.new
+preserve_perms etc/burp/notify_script.new
+preserve_perms etc/burp/summary_script.new
+preserve_perms etc/burp/timer_script.new
diff --git a/system/burp/rc.burp b/system/burp/rc.burp
new file mode 100644
index 0000000000..9f4b117e6f
--- /dev/null
+++ b/system/burp/rc.burp
@@ -0,0 +1,59 @@
+#!/bin/sh
+# start, stop, restart and status of burp
+
+RETVAL=0
+
+start(){
+ echo "Starting burp: /usr/sbin/burp -c /etc/burp/burp-server.conf"
+ /usr/sbin/burp -c /etc/burp/burp-server.conf
+ RETVAL=$?
+ [ "$RETVAL" = 0 ] && touch /var/lock/subsys/burp
+ return $RETVAL
+}
+
+stop(){
+ echo "Stopping burp... "
+ killall burp 2>/dev/null
+ RETVAL=$?
+ rm -f /var/lock/subsys/burp
+ return $RETVAL
+}
+
+restart(){
+ stop
+ sleep 1
+ start
+}
+
+status(){
+ echo -n $"Checking burp: "
+ /bin/kill -s IOT burp 2>/dev/null
+ RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ echo "burp is running"
+ else
+ echo "burp is not running"
+ fi
+ return $RETVAL
+}
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart)
+ restart
+ ;;
+ status)
+ status
+ ;;
+ *)
+ echo $"Usage: $0 {start|stop|restart|status}"
+ RETVAL=1
+esac
+
+exit $RETVAL
diff --git a/system/burp/slack-desc b/system/burp/slack-desc
new file mode 100644
index 0000000000..3bdc2eb41e
--- /dev/null
+++ b/system/burp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |--------handy-ruler------------------------------------------------------|
+burp: burp (backup and restore program)
+burp:
+burp: Burp uses librsync in order to save on the amount of space that is used
+burp: by each backup. It also uses VSS (Volume Shadow Copy Service) to make
+burp: snapshots when backing up Windows computers.
+burp:
+burp: Homepage: http://burp.grke.net
+burp:
+burp:
+burp:
+burp: