summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2017-06-17 10:49:07 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-24 08:33:08 +0700
commitd56b242eca5ae61b5fc5cc3a928a4fb99a88816b (patch)
treead12726a010ba7c1aacf8a6d6db346d4006ec1a6 /system
parent9f315c18f9849f37ac0dc404384d6df0447fa763 (diff)
downloadslackbuilds-d56b242eca5ae61b5fc5cc3a928a4fb99a88816b.tar.gz
slackbuilds-d56b242eca5ae61b5fc5cc3a928a4fb99a88816b.tar.xz
gis/gpsbabel: Updated for version 1.5.4, moved from system/.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'system')
-rw-r--r--system/gpsbabel/README13
-rw-r--r--system/gpsbabel/gpsbabel.SlackBuild124
-rw-r--r--system/gpsbabel/gpsbabel.info10
-rw-r--r--system/gpsbabel/slack-desc19
4 files changed, 0 insertions, 166 deletions
diff --git a/system/gpsbabel/README b/system/gpsbabel/README
deleted file mode 100644
index 223ad30c13..0000000000
--- a/system/gpsbabel/README
+++ /dev/null
@@ -1,13 +0,0 @@
-GPSBabel converts waypoints, tracks, and routes from one format to another,
-whether that format is a common mapping format like Delorme, Streets and
-Trips, or even a serial or USB upload or download to a GPS receiver such as
-those from Garmin and Magellan. By flattening the Tower of Babel that the
-authors of various programs for manipulating GPS data have imposed upon us, it
-returns to us the ability to freely move our own waypoint data between the
-programs and hardware we choose to use.
-
-It contains extensive data manipulation abilities making it a convenient for
-server-side processing or as the backend for other tools.
-
-It does not convert, transfer, send, or manipulate maps. We process data that
-may (or may not be) placed on a map, such as waypoints, tracks, and routes.
diff --git a/system/gpsbabel/gpsbabel.SlackBuild b/system/gpsbabel/gpsbabel.SlackBuild
deleted file mode 100644
index 26475dd6e9..0000000000
--- a/system/gpsbabel/gpsbabel.SlackBuild
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for gpsbabel
-
-# Copyright 2017 Kyle Guinn <elyk03@gmail.com>, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=gpsbabel
-VERSION=${VERSION:-1.5.3}
-SRCVER=${PRGNAM}_$(echo ${VERSION} | tr . _)
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="AUTHORS COPYING README*"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
-cd $PRGNAM-$SRCVER
-chown -R root:root .
-chmod -R u+w,go-w,a+rX-st .
-
-# Protect your privacy: Turn off usage reporting and checks for upgrades
-# by default. These can be enabled manually via the preferences window.
-# Upgrade checking is broken (for me, at least) so this silences an error dialog.
-sed -i \
- -e '/reportStatistics_/s/true/false/' \
- -e '/startupVersionCheck_/s/true/false/' \
- -e '/ignoreVersionMismatch/s/false/true/' \
- gui/babeldata.h
-
-# Make it more FHS-compliant by moving gmapbase.html and the translations
-# to /usr/share. Tell the GUI where to find them. Thanks to Arch.
-sed -i 's|QApplication::applicationDirPath() +|"/usr/share/gpsbabel"|' gui/map.cc
-sed -i 's|QApplication::applicationDirPath()|"/usr/share/gpsbabel"|' gui/mainwindow.cc
-
-# Build using the system zlib and libminizip from SBo (see --with-zlib=system).
-# Thanks to Gentoo.
-sed -i '/AC_CHECK_LIB(\[z\], \[gzopen\])/aAC_CHECK_LIB([minizip], [zipOpen64])' configure.in
-sed -i 's|"zlib/contrib/minizip/zip.h"|<minizip/zip.h>|' src/core/ziparchive.cc src/core/ziparchive.h
-autoreconf -vif
-
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-zlib=system \
- --build=$ARCH-slackware-linux \
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
-
-make
-make gui
-
-install -D -m0755 -s gpsbabel $PKG/usr/bin/gpsbabel
-install -D -m0755 -s gui/objects/gpsbabelfe-bin $PKG/usr/bin/gpsbabelfe
-install -D -m0644 gui/gmapbase.html $PKG/usr/share/gpsbabel/gmapbase.html
-install -d -m0755 $PKG/usr/share/gpsbabel/translations/
-install -D -m0644 gui/*.qm $PKG/usr/share/gpsbabel/translations/
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/gpsbabel/gpsbabel.info b/system/gpsbabel/gpsbabel.info
deleted file mode 100644
index 6131410009..0000000000
--- a/system/gpsbabel/gpsbabel.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gpsbabel"
-VERSION="1.5.3"
-HOMEPAGE="https://www.gpsbabel.org/"
-DOWNLOAD="https://github.com/gpsbabel/gpsbabel/archive/gpsbabel_1_5_3/gpsbabel-gpsbabel_1_5_3.tar.gz"
-MD5SUM="dd09e1617b0be2de03f860b7d7e4c537"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libminizip"
-MAINTAINER="Kyle Guinn"
-EMAIL="elyk03@gmail.com"
diff --git a/system/gpsbabel/slack-desc b/system/gpsbabel/slack-desc
deleted file mode 100644
index 82da398517..0000000000
--- a/system/gpsbabel/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gpsbabel: gpsbabel (GPS format converter)
-gpsbabel:
-gpsbabel: GPSBabel converts waypoints, tracks, and routes from one format
-gpsbabel: to another, whether that format is a common mapping format like
-gpsbabel: Delorme, Streets and Trips, or even a serial or USB upload or
-gpsbabel: download to a GPS receiver such as those from Garmin and Magellan.
-gpsbabel:
-gpsbabel:
-gpsbabel:
-gpsbabel:
-gpsbabel: