summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:31:01 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:31:01 +0200
commite0a9f99c7adbe54925233c3f8de42b8988db507d (patch)
tree03991c0e7278da2b6c4e0e98a27491d381e3a1d4 /system
parentd0b0e987efe68b7a1fa8eb58f0bac1bfb56ca1f1 (diff)
downloadslackbuilds-e0a9f99c7adbe54925233c3f8de42b8988db507d.tar.gz
slackbuilds-e0a9f99c7adbe54925233c3f8de42b8988db507d.tar.xz
system/bonniexx: Removed from 12.1 repository
Diffstat (limited to 'system')
-rw-r--r--system/bonniexx/Makefile.in_DESTDIR.diff34
-rw-r--r--system/bonniexx/README6
-rw-r--r--system/bonniexx/bonniexx.SlackBuild73
-rw-r--r--system/bonniexx/bonniexx.info8
-rw-r--r--system/bonniexx/slack-desc19
5 files changed, 0 insertions, 140 deletions
diff --git a/system/bonniexx/Makefile.in_DESTDIR.diff b/system/bonniexx/Makefile.in_DESTDIR.diff
deleted file mode 100644
index 3b556e0b09..0000000000
--- a/system/bonniexx/Makefile.in_DESTDIR.diff
+++ /dev/null
@@ -1,34 +0,0 @@
-Small patch to add DESTDIR support for easier packaging
-Use as you wish. --Robby Workman <rworkman@slackware.com>
-
---- orig/Makefile.in 2008-02-20 13:53:26.319108308 -0600
-+++ new/Makefile.in 2008-02-20 14:17:25.875109567 -0600
-@@ -4,6 +4,7 @@
-
- SCRIPTS=bon_csv2html bon_csv2txt
-
-+DESTDIR =
- prefix=@prefix@
- eprefix=@exec_prefix@
- #MORE_WARNINGS=-Weffc++ -Wcast-align
-@@ -33,14 +34,14 @@
- $(CXX) zcav.cpp -o zcav $(ZCAVOBJS) $(LFLAGS)
-
- install-bin: $(EXES)
-- mkdir -p $(eprefix)/bin $(eprefix)/sbin
-- @INSTALL_PROGRAM@ @stripping@ $(EXES) $(eprefix)/sbin
-- @INSTALL_SCRIPT@ $(SCRIPTS) $(eprefix)/bin
-+ mkdir -p $(DESTDIR)/$(eprefix)/bin $(DESTDIR)/$(eprefix)/sbin
-+ @INSTALL_PROGRAM@ @stripping@ $(EXES) $(DESTDIR)/$(eprefix)/sbin
-+ @INSTALL_SCRIPT@ $(SCRIPTS) $(DESTDIR)/$(eprefix)/bin
-
- install: install-bin
-- mkdir -p @mandir@/man1 @mandir@/man8
-- @INSTALL_DATA@ $(MAN1) @mandir@/man1
-- @INSTALL_DATA@ $(MAN8) @mandir@/man8
-+ mkdir -p $(DESTDIR)/@mandir@/man1 $(DESTDIR)/@mandir@/man8
-+ @INSTALL_DATA@ $(MAN1) $(DESTDIR)/@mandir@/man1
-+ @INSTALL_DATA@ $(MAN8) $(DESTDIR)/@mandir@/man8
-
- %.o: %.cpp %.h bonnie.h port.h
- $(CXX) -c $<
diff --git a/system/bonniexx/README b/system/bonniexx/README
deleted file mode 100644
index cce4ad527f..0000000000
--- a/system/bonniexx/README
+++ /dev/null
@@ -1,6 +0,0 @@
-bonnie++ (a system benchmarking tool)
-
-This benchmark is named Bonnie++ - it is based on the Bonnie benchmark
-written by Tim Bray.
-Bonnie++ adds the facility to test more than 2G of storage on a on a
-32bit machine, and tests for file creat(), stat(), unlink() operations.
diff --git a/system/bonniexx/bonniexx.SlackBuild b/system/bonniexx/bonniexx.SlackBuild
deleted file mode 100644
index 1435f3ce8b..0000000000
--- a/system/bonniexx/bonniexx.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for bonnie++
-
-# Written by Vincent Batts, vbatts@batts.mine.nu
-
-PRGNAM=bonniexx
-VERSION=1.03c
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRCNAM=bonnie++
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tgz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Small patch to Makefile.in to add DESTDIR support
-# Patch submitted to upstream --rworkman
-patch -p1 < $CWD/Makefile.in_DESTDIR.diff
-
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION
-
-make MORECFLAGS="$SLKCFLAGS"
-make install DESTDIR=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a readme.html credits.txt copyright.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/bonniexx/bonniexx.info b/system/bonniexx/bonniexx.info
deleted file mode 100644
index e785d1b008..0000000000
--- a/system/bonniexx/bonniexx.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="bonniexx"
-VERSION="1.03c"
-HOMEPAGE="http://www.coker.com.au/bonnie++/"
-DOWNLOAD="http://www.coker.com.au/bonnie++/bonnie++-1.03c.tgz"
-MD5SUM="77a1ba78f37bdd7f024b67e1e36ad151"
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@batts.mine.nu"
-APPROVED="rworkman"
diff --git a/system/bonniexx/slack-desc b/system/bonniexx/slack-desc
deleted file mode 100644
index b064a468e8..0000000000
--- a/system/bonniexx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------|
-bonniexx: bonnie++ (a system benchmarking tool)
-bonniexx:
-bonniexx: This benchmark is named Bonnie++ - it is based on the
-bonniexx: Bonnie benchmark written by Tim Bray.
-bonniexx: Bonnie++ adds the facility to test more than 2G of storage on a
-bonniexx: on a 32bit machine, and tests for file creat(), stat(), unlink()
-bonniexx: operations.
-bonniexx:
-bonniexx: Homepage: http://www.coker.com.au/bonnie++/
-bonniexx:
-bonniexx: