summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2011-04-04 11:17:43 +0200
committer Robby Workman <rworkman@slackbuilds.org>2011-04-05 18:54:18 -0500
commite7ddf6436107d7e016b74f5b2408e0efb1a0eaa4 (patch)
tree0a49099752039e45b802d2525e45211453fc3340 /system
parentd1e5a1aba9292f7cdfb296a8425e0cfd9dd7460b (diff)
downloadslackbuilds-e7ddf6436107d7e016b74f5b2408e0efb1a0eaa4.tar.gz
slackbuilds-e7ddf6436107d7e016b74f5b2408e0efb1a0eaa4.tar.xz
system/vboxgtk: Removed. Does not work with virtualbox-4.x
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/vboxgtk/README4
-rw-r--r--system/vboxgtk/doinst.sh10
-rw-r--r--system/vboxgtk/slack-desc19
-rw-r--r--system/vboxgtk/vboxgtk.SlackBuild87
-rw-r--r--system/vboxgtk/vboxgtk.info10
5 files changed, 0 insertions, 130 deletions
diff --git a/system/vboxgtk/README b/system/vboxgtk/README
deleted file mode 100644
index adaeff13b1..0000000000
--- a/system/vboxgtk/README
+++ /dev/null
@@ -1,4 +0,0 @@
-VBoxGtk is a simple GTK frontend for VirtualBox. Its objective is to support
-only the basic features of VirtualBox and keep the interface simple and clean.
-
-This requires virtualbox-ose.
diff --git a/system/vboxgtk/doinst.sh b/system/vboxgtk/doinst.sh
deleted file mode 100644
index 0b28dadc4a..0000000000
--- a/system/vboxgtk/doinst.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-if [ -x usr/bin/update-desktop-database ]; then
- usr/bin/update-desktop-database -q usr/share/applications
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
diff --git a/system/vboxgtk/slack-desc b/system/vboxgtk/slack-desc
deleted file mode 100644
index 49e763deb4..0000000000
--- a/system/vboxgtk/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler--------------------------------------------------|
-vboxgtk: vboxgtk (Simple GTK fronted for VirtualBox)
-vboxgtk:
-vboxgtk: VBoxGtk is a simple GTK frontend for VirtualBox. Its objective is
-vboxgtk: to support only the basic features of VirtualBox and keep the
-vboxgtk: interface simple and clean.
-vboxgtk:
-vboxgtk: Homepage: http://vboxgtk.sourceforge.net/
-vboxgtk:
-vboxgtk:
-vboxgtk:
-vboxgtk:
diff --git a/system/vboxgtk/vboxgtk.SlackBuild b/system/vboxgtk/vboxgtk.SlackBuild
deleted file mode 100644
index 9a31c469b2..0000000000
--- a/system/vboxgtk/vboxgtk.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for vboxgtk
-
-# Copyright 2009-2010 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=vboxgtk
-VERSION=0.5.2
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL PKG-INFO README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/vboxgtk/vboxgtk.info b/system/vboxgtk/vboxgtk.info
deleted file mode 100644
index 6498864c5f..0000000000
--- a/system/vboxgtk/vboxgtk.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="vboxgtk"
-VERSION="0.5.2"
-HOMEPAGE="http://vboxgtk.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/vboxgtk/vboxgtk-0.5.2.tar.gz"
-MD5SUM="48a808b7f069df52d9e857c6e9b14d61"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
-APPROVED="Erik Hanson"