summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dugan Chen <thedoogster [at] gmail [dot] com>2016-08-10 08:32:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-10 08:32:19 +0700
commitf6be14aaa0177578cf9e8c3899774b24ab87c9a6 (patch)
tree45d07c3f50c13d385091c2ee1648a0536592cc75 /system
parent159e7d50f3a02d76c66b7f84950f3356286645cd (diff)
downloadslackbuilds-f6be14aaa0177578cf9e8c3899774b24ab87c9a6.tar.gz
slackbuilds-f6be14aaa0177578cf9e8c3899774b24ab87c9a6.tar.xz
games/innoextract: Updated for version 1.6 (Moved from system).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/innoextract/README15
-rw-r--r--system/innoextract/innoextract-1.4-cmake-3.5.patch31
-rw-r--r--system/innoextract/innoextract.SlackBuild104
-rw-r--r--system/innoextract/innoextract.info10
-rw-r--r--system/innoextract/slack-desc19
5 files changed, 0 insertions, 179 deletions
diff --git a/system/innoextract/README b/system/innoextract/README
deleted file mode 100644
index 7311965c9d..0000000000
--- a/system/innoextract/README
+++ /dev/null
@@ -1,15 +0,0 @@
-While Inno Setup is a tool to create installers for Microsoft Windows
-applications, innoextract allows you to extract such installers without using
-Wine. In particular, innoextract supports GOG.com installers and Arx Fatalis
-patches.
-
-To extract a file to the current directory, run:
-
-$ innoextract <file>
-
-A list of available options can be retrieved using:
-
-$ innoextract --help
-
-Documentation is also available as a manpage.
-
diff --git a/system/innoextract/innoextract-1.4-cmake-3.5.patch b/system/innoextract/innoextract-1.4-cmake-3.5.patch
deleted file mode 100644
index 0b619ac381..0000000000
--- a/system/innoextract/innoextract-1.4-cmake-3.5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 01705758dd04d937160c99c8b87c6fa2057db894 Mon Sep 17 00:00:00 2001
-From: Daniel Scharrer <daniel@constexpr.org>
-Date: Tue, 23 Feb 2016 05:45:50 +0100
-Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
-
-This makes the build system more rubust against stray variables
-coming from included CMake scripts provided by the system.
-
-Fixes build with CMake 3.5 (tested with 3.5.0-rc3).
-
-Fixes: issue #50
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 02e0308..8653b93 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2,6 +2,11 @@ project(innoextract)
-
- cmake_minimum_required(VERSION 2.8)
-
-+if(POLICY CMP0054)
-+ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
-+ cmake_policy(SET CMP0054 NEW)
-+endif()
-+
-
- # Define configuration options
-
diff --git a/system/innoextract/innoextract.SlackBuild b/system/innoextract/innoextract.SlackBuild
deleted file mode 100644
index 8674254c2f..0000000000
--- a/system/innoextract/innoextract.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for innoextract
-
-# Copyright 2013 Dugan Chen Canada
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=innoextract
-VERSION=${VERSION:-1.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix build with cmake-3.5
-# https://github.com/gentoo/gentoo/pull/1025
-patch -p1 < $CWD/innoextract-1.4-cmake-3.5.patch
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release .. \
- -DCMAKE_INSTALL_MANDIR=man
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGELOG LICENSE README.md VERSION doc/ \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/innoextract/innoextract.info b/system/innoextract/innoextract.info
deleted file mode 100644
index 7e7baf4ea5..0000000000
--- a/system/innoextract/innoextract.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="innoextract"
-VERSION="1.5"
-HOMEPAGE="http://constexpr.org/innoextract/"
-DOWNLOAD="http://constexpr.org/innoextract/files/innoextract-1.5.tar.gz"
-MD5SUM="86dc2061e86df5ae8872cb7deacfcaf5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dugan Chen"
-EMAIL="thedoogster [at] gmail [dot] com"
diff --git a/system/innoextract/slack-desc b/system/innoextract/slack-desc
deleted file mode 100644
index 37df8d9d1f..0000000000
--- a/system/innoextract/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-innoextract: innoextract (Unpacker for Inno Setup installers)
-innoextract:
-innoextract: While Inno Setup is a tool to create installers for Microsoft Windows
-innoextract: applications, innoextract allows you to extract such installers
-innoextract: without using Wine. In particular, innoextract supports GOG.com
-innoextract: installers and Arx Fatalis patches.
-innoextract:
-innoextract: http://constexpr.org/innoextract/
-innoextract:
-innoextract:
-innoextract: