summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy [AT] linuxleo.com>2016-08-26 00:49:03 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:59 +0100
commitf9cc9cf0292a0c35955b31fa432dac9327bd1dcd (patch)
treecc5a19152ded04c6bb8c0cf7257bd21aa6fb7d61 /system
parent90d74f93e82725c2823119be81b3f2f6b76c81f1 (diff)
downloadslackbuilds-f9cc9cf0292a0c35955b31fa432dac9327bd1dcd.tar.gz
slackbuilds-f9cc9cf0292a0c35955b31fa432dac9327bd1dcd.tar.xz
system/distorm3: Moved to python/distorm.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/distorm3/README7
-rw-r--r--system/distorm3/distorm3.SlackBuild86
-rw-r--r--system/distorm3/distorm3.info10
-rw-r--r--system/distorm3/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/system/distorm3/README b/system/distorm3/README
deleted file mode 100644
index 93f03ad567..0000000000
--- a/system/distorm3/README
+++ /dev/null
@@ -1,7 +0,0 @@
-diStorm3 is really a decomposer, which means it takes an
-instruction and returns a binary structure which describes
-it rather than static text, which is great for advanced
-binary code analysis.
-
-diStorm3 is super lightweight (~45KB), ultra fast and easy
-to use (a single API)!
diff --git a/system/distorm3/distorm3.SlackBuild b/system/distorm3/distorm3.SlackBuild
deleted file mode 100644
index 97aefc6752..0000000000
--- a/system/distorm3/distorm3.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for distorm3
-# Copyright 2014-2015 Barry Grundy <bgrundy[at]linuxleo.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Created v3.3.0 December 2015, Barry J. Grundy.
-
-PRGNAM=distorm3
-SRCNAM=distorm
-VERSION=${VERSION:-3.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
-\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/distorm3/distorm3.info b/system/distorm3/distorm3.info
deleted file mode 100644
index 2fcb1a7e65..0000000000
--- a/system/distorm3/distorm3.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="distorm3"
-VERSION="3.3.0"
-HOMEPAGE="https://github.com/gdabah/distorm"
-DOWNLOAD="https://github.com/gdabah/distorm/archive/v3.3.0.tar.gz"
-MD5SUM="9bf35b3632db37abb83602a0472e9743"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Barry J. Grundy"
-EMAIL="bgrundy AT linuxleo.com"
diff --git a/system/distorm3/slack-desc b/system/distorm3/slack-desc
deleted file mode 100644
index 08b3645be5..0000000000
--- a/system/distorm3/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-distorm3: distorm3 (Disassembler Library for x86/AMD64 binary streams)
-distorm3:
-distorm3: The goal of diStorm3 is to decode x86/AMD64 binary streams and return
-distorm3: a structure that describes each instruction.
-distorm3:
-distorm3: The package includes Python Bindings
-distorm3:
-distorm3:
-distorm3:
-distorm3:
-distorm3: