summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2013-11-11 23:53:14 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-11-12 01:25:04 -0600
commitfb12e1f0ddbed4aebd1d6f4e23061399ccc7deae (patch)
treec6fae7f49fe663726de777f4eb1a7114d9c2fe8f /system
parentb5f8ce7e5a72106c6659fe34b4c8e1e760a8ee7d (diff)
downloadslackbuilds-fb12e1f0ddbed4aebd1d6f4e23061399ccc7deae.tar.gz
slackbuilds-fb12e1f0ddbed4aebd1d6f4e23061399ccc7deae.tar.xz
system/virt-manager: Updated for version 0.10.0.
This almost surely still has bugs, but it's more functional that the version we had. Feedback is welcome and encouraged. Patches are even more so. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/virt-manager/doinst.sh21
-rw-r--r--system/virt-manager/slack-desc12
-rw-r--r--system/virt-manager/virt-manager.SlackBuild28
-rw-r--r--system/virt-manager/virt-manager.info12
-rw-r--r--system/virt-manager/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch20
5 files changed, 52 insertions, 41 deletions
diff --git a/system/virt-manager/doinst.sh b/system/virt-manager/doinst.sh
index ee5dc2a711..36c8205d7d 100644
--- a/system/virt-manager/doinst.sh
+++ b/system/virt-manager/doinst.sh
@@ -1,19 +1,20 @@
-schema_install() {
- SCHEMA="$1"
- GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
- chroot . gconftool-2 --makefile-install-rule \
- /etc/gconf/schemas/$SCHEMA \
- 1>/dev/null
-}
-
-schema_install virt-manager.schemas
-
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
+
diff --git a/system/virt-manager/slack-desc b/system/virt-manager/slack-desc
index 3cdc05c549..bd521e8666 100644
--- a/system/virt-manager/slack-desc
+++ b/system/virt-manager/slack-desc
@@ -1,15 +1,15 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
virt-manager: virt-manager (a gtk interface for libvirt)
virt-manager:
virt-manager: virt-manager is a gtk interface for libvirt.
-virt-manager: It supports both Xen and qemu/kvm.
+virt-manager: It supports Xen, qemu/kvm, virtualbox, and perhaps others.
virt-manager:
virt-manager:
virt-manager:
diff --git a/system/virt-manager/virt-manager.SlackBuild b/system/virt-manager/virt-manager.SlackBuild
index 415a04abe8..06af0d9f80 100644
--- a/system/virt-manager/virt-manager.SlackBuild
+++ b/system/virt-manager/virt-manager.SlackBuild
@@ -2,15 +2,12 @@
# Slackware build script for virt-manager
-# For version 0.8.3
-# Written by Ash Wiren ash@spooksoftware.com
-# Released to public domain.
-# Lots of fixes by Robby Workman
-# For version 0.9.0
+# Written by Ash Wiren ash@spooksoftware.com # Released to public domain.
# Modified by Zoran Stojakovic
+# Lots of mods by rworkman for 0.10.x
PRGNAM=virt-manager
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,29 +53,22 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- -prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
+# Add Slackware support
+patch -p1 < $CWD/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch
-make
-make install DESTDIR=$PKG
+python setup.py configure
+python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ABOUT-NLS ChangeLog AUTHORS COPYING COPYING-DOCS HACKING INSTALL NEWS README \
+ COPYING HACKING INSTALL NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/system/virt-manager/virt-manager.info b/system/virt-manager/virt-manager.info
index 7fc44c3995..ed77c586b1 100644
--- a/system/virt-manager/virt-manager.info
+++ b/system/virt-manager/virt-manager.info
@@ -1,10 +1,10 @@
PRGNAM="virt-manager"
-VERSION="0.9.4"
+VERSION="0.10.0"
HOMEPAGE="http://virt-manager.et.redhat.com"
-DOWNLOAD="http://virt-manager.et.redhat.com/download/sources/virt-manager/virt-manager-0.9.4.tar.gz"
-MD5SUM="7f724839749f6d8d2e57ce8bb8a6a76f"
+DOWNLOAD="http://virt-manager.org/download/sources/virt-manager/virt-manager-0.10.0.tar.gz"
+MD5SUM="e23b8d2a7623b4e8e256c25735f332c8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gnome-python gtk-vnc qemu rarian tunctl urlgrabber virtinst"
-MAINTAINER="Zoran Stojakovic"
-EMAIL="stojakovic.zoran@gmail.com"
+REQUIRES="libvirt-glib gnome-python2-gconf tunctl ipaddr-py urlgrabber pygobject3 gtk-vnc spice-gtk vte3"
+MAINTAINER="Robby Workman"
+EMAIL="rworkman@slackbuilds.org"
diff --git a/system/virt-manager/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch b/system/virt-manager/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch
new file mode 100644
index 0000000000..4abbf94fa4
--- /dev/null
+++ b/system/virt-manager/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch
@@ -0,0 +1,20 @@
+diff -Nur virt-manager-0.10.0.orig/virtinst/osdict.py virt-manager-0.10.0/virtinst/osdict.py
+--- virt-manager-0.10.0.orig/virtinst/osdict.py 2013-06-13 14:10:00.000000000 -0500
++++ virt-manager-0.10.0/virtinst/osdict.py 2013-11-11 17:47:51.907305561 -0600
+@@ -619,7 +619,15 @@
+ VIDEO : VMVGA_VIDEO,
+ },
+ },
+-
++ "slackware": {
++ "label": "Slackware",
++ "distro": "slackware",
++ "supported": False,
++ "devices" : {
++ DISK : VIRTIO_DISK,
++ NET : VIRTIO_NET,
++ },
++ },
+ "generic24": {
+ "label": "Generic 2.4.x kernel"
+ },