summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author DhabyX <slack.dhabyx@gmail.com>2016-07-24 10:39:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-24 11:41:23 +0700
commit3dda8bce056d1e96c8fd18a34f119335f08ea229 (patch)
tree2cb06abd7b16206ad17e418fc49a6cf1e2f99d24 /system
parent53834bbff0f5c0f8b7f893e687db2bb33b2bb95b (diff)
downloadslackbuilds-3dda8bce056d1e96c8fd18a34f119335f08ea229.tar.gz
slackbuilds-3dda8bce056d1e96c8fd18a34f119335f08ea229.tar.xz
system/hplip-plugin: Added (Binary plugin for HP devices).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/hplip-plugin/README12
-rw-r--r--system/hplip-plugin/hplip-plugin.SlackBuild110
-rw-r--r--system/hplip-plugin/hplip-plugin.info10
-rw-r--r--system/hplip-plugin/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/system/hplip-plugin/README b/system/hplip-plugin/README
new file mode 100644
index 0000000000..70c08fe5f8
--- /dev/null
+++ b/system/hplip-plugin/README
@@ -0,0 +1,12 @@
+HPLIP Plugin (Binary plugin for HP devices)
+
+Some HP printers require proprietary software technologies to allow
+full access to printer features and performance.
+
+This plug-in is required by CUPS and HPLIP software for some laserjet
+printers.
+
+HPLIP Plugin is distributed under EULA license and this script accepts
+the license for you. Do not use if you don't agree with the conditions.
+
+To check the proper installation, use the "hp-diagnose_plugin" command.
diff --git a/system/hplip-plugin/hplip-plugin.SlackBuild b/system/hplip-plugin/hplip-plugin.SlackBuild
new file mode 100644
index 0000000000..29b6224aa4
--- /dev/null
+++ b/system/hplip-plugin/hplip-plugin.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/sh
+
+# Slackware build script for hplip-plugin
+
+# Copyright 2016 Dhaby Xiloj <slack.dhabyx@gmail.com> Guatemala
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hplip-plugin
+VERSION=${VERSION:-3.16.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+PKGNAM=hplip-${VERSION}-plugin.run
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586;;
+ x86_64) ARCH=x86_64;;
+ *) echo "Not tested on this architecture"; exit 1;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ LIBSUFFIX="x86_32"
+elif [ "$ARCH" = "i686" ]; then
+ LIBSUFFIX="x86_32"
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBSUFFIX="x86_64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+
+sh $CWD/$PKGNAM --target $PRGNAM-$VERSION --noexec
+
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# create directory structure
+mkdir -p $PKG/usr/share/hplip/data/firmware
+mkdir -p $PKG/usr/share/hplip/fax/plugins
+mkdir -p $PKG/usr/share/hplip/prnt/plugins
+mkdir -p $PKG/usr/share/hplip/scan/plugins
+mkdir -p $PKG/var/lib/hp
+
+# Putting everything in place
+install -m755 bb_*-${LIBSUFFIX}.so $PKG/usr/share/hplip/scan/plugins
+install -m755 fax_marvell-${LIBSUFFIX}.so $PKG/usr/share/hplip/fax/plugins
+install -m755 hbpl1-${LIBSUFFIX}.so $PKG/usr/share/hplip/prnt/plugins
+install -m644 hp_laserjet_*.fw.gz $PKG/usr/share/hplip/data/firmware
+install -m755 lj-${LIBSUFFIX}.so $PKG/usr/share/hplip/prnt/plugins
+install -m644 plugin.spec $PKG/usr/share/hplip/
+
+cat << EOF > $PKG/var/lib/hp/hplip.state
+[plugin]
+installed = 1
+eula = 1
+version = ${VERSION}
+EOF
+
+(
+for library in $(find $PKG/usr/share/hplip -type f -name "*.so"); do
+ cd $PKG/usr/share/hplip
+ cd $(dirname $library)
+ link_name="$(basename $library | cut -d- -f1).so"
+ ln -s $(basename $library) $link_name
+done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a license.txt version.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/hplip-plugin/hplip-plugin.info b/system/hplip-plugin/hplip-plugin.info
new file mode 100644
index 0000000000..42c58a31da
--- /dev/null
+++ b/system/hplip-plugin/hplip-plugin.info
@@ -0,0 +1,10 @@
+PRGNAM="hplip-plugin"
+VERSION="3.16.5"
+HOMEPAGE="http://hplipopensource.com/node/309"
+DOWNLOAD="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.16.5-plugin.run"
+MD5SUM="7179cb3a8f23cabb52aa69a927e973fc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="DhabyX"
+EMAIL="slack.dhabyx@gmail.com"
diff --git a/system/hplip-plugin/slack-desc b/system/hplip-plugin/slack-desc
new file mode 100644
index 0000000000..cf3c07d2ff
--- /dev/null
+++ b/system/hplip-plugin/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hplip-plugin: hplip-plugin (Binary plugin for HP devices)
+hplip-plugin:
+hplip-plugin: Some HP printers require proprietary software technologies to allow
+hplip-plugin: full access to printer features and performance.
+hplip-plugin:
+hplip-plugin: This plug-in is required by CUPS and HPLIP software for
+hplip-plugin: some laserjet printers.
+hplip-plugin:
+hplip-plugin:
+hplip-plugin:
+hplip-plugin: