summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Andreas Guldstrand <andreas.guldstrand@gmail.com>2017-03-15 00:05:47 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-18 06:58:36 +0700
commit85ef10e91e6e004b2ccbda15a40a3a9a34062fb1 (patch)
tree45a91062578034d3bce44e7f19832d0aa6a5841f /system
parent21482402723c6b96454cee4ea1059dd6ea35f22c (diff)
downloadslackbuilds-85ef10e91e6e004b2ccbda15a40a3a9a34062fb1.tar.gz
slackbuilds-85ef10e91e6e004b2ccbda15a40a3a9a34062fb1.tar.xz
system/acd_cli: Added (CLI and FUSE fs for Amazon Cloud Drive).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/acd_cli/README5
-rw-r--r--system/acd_cli/acd_cli.SlackBuild88
-rw-r--r--system/acd_cli/acd_cli.info10
-rw-r--r--system/acd_cli/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/system/acd_cli/README b/system/acd_cli/README
new file mode 100644
index 0000000000..c541398dac
--- /dev/null
+++ b/system/acd_cli/README
@@ -0,0 +1,5 @@
+acd_cli provides a command line interface to Amazon Drive and allows
+Unix users to mount their drive using FUSE for read and (sequential)
+write access. It is currently in beta stage.
+
+All dependencies for this need to be built with python3 support.
diff --git a/system/acd_cli/acd_cli.SlackBuild b/system/acd_cli/acd_cli.SlackBuild
new file mode 100644
index 0000000000..d3f7bfaf9a
--- /dev/null
+++ b/system/acd_cli/acd_cli.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for acd_cli
+
+# Copyright 2017 Andreas Guldstrand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=acd_cli
+VERSION=${VERSION:-20170305+d057dc0a}
+COMMIT="d057dc0ad7aeb9816b5bcbdce2bea985b1ddb142"
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz || tar xvf $CWD/$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CONTRIBUTING.rst LICENSE README.rst docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/acd_cli/acd_cli.info b/system/acd_cli/acd_cli.info
new file mode 100644
index 0000000000..0786efb356
--- /dev/null
+++ b/system/acd_cli/acd_cli.info
@@ -0,0 +1,10 @@
+PRGNAM="acd_cli"
+VERSION="20170305+d057dc0a"
+HOMEPAGE="https://github.com/yadayada/acd_cli"
+DOWNLOAD="https://github.com/yadayada/acd_cli/archive/d057dc0ad7aeb9816b5bcbdce2bea985b1ddb142.tar.gz"
+MD5SUM="4760f896dd21bb0b3088d5bea200f918"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 python3-appdirs colorama python-dateutil python-requests requests-toolbelt SQLAlchemy python-fusepy"
+MAINTAINER="Andreas Guldstrand"
+EMAIL="andreas.guldstrand@gmail.com"
diff --git a/system/acd_cli/slack-desc b/system/acd_cli/slack-desc
new file mode 100644
index 0000000000..6d34dabe46
--- /dev/null
+++ b/system/acd_cli/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+acd_cli: acd_cli (A command line interface and FUSE fs for Amazon Cloud Drive)
+acd_cli:
+acd_cli: acd_cli provides a command line interface to Amazon Drive and allows
+acd_cli: Unix users to mount their drive using FUSE for read and (sequential)
+acd_cli: write access. It is currently in beta stage.
+acd_cli:
+acd_cli: Website: https://github.com/yadayada/acd_cli
+acd_cli:
+acd_cli:
+acd_cli:
+acd_cli: