summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Philip van der Hoeven <philip@vd-hoeven.nl>2017-08-04 23:37:04 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-08-05 07:07:38 +0700
commit07741a0fd577cc57e951cf095973ad4a8129a1fd (patch)
treedbd12206466468efc360896e64a649100098b5e6 /system
parent600b3a3b352bb0f80dbc9f45f23bbfb2cc8cdb93 (diff)
downloadslackbuilds-07741a0fd577cc57e951cf095973ad4a8129a1fd.tar.gz
slackbuilds-07741a0fd577cc57e951cf095973ad4a8129a1fd.tar.xz
system/tilix: Added (Tiling terminal emulator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/tilix/README5
-rw-r--r--system/tilix/doinst.sh15
-rw-r--r--system/tilix/slack-desc19
-rw-r--r--system/tilix/tilix.SlackBuild97
-rw-r--r--system/tilix/tilix.info10
5 files changed, 146 insertions, 0 deletions
diff --git a/system/tilix/README b/system/tilix/README
new file mode 100644
index 0000000000..7d35b86033
--- /dev/null
+++ b/system/tilix/README
@@ -0,0 +1,5 @@
+Tilix is a tiling terminal emulator which uses the VTE GTK+ 3 widget.
+It was formerly known as Terminix.
+
+To fix the configuration warning at startup enable
+'Run command as a login shell' in the Default profile.
diff --git a/system/tilix/doinst.sh b/system/tilix/doinst.sh
new file mode 100644
index 0000000000..401d987795
--- /dev/null
+++ b/system/tilix/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/system/tilix/slack-desc b/system/tilix/slack-desc
new file mode 100644
index 0000000000..df815dc819
--- /dev/null
+++ b/system/tilix/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tilix: tilix (Tiling terminal emulator)
+tilix:
+tilix: A tiling terminal emulator for Linux using GTK+ 3
+tilix:
+tilix:
+tilix:
+tilix:
+tilix:
+tilix:
+tilix:
+tilix:
diff --git a/system/tilix/tilix.SlackBuild b/system/tilix/tilix.SlackBuild
new file mode 100644
index 0000000000..45a38e3ec6
--- /dev/null
+++ b/system/tilix/tilix.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for tilix
+
+# Copyright 2017 Philip van der Hoeven, Almere, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tilix
+VERSION=${VERSION:-1.6.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Remove suffixes from pkgconfig files
+sed -i 's/gtkd-3$DC_SUFFIX/gtkd-3/g' configure.ac
+sed -i 's/vted-3$DC_SUFFIX/vted-3/g' configure.ac
+
+./autogen.sh
+./configure --prefix=/usr
+make DC='dmd' DCFLAGS='-O -inline -release -version=StdLoggerDisableTrace'
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CREDITS.md LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/tilix/tilix.info b/system/tilix/tilix.info
new file mode 100644
index 0000000000..68c2232933
--- /dev/null
+++ b/system/tilix/tilix.info
@@ -0,0 +1,10 @@
+PRGNAM="tilix"
+VERSION="1.6.4"
+HOMEPAGE="https://gnunn1.github.io/tilix-web/"
+DOWNLOAD="https://github.com/gnunn1/tilix/archive/1.6.4/tilix-1.6.4.tar.gz"
+MD5SUM="66ae2b4e2c6979c2be2dd977beef762c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="GtkD po4a vte3"
+MAINTAINER="Philip van der Hoeven"
+EMAIL="philip@vd-hoeven.nl"