summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author K. Eugene Carlson <kvngncrlsn@gmail.com>2022-03-30 21:11:43 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:19:16 +0700
commit304cbbe6d9066f23ebb11dd1eef241836f5f7d21 (patch)
tree534ef806fd78f6705d0a22f508cd6b3398c18d36 /system
parentc930ce80121739c62e6879cf05e8426f546c1143 (diff)
downloadslackbuilds-304cbbe6d9066f23ebb11dd1eef241836f5f7d21.tar.gz
slackbuilds-304cbbe6d9066f23ebb11dd1eef241836f5f7d21.tar.xz
system/pcem: Added (low-level emulator for IBM compatibles)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/pcem/README75
-rw-r--r--system/pcem/pcem.SlackBuild150
-rw-r--r--system/pcem/pcem.info10
-rw-r--r--system/pcem/plugins.diff13
-rw-r--r--system/pcem/slack-desc19
5 files changed, 267 insertions, 0 deletions
diff --git a/system/pcem/README b/system/pcem/README
new file mode 100644
index 0000000000..9d781f8022
--- /dev/null
+++ b/system/pcem/README
@@ -0,0 +1,75 @@
+PCem (low-level emulator for 1980s-1990s IBM compatibles)
+
+PCem is capable of emulating a wide array of IBM-compatible computers
+from the 1980s through the late 1990s.
+
+PCem is, for the most part, a single-threaded process, and some CPU
+frequency governors may fail to reach high enough frequencies for
+acceptable performance in emulating the higher-end models. If the
+program is unexpectedly slow, consider setting the CPU frequency
+governor to "performance" or "schedutil" mode temporarily.
+
+Required: wxGTK3
+
+ ____________
+ | Building |
+ ------------
+
+Aside from BUILD and VERSION, the following options are available when
+calling pcem.SlackBuild:
+
+ ALSA=yes # Use ALSA for MIDI output
+ NETWORKING=yes # Enable network connectivity
+ PCAP=no # Disable PCAP networking (no effect without networking)
+ PLUGINS=yes # Build the plugin engine
+
+This SlackBuild follows the vast majority of other SlackBuilds in using
+the -O2 optimization flag. That being said, -O3 is the upstream default
+for PCem. Testing revealed no obvious performance differences, but your
+mileage may vary.
+
+ _____________
+ | Rom Files |
+ -------------
+
+Rom files for individual models are required for emulation. These files
+are not included in the PCem source. Once the roms have been acquired,
+they should be placed in /usr/share/pcem or in the $HOME/.pcem directory
+for the running user:
+
+ /usr/share/pcem/roms
+ $HOME/.pcem/roms
+
+The system-wide directory is supplied by the PCem package, and the user
+directory is created when running PCem for the first time. The internal
+structure of the roms directory is non-trivial. See "README.md" after
+installation for a list of compatible guests, the necessary location of
+each rom file and technical specifications.
+
+A "pcem-roms" collection is available, but please bear in mind that
+although the roms within are ancient, they are also proprietary and
+provided without a license. The collection provides a large number of
+usable rom files in their proper positions within the roms directory
+tree.
+
+ _________________________
+ | Configuration and Use |
+ -------------------------
+
+A variety of guest-specific settings are available through the GUI menu,
+incuding the CPU to emulate, storage devices, peripherals, etc.
+
+PCem can be configured on a per-user basis by modifying
+$HOME/.pcem/pcem.cfg. This file is generated automatically at the first
+run.
+
+Keyboard shortcuts are not configurable:
+
+ Ctrl + Alt + PgDn - toggle fullscreen
+ (enter fullscreen: mouse capture on; leave: mouse capture off)
+ Ctrl + End - leave mouse capture in windowed mode
+ Ctrl + Alt + PgUp - screenshot to $HOME/.pcem/screenshots
+
+To make changes to a running session (insert disks, etc.), or to create
+blank disk images, right-click the screen area outside of fullscreen
+mode and/or mouse capture.
diff --git a/system/pcem/pcem.SlackBuild b/system/pcem/pcem.SlackBuild
new file mode 100644
index 0000000000..f3fa93810a
--- /dev/null
+++ b/system/pcem/pcem.SlackBuild
@@ -0,0 +1,150 @@
+#!/bin/bash
+
+# Slackware build script for pcem
+
+# Copyright 2022 K. Eugene Carlson Tsukuba, Japan
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pcem
+VERSION=${VERSION:-965ea55.20220306}
+SRCVERSION=${SRCVERSION:-965ea55331e7c1c5a3ca169e006150615cb65776}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+# Use ALSA=yes to output MIDI with ALSA.
+unset USE_ALSA
+[ ${ALSA:-no} = yes ] && USE_ALSA="-Duse-alsa=true"
+
+# Use NETWORKING=yes to enable networking.
+unset USE_NETWORKING
+[ ${NETWORKING:-no} = yes ] && USE_NETWORKING="-Duse-networking=true"
+
+# Use PCAP=no to disable PCAP networking. Has no effect unless networking is
+# turned on.
+unset NO_PCAP
+[ ${PCAP:-yes} = no ] && NO_PCAP="-Duse-pcap-networking=false"
+
+# Use PLUGINS=yes to build the plugin engine.
+unset USE_PLUGINS
+[ ${PLUGINS:-no} = yes ] && USE_PLUGINS="-Duse-plugin-engine=true"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX=64
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+unzip $CWD/$PRGNAM-$SRCVERSION.zip
+cd $PRGNAM-$SRCVERSION
+
+# Fix building the plugin engine with meson
+patch -p1 < $CWD/plugins.diff
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir build
+cd build
+CXXFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS" \
+meson \
+ --buildtype release \
+ $USE_ALSA \
+ $USE_NETWORKING \
+ $NO_PCAP \
+ $USE_PLUGINS \
+ --prefix=/usr \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --mandir=/usr/man \
+ ..
+ninja
+meson install --destdir=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/man/man1/pcem.man.1 $PKG/usr/man/man1/pcem.1
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# The text files saying "roms go here" aren't really necessary.
+find $PKG/usr/share/pcem/roms -name roms.txt -delete
+# File included in error.
+rm -f $PKG/usr/share/pcem/roms/mda.rom
+
+# Make the plugins directory, if appropriate
+[ ${PLUGINS:-no} = yes ] && mkdir $PKG/usr/share/pcem/plugins
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ tested.html \
+ README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.sw
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/pcem/pcem.info b/system/pcem/pcem.info
new file mode 100644
index 0000000000..5eb31dd41c
--- /dev/null
+++ b/system/pcem/pcem.info
@@ -0,0 +1,10 @@
+PRGNAM="pcem"
+VERSION="965ea55.20220306"
+HOMEPAGE="http://pcem-emulator.co.uk/"
+DOWNLOAD="https://github.com/sarah-walker-pcem/pcem/archive/965ea55331e7c1c5a3ca169e006150615cb65776/pcem-965ea55331e7c1c5a3ca169e006150615cb65776.zip"
+MD5SUM="2606944e16aa39a0c1cf4e14599c9ca2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wxGTK3"
+MAINTAINER="K. Eugene Carlson"
+EMAIL="kvngncrlsn@gmail.com"
diff --git a/system/pcem/plugins.diff b/system/pcem/plugins.diff
new file mode 100644
index 0000000000..565e55487e
--- /dev/null
+++ b/system/pcem/plugins.diff
@@ -0,0 +1,13 @@
+--- pcem-965ea55331e7c1c5a3ca169e006150615cb65776.orig/src/plugin-api/meson.build 2022-03-19 19:19:47.223202352 +0900
++++ pcem-965ea55331e7c1c5a3ca169e006150615cb65776/src/plugin-api/meson.build 2022-03-19 19:20:10.085117202 +0900
+@@ -26,7 +26,9 @@
+ )
+
+ if get_option('use-plugin-engine')
+- pcem_plugin_api = shared_library('pcem', sources: pcem_pluginapi_src, dependencies: pcem_dependencies, include_directories: pcem_include_dirs, install: true)
++ libdl = compiler.find_library('dl', required: false)
++ pcem_dependencies += libdl
++ pcem_plugin_api = shared_library('pcem-plugin-api', sources: pcem_pluginapi_src, dependencies: pcem_dependencies, include_directories: pcem_include_dirs, install: true)
+ pcem_project_libraries += pcem_plugin_api
+ else
+ pcem_src += pcem_pluginapi_src
diff --git a/system/pcem/slack-desc b/system/pcem/slack-desc
new file mode 100644
index 0000000000..910c104a8d
--- /dev/null
+++ b/system/pcem/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pcem: pcem (low-level emulator for IBM compatibles)
+pcem:
+pcem: pcem is an emulator for IBM compatibles from the 1980s through late
+pcem: 1990s.
+pcem:
+pcem: pcem will not operate without an appropriate collection of roms.
+pcem:
+pcem:
+pcem: Author: Sarah Walker
+pcem: Maintainer: Michael Manley
+pcem: http://pcem-emulator.co.uk