summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2022-03-08 22:16:48 +1300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 17:21:07 +0700
commit0b5174007e7cde8b96c28288f5c0ff474a1e0250 (patch)
treefd7098b1222dae3b9cab3c491435a9a88e8adf1b /system
parent2aaff2f3768a0f0bbea43b48c98da51d89f35787 (diff)
downloadslackbuilds-0b5174007e7cde8b96c28288f5c0ff474a1e0250.tar.gz
slackbuilds-0b5174007e7cde8b96c28288f5c0ff474a1e0250.tar.xz
system/steamos-xpad: Respect KERNEL.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/steamos-xpad/Makefile2
-rw-r--r--system/steamos-xpad/steamos-xpad.SlackBuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/system/steamos-xpad/Makefile b/system/steamos-xpad/Makefile
index 97907b3967..dd47b8423e 100644
--- a/system/steamos-xpad/Makefile
+++ b/system/steamos-xpad/Makefile
@@ -1,6 +1,6 @@
obj-m = steamos-xpad.o
-KVERSION = $(shell uname -r)
+KVERSION ?= $(shell uname -r)
all:
make -C /lib/modules/$(KVERSION)/build V=1 M=$(PWD) modules
clean:
diff --git a/system/steamos-xpad/steamos-xpad.SlackBuild b/system/steamos-xpad/steamos-xpad.SlackBuild
index da8bd5d616..96a30e0fb8 100644
--- a/system/steamos-xpad/steamos-xpad.SlackBuild
+++ b/system/steamos-xpad/steamos-xpad.SlackBuild
@@ -30,12 +30,12 @@ BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-KERNEL=$(uname -r)
+KERNEL=${KERNEL:-$(uname -r)}
PKGVER=${VERSION}_$(echo $KERNEL | tr - _)
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -67,6 +67,7 @@ sed -e 's/"xpad"/"steamos-xpad"/' xpad.c > steamos-xpad.c
# Makefile is from the ARCH AUR steamos-xpad-dkms located here:
# https://aur.archlinux.org/packages/steamos-xpad-dkms/
+export KVERSION="$KERNEL"
env -u ARCH make
mkdir -p $PKG/lib/modules/$KERNEL/kernel/drivers/input/joystick