summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2011-07-13 04:52:52 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:06 -0300
commit100c17634be70c0997a66dd9cd1bf117d1f2cebb (patch)
tree7a69654d8d8baf67b3fb0d5a52425c07a3ad4b03 /system
parent39270a63ac73accfd920f16835c109ef6c0b3429 (diff)
downloadslackbuilds-100c17634be70c0997a66dd9cd1bf117d1f2cebb.tar.gz
slackbuilds-100c17634be70c0997a66dd9cd1bf117d1f2cebb.tar.xz
system/ranger: Added (curses file manager that uses vi/vim bindings)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/ranger/README6
-rw-r--r--system/ranger/ranger.SlackBuild91
-rw-r--r--system/ranger/ranger.info10
-rw-r--r--system/ranger/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/system/ranger/README b/system/ranger/README
new file mode 100644
index 0000000000..110c4c6f7c
--- /dev/null
+++ b/system/ranger/README
@@ -0,0 +1,6 @@
+A multi-column display allows viewing in a tree-like manner. You can
+preview the content of the selected file or directory, copy or move
+files around with the VIM-like commands dd and yy, execute predefined
+applications when opening a file, etc...
+Everything is fully customizable and written in Python (2.6 and 3.1
+compatible) using curses for the text-based user interface.
diff --git a/system/ranger/ranger.SlackBuild b/system/ranger/ranger.SlackBuild
new file mode 100644
index 0000000000..3a74000f5c
--- /dev/null
+++ b/system/ranger/ranger.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-ranger
+# Copyright 2010-2011 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ranger
+VERSION=${VERSION:-1.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYING INSTALL README doc/HACKING doc/TODO \
+ doc/colorschemes.txt doc/print_colors.py doc/print_keys.py \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ranger/ranger.info b/system/ranger/ranger.info
new file mode 100644
index 0000000000..070320cfa3
--- /dev/null
+++ b/system/ranger/ranger.info
@@ -0,0 +1,10 @@
+PRGNAM="ranger"
+VERSION="1.4.2"
+HOMEPAGE="https://savannah.nongnu.org/projects/ranger/"
+DOWNLOAD="http://nongnu.uib.no/ranger/releases/ranger-1.4.2.tar.gz"
+MD5SUM="93696d44fcf039a6e3aa9efa270f70c4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="dsomero"
diff --git a/system/ranger/slack-desc b/system/ranger/slack-desc
new file mode 100644
index 0000000000..e1183b8d35
--- /dev/null
+++ b/system/ranger/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+ranger: Ranger (a curses file manager that uses vi/vim bindings)
+ranger:
+ranger: A multi-column display allows viewing in a tree-like manner. You can
+ranger: preview the content of the selected file or directory, copy or move
+ranger: files around with the VIM-like commands dd and yy, execute predefined
+ranger: applications when opening a file, etc...
+ranger: Everything is fully customizable and written in Python (2.6 and 3.1
+ranger: compatible) using curses for the text-based user interface.
+ranger:
+ranger: Homepage: https://savannah.nongnu.org/projects/ranger/
+ranger: