summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-28 21:05:36 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-28 21:26:58 -0500
commit7c9af8a39a75cc6bf516ef0e08767cd958afacdc (patch)
tree6b1acfd05c169fb55015fb504e6ef0787b79f7bd /system
parent2fadf73222ca4c5df26f425bae6ebe203a4cfc69 (diff)
downloadslackbuilds-7c9af8a39a75cc6bf516ef0e08767cd958afacdc.tar.gz
slackbuilds-7c9af8a39a75cc6bf516ef0e08767cd958afacdc.tar.xz
system/gnome-commander: Updated for version 20120801_2f83e80.
Added a patch for the new poppler, and another for gcc-4.7.x Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/gnome-commander/gcc47.patch16
-rw-r--r--system/gnome-commander/gnome-commander-poppler020.patch41
-rw-r--r--system/gnome-commander/gnome-commander.SlackBuild26
-rw-r--r--system/gnome-commander/gnome-commander.info8
4 files changed, 79 insertions, 12 deletions
diff --git a/system/gnome-commander/gcc47.patch b/system/gnome-commander/gcc47.patch
new file mode 100644
index 0000000000..5960379c72
--- /dev/null
+++ b/system/gnome-commander/gcc47.patch
@@ -0,0 +1,16 @@
+diff -Naur gnome-commander-20120801_2f83e80.orig/src/gnome-cmd-collection.h gnome-commander-20120801_2f83e80/src/gnome-cmd-collection.h
+--- gnome-commander-20120801_2f83e80.orig/src/gnome-cmd-collection.h 2012-08-01 21:05:40.000000000 +0200
++++ gnome-commander-20120801_2f83e80/src/gnome-cmd-collection.h 2012-09-28 20:41:46.264480154 +0200
+@@ -35,9 +35,9 @@
+ template <typename T>
+ struct Collection<T *>: std::set<T *>
+ {
+- void add(T *t) { insert(t); }
+- void remove(T *t) { erase(t); }
+- bool contain(T *t) const { return find(t)!=Collection::end(); }
++ void add(T *t) { this->insert(t); }
++ void remove(T *t) { this->erase(t); }
++ bool contain(T *t) const { return this->find(t)!=Collection::end(); }
+
+ GList *get_list();
+ };
diff --git a/system/gnome-commander/gnome-commander-poppler020.patch b/system/gnome-commander/gnome-commander-poppler020.patch
new file mode 100644
index 0000000000..2354f505b7
--- /dev/null
+++ b/system/gnome-commander/gnome-commander-poppler020.patch
@@ -0,0 +1,41 @@
+diff -Naur gnome-commander-20120801_2f83e80.orig/configure.in gnome-commander-20120801_2f83e80/configure.in
+--- gnome-commander-20120801_2f83e80.orig/configure.in 2012-08-01 21:05:40.000000000 +0200
++++ gnome-commander-20120801_2f83e80/configure.in 2012-09-28 20:30:08.952474818 +0200
+@@ -259,6 +259,9 @@
+ if pkg-config --max-version=0.11.2 poppler; then
+ AC_DEFINE(POPPLER_HAS_GET_PDF_VERSION, 1, [Define to 1 if poppler has support for PDFDoc::getPDFVersion()])
+ fi
++ if pkg-config --atleast-version=0.19.0 poppler; then
++ AC_DEFINE(POPPLER_HAS_SET_ERROR_CALLBACK, 1, [Define to 1 if poppler has support for setErrorCallback()])
++ fi
+ fi
+ if test "x$have_pdf" = "xyes"; then
+ AC_DEFINE(HAVE_PDF, 1, [Define to 1 if you have PDF support])
+diff -Naur gnome-commander-20120801_2f83e80.orig/src/tags/gnome-cmd-tags-poppler.cc gnome-commander-20120801_2f83e80/src/tags/gnome-cmd-tags-poppler.cc
+--- gnome-commander-20120801_2f83e80.orig/src/tags/gnome-cmd-tags-poppler.cc 2012-08-01 21:05:40.000000000 +0200
++++ gnome-commander-20120801_2f83e80/src/tags/gnome-cmd-tags-poppler.cc 2012-09-28 20:32:21.602458163 +0200
+@@ -41,7 +41,11 @@
+ static regex_t rxDate;
+ static gboolean rxDate_OK;
+
++#ifdef POPPLER_HAS_SET_ERROR_CALLBACK
++static void noErrorReporting(void *, ErrorCategory, int pos, char *msg)
++#else
+ static void noErrorReporting(int pos, char *msg, va_list args)
++#endif
+ {
+ }
+ #endif
+@@ -52,8 +56,12 @@
+ #ifdef HAVE_PDF
+ rxDate_OK = regcomp (&rxDate, "^(D:)?([12][019][0-9][0-9]([01][0-9]([0-3][0-9]([012][0-9]([0-5][0-9]([0-5][0-9])?)?)?)?)?)", REG_EXTENDED)==0;
+
++#ifdef POPPLER_HAS_SET_ERROR_CALLBACK
++ setErrorCallback(noErrorReporting, NULL);
++#else
+ setErrorFunction(noErrorReporting);
+ #endif
++#endif
+ }
+
+
diff --git a/system/gnome-commander/gnome-commander.SlackBuild b/system/gnome-commander/gnome-commander.SlackBuild
index 3499974caa..d08463338a 100644
--- a/system/gnome-commander/gnome-commander.SlackBuild
+++ b/system/gnome-commander/gnome-commander.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for <gnome-commander>
PRGNAM=gnome-commander
-VERSION=${VERSION:-1.2.8.2}
+VERSION=${VERSION:-20120801_2f83e80}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,13 +35,15 @@ else
LIBDIRSUFFIX=""
fi
+#PYTHON_ROOT=/usr/lib$LIBDIRSUFFIX/python2.7/config
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -50,26 +52,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix for the new poppler
+patch -p1 < $CWD/gnome-commander-poppler020.patch
+
+# Another for gcc-4.7.x
+patch -p1 < $CWD/gcc47.patch
+
+# This helps autodetecting pyton
+sed -i "s|PY_EXEC_PREFIX/lib|PY_EXEC_PREFIX/lib${LIBDIRSUFFIX}|" configure.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-./configure \
+./autogen.sh \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --disable-scrollkeeper \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/system/gnome-commander/gnome-commander.info b/system/gnome-commander/gnome-commander.info
index 89b98668fd..569bbf39a6 100644
--- a/system/gnome-commander/gnome-commander.info
+++ b/system/gnome-commander/gnome-commander.info
@@ -1,10 +1,10 @@
PRGNAM="gnome-commander"
-VERSION="1.2.8.2"
+VERSION="20120801_2f83e80"
HOMEPAGE="http://www.nongnu.org/gcmd/"
-DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/gnome-commander/1.2/gnome-commander-1.2.8.2.tar.gz"
-MD5SUM="d023f6f501b27ef247d89489bb8f6e9e"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/gnome-commander-20120801_2f83e80.tar.xz"
+MD5SUM="45c499bc494e9c398ef827b8281ec993"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libgnomeui rarian"
+REQUIRES="libgnomeui libunique"
MAINTAINER="Bogdan Tatarov"
EMAIL="bogdan.tatarov@gmail.com"