summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2010-05-11 23:03:48 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-16 22:24:23 -0500
commita20892105a24cdd3b8d4c36bb19b059d67e067d4 (patch)
tree67e9af40f873a38b01b907eb714b45b24428eeda /system
parente3e22ec5df8d4eac6395f969e84dd54ed73f2421 (diff)
downloadslackbuilds-a20892105a24cdd3b8d4c36bb19b059d67e067d4.tar.gz
slackbuilds-a20892105a24cdd3b8d4c36bb19b059d67e067d4.tar.xz
system/ranger: Added (an ncurses filemanager with vi keybindings)
Diffstat (limited to 'system')
-rw-r--r--system/ranger/README16
-rw-r--r--system/ranger/pkg-support.diff20
-rw-r--r--system/ranger/ranger.SlackBuild75
-rw-r--r--system/ranger/ranger.info10
-rw-r--r--system/ranger/slack-desc19
5 files changed, 140 insertions, 0 deletions
diff --git a/system/ranger/README b/system/ranger/README
new file mode 100644
index 0000000000..fafda18d12
--- /dev/null
+++ b/system/ranger/README
@@ -0,0 +1,16 @@
+Ranger: A keeper, guardian, or soldier who ranges over a region to
+protect the area or enforce the law.
+
+This is the filemanager Chuck Norris the Texas Ranger would use if he
+had a computer with a unix-like operating system. (He doesn't trust
+computers though and prefers to do the calculations himself.)
+
+After all, as a professional ranger, he needs a broad overview of his
+territory, and the multi-column display of ranger provides just that,
+rather than restricting you to the current directory only. You can
+preview the content of the selected file or directory, copy or move
+files around with the VIM-like commands dd and yy, execute predefined
+applications when opening a file, etc...
+
+Everything is fully customizable and written in Python (2.6 and 3.1
+compatible) using curses for the text-based user interface.
diff --git a/system/ranger/pkg-support.diff b/system/ranger/pkg-support.diff
new file mode 100644
index 0000000000..90651de52d
--- /dev/null
+++ b/system/ranger/pkg-support.diff
@@ -0,0 +1,20 @@
+diff -Naur ranger-master.orig/Makefile ranger-master/Makefile
+--- ranger-master.orig/Makefile 2010-04-25 23:41:15.000000000 +0100
++++ ranger-master/Makefile 2010-04-26 03:42:48.000000000 +0100
+@@ -53,10 +53,12 @@
+ false; \
+ fi
+ @echo "Installing..."
+- cp ranger.py $(PREFIX)/bin/ranger
+- cp -ruT ranger $(DEST)
+- chmod 755 $(PREFIX)/bin/ranger
+- chmod -R +rX $(DEST)
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)$(DEST)
++ cp ranger.py $(DESTDIR)$(PREFIX)/bin/ranger
++ cp -ruT ranger $(DESTDIR)$(DEST)
++ chmod 755 $(DESTDIR)$(PREFIX)/bin/ranger
++ chmod -R +rX $(DESTDIR)$(DEST)
+ @echo '--------------------------------------'
+ @echo 'Finished.'
+ @echo 'If you use BASH or ZSH, you can activate an extra feature now:'
diff --git a/system/ranger/ranger.SlackBuild b/system/ranger/ranger.SlackBuild
new file mode 100644
index 0000000000..e011dff41c
--- /dev/null
+++ b/system/ranger/ranger.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for ranger
+
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ranger
+VERSION=${VERSION:-git20100426}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+SRCDIR=ranger-master
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $SRCDIR
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p1 < $CWD/pkg-support.diff
+
+make install PREFIX=/usr DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ TODO README INSTALL COPYING HACKING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ranger/ranger.info b/system/ranger/ranger.info
new file mode 100644
index 0000000000..a56122cb6e
--- /dev/null
+++ b/system/ranger/ranger.info
@@ -0,0 +1,10 @@
+PRGNAM="ranger"
+VERSION="git20100426"
+HOMEPAGE="https://savannah.nongnu.org/projects/ranger/"
+DOWNLOAD="http://www.davidwoodfall.co.uk/sources/ranger-git20100426.tar.gz"
+MD5SUM="d72e5708a2db70774c59d5f2e4ad03fb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="rworkman"
diff --git a/system/ranger/slack-desc b/system/ranger/slack-desc
new file mode 100644
index 0000000000..7124d9aa50
--- /dev/null
+++ b/system/ranger/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+ranger: Ranger (a curses file manager that uses vi/vim bindings)
+ranger:
+ranger: A multi-column display allows viewing in a tree-like manner. You can
+ranger: preview the content of the selected file or directory, copy or move
+ranger: files around with the VIM-like commands dd and yy, execute predefined
+ranger: applications when opening a file, etc...
+ranger: Everything is fully customizable and written in Python (2.6 and 3.1
+ranger: compatible) using curses for the text-based user interface.
+ranger:
+ranger: Homepage: https://savannah.nongnu.org/projects/ranger/
+ranger: