summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Kurt Erickson <kurt_erickson@att.net>2012-01-15 11:12:40 -0600
committer Robby Workman <rworkman@slackbuilds.org>2012-01-15 11:12:40 -0600
commitab7fa95188fe3509d62df8d56f5f40bcab0dd1b8 (patch)
tree8cafd37f564d9f944725e93df6f3d40dd9ecee67 /system
parent9c634f8e5f47a4de3775f17da83b54748ec23bb0 (diff)
downloadslackbuilds-ab7fa95188fe3509d62df8d56f5f40bcab0dd1b8.tar.gz
slackbuilds-ab7fa95188fe3509d62df8d56f5f40bcab0dd1b8.tar.xz
system/reiser4progs: Added (utilities for the reiser4 filesystem)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/reiser4progs/README3
-rw-r--r--system/reiser4progs/fix_typo.patch8
-rw-r--r--system/reiser4progs/reiser4progs.SlackBuild97
-rw-r--r--system/reiser4progs/reiser4progs.info10
-rw-r--r--system/reiser4progs/slack-desc19
5 files changed, 137 insertions, 0 deletions
diff --git a/system/reiser4progs/README b/system/reiser4progs/README
new file mode 100644
index 0000000000..37a0944a73
--- /dev/null
+++ b/system/reiser4progs/README
@@ -0,0 +1,3 @@
+The reiser4progs package contains the reiser4 utilities, including
+fsck and mkfs, the library for reiser4 filesystem access and
+manipulation, and libaal, an application abstraction mechanism.
diff --git a/system/reiser4progs/fix_typo.patch b/system/reiser4progs/fix_typo.patch
new file mode 100644
index 0000000000..26e2f97f0b
--- /dev/null
+++ b/system/reiser4progs/fix_typo.patch
@@ -0,0 +1,8 @@
+--- include/repair/Makefile.am~ 2009-01-08 15:34:27.000000000 -0600
++++ include/repair/Makefile.am 2011-02-23 22:23:25.654384304 -0600
+@@ -3,4 +3,4 @@
+ master.h format.h journal.h node.h place.h item.h \
+ filter.h disk_scan.h twig_scan.h add_missing.h \
+ semantic.h lost_found.h cleanup.h tree.h alloc.h \
+- object.h status.h backup.h oid.h pset.h
++ status.h backup.h oid.h pset.h
diff --git a/system/reiser4progs/reiser4progs.SlackBuild b/system/reiser4progs/reiser4progs.SlackBuild
new file mode 100644
index 0000000000..8afcea94da
--- /dev/null
+++ b/system/reiser4progs/reiser4progs.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for reiser4progs
+
+# Written by Kurt Erickson <kurt_erickson@att.net>
+
+PRGNAM=reiser4progs
+VERSION=${VERSION:-1.0.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# fix typo in a makefile.am that trips up more recent automake
+patch -p0 < $CWD/fix_typo.patch
+
+# reiser4progs ships with older, incompatible libtools
+libtoolize --force --copy
+aclocal && autoheader && autoconf && automake --add-missing
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-libminimal \
+ --build=$ARCH-slackware-linux
+
+# --with-libaal=/usr/lib${LIBDIRSUFFIX} \
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS BUGS COPYING CREDITS CUSTOM_INSTALL_README ChangeLog \
+ INSTALL INSTALL_README README THANKS TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/reiser4progs/reiser4progs.info b/system/reiser4progs/reiser4progs.info
new file mode 100644
index 0000000000..ee41a978f7
--- /dev/null
+++ b/system/reiser4progs/reiser4progs.info
@@ -0,0 +1,10 @@
+PRGNAM="reiser4progs"
+VERSION="1.0.7"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/reiser4/"
+DOWNLOAD="http://korg.cs.utah.edu/pub/linux/utils/fs/reiser4/reiser4progs/reiser4progs-1.0.7.tar.bz2"
+MD5SUM="0f637512ad11f73739e0e44057bd59e2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Kurt Erickson"
+EMAIL="kurt_erickson@att.net"
+APPROVED="rworkman"
diff --git a/system/reiser4progs/slack-desc b/system/reiser4progs/slack-desc
new file mode 100644
index 0000000000..38548e30ce
--- /dev/null
+++ b/system/reiser4progs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+reiser4progs: reiser4progs (fsck, mkfs, libraries, and utilities for reiser4)
+reiser4progs:
+reiser4progs: The reiser4progs package contains the reiser4 utilities, including
+reiser4progs: fsck and mkfs, the library for reiser4 filesystem access and
+reiser4progs: manipulation, and libaal, an application abstraction mechanism.
+reiser4progs:
+reiser4progs: Homepage: http://www.kernel.org/pub/linux/utils/fs/reiser4/
+reiser4progs:
+reiser4progs:
+reiser4progs:
+reiser4progs: