summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2011-06-23 20:34:30 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:00 -0300
commitc00493b2b9377178dfb5c4a4ec2db9adcc874672 (patch)
tree35e3b553fb594982fa95ea3c69ead3042592f3bd /system
parentd4fc1ce320adb3b436998344c2badd42a7ad132e (diff)
downloadslackbuilds-c00493b2b9377178dfb5c4a4ec2db9adcc874672.tar.gz
slackbuilds-c00493b2b9377178dfb5c4a4ec2db9adcc874672.tar.xz
system/pcsc-lite: Updated for version 1.7.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/pcsc-lite/README12
-rw-r--r--system/pcsc-lite/README.SLACKWARE2
-rw-r--r--system/pcsc-lite/pcsc-lite.SlackBuild43
-rw-r--r--system/pcsc-lite/pcsc-lite.info8
-rw-r--r--system/pcsc-lite/slack-desc4
5 files changed, 15 insertions, 54 deletions
diff --git a/system/pcsc-lite/README b/system/pcsc-lite/README
index d718477afd..2123870c8c 100644
--- a/system/pcsc-lite/README
+++ b/system/pcsc-lite/README
@@ -3,16 +3,10 @@ Its purpose is to provide a Windows(R) SCard interface in a very small
form factor for communicating to smart cards and readers.
Compiling with "DEBUGATR=1 ./pcsc-lite.SlackBuild" enables ATR parsing
-debug output messages. Compiling with "APIDOC=1 ./pcsc-lite.SlackBuild"
-produces API .pdf documentation (for ifd handlers only, mainly intended
-for developers).
+debug output messages.
-pcsc-lite uses libhal for smart-card reader's detection, according to
-upstream's advice. If you want to use usb polling, you can pass "HALD=0"
-to the script when building in order to use libusb for detecting your
-reader (be aware that, using libusb, if your reader can be managed at
-the same time by the openct driver *and* by the pcsc-lite driver, so
-you may experience some detection issues).
+pcsc-lite no longer uses (deprecated) libhal for smart-card reader's
+detection. By default libudev is used now.
Please see README.SLACKWARE in pcsc-lite's documentation directory
for notes.
diff --git a/system/pcsc-lite/README.SLACKWARE b/system/pcsc-lite/README.SLACKWARE
index 392991f6b1..4cf8418e88 100644
--- a/system/pcsc-lite/README.SLACKWARE
+++ b/system/pcsc-lite/README.SLACKWARE
@@ -6,7 +6,7 @@ easily accomplished by adding the following to /etc/rc.d/rc.local:
For pcmcia readers, this daemon should be started after rc.pcmcia.
Beware!
-- PC/SL-lite daemon is meant as _alternative_ to openct: running rc.openctd
+- PC/SC-lite daemon is meant as _alternative_ to openct: running rc.openctd
and rc.pcscd at the same time can and will lead to unforseeable problems
(specially with usb devices that can be managed by both of them, one daemon
can claim one device, making it unavailable for other daemon).
diff --git a/system/pcsc-lite/pcsc-lite.SlackBuild b/system/pcsc-lite/pcsc-lite.SlackBuild
index 7a768870ec..263bb33085 100644
--- a/system/pcsc-lite/pcsc-lite.SlackBuild
+++ b/system/pcsc-lite/pcsc-lite.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pcsc-lite
-VERSION=${VERSION:-1.6.7}
+VERSION=${VERSION:-1.7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,14 +42,6 @@ OUTPUT=${OUTPUT:-/tmp}
# Debug is off by default
DEBUGATR=${DEBUGATR:-0}
-# API documentation building is off by default
-APIDOC=${APIDOC:-0}
-
-# Program to convert .tex files into .pdf (for APIDOC)
-TEXTOPDFBIN="/usr/share/texmf/bin/pdflatex"
-
-# 0 for conservative detection behaviour (libusb), 1 for libhal
-HALD=${HALD:-1} # using libhal behaviour by default
# README and README.DAEMON are not useful and partly outdated.
DOCFILES="DRIVERS SECURITY ChangeLog* COPYING HELP NEWS TODO AUTHORS INSTALL"
@@ -87,21 +79,17 @@ find . \
# with this script
patch -p0 < $CWD/docs-DRIVERS.diff || exit 1
-# ATR (answer to reset) debug parsing output
+# ATR (answer to reset) debug parsing output
case "$DEBUGATR" in
0) DEBUGATR_FLAG="dis" ;;
*) DEBUGATR_FLAG="en" ;;
esac
-# libusb and libhal support are mutually exclusive for reader detection:
-case "$HALD" in
- 0) LIBHAL_FLAG="--enable-libusb --disable-libhal" ;;
- *) LIBHAL_FLAG="--enable-libhal --disable-libusb" ;;
-esac
-
# --enable-runpid=/var/run/pcscd.pid, and
# --enable-muscledropdir="<libdir>/pcsc/services" are not supported anymore;
# pid directory changed to /var/run/pcscd for consistency
+# libhal support is gone
+# API docs not included anymore
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -113,8 +101,8 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-usbdropdir="/usr/lib${LIBDIRSUFFIX}/pcsc/drivers" \
+ --enable-confdir=/etc/reader.conf.d \
--${DEBUGATR_FLAG}able-debugatr \
- $LIBHAL_FLAG \
--build=$ARCH-slackware-linux
make
@@ -150,27 +138,6 @@ cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
# remove README.DAEMON, automatically installed by doc/Makefile.
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/README.DAEMON
-# .pdf api documentation files seem not to be built from .tex sources during
-# make. Most people don't need/want api docs anyway. Nonetheless tex sources
-# are removed.
-( cd $PKG/usr/doc/$PRGNAM-$VERSION/
-case "$APIDOC" in
- 1) if [ -x $TEXTOPDFBIN ]; then
- echo "Building API .pdf documentation ..."
- $TEXTOPDFBIN ifdhandler-3.tex 1>&2 >/dev/null
- else
- echo "API .pdf documentation NOT built."
- fi
- ;;
- *) echo "API .pdf documentation NOT built."
- ;;
-esac
-
-for oldfiles in *.aux *.tex *.toc *.log *.bib *.out ;
- do rm -f $oldfiles ;
-done
-)
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/system/pcsc-lite/pcsc-lite.info b/system/pcsc-lite/pcsc-lite.info
index 2b5a1b1338..00da3d800f 100644
--- a/system/pcsc-lite/pcsc-lite.info
+++ b/system/pcsc-lite/pcsc-lite.info
@@ -1,10 +1,10 @@
PRGNAM="pcsc-lite"
-VERSION="1.6.7"
+VERSION="1.7.2"
HOMEPAGE="http://pcsclite.alioth.debian.org"
-DOWNLOAD="https://alioth.debian.org/frs/download.php/3516/pcsc-lite-1.6.7.tar.bz2"
-MD5SUM="62115ae6dc6fc23da7ffe50986e84eb7"
+DOWNLOAD="https://alioth.debian.org/frs/download.php/3533/pcsc-lite-1.7.2.tar.bz2"
+MD5SUM="47e7055cfc14399fdaa1b7a4aa06e5aa"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
-APPROVED="rworkman"
+APPROVED="dsomero"
diff --git a/system/pcsc-lite/slack-desc b/system/pcsc-lite/slack-desc
index af283d5708..88de04ddf4 100644
--- a/system/pcsc-lite/slack-desc
+++ b/system/pcsc-lite/slack-desc
@@ -9,8 +9,8 @@
pcsc-lite: pcsc-lite (Middleware to access a smart card using SCard API)
pcsc-lite:
pcsc-lite: Middleware to access a smart card using SCard API (PC/SC)
-pcsc-lite: Its purpose is to provide a Windows(R) SCard interface in a
-pcsc-lite: very small form factor for communicating to smart cards and
+pcsc-lite: Its purpose is to provide a Windows(R) SCard interface in a
+pcsc-lite: very small form factor for communicating to smart cards and
pcsc-lite: readers.
pcsc-lite:
pcsc-lite: Homepage: http://alioth.debian.org/projects/pcsclite/