summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author wigums <pioneer22675@gmail.com>2018-04-06 07:26:30 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-07 08:13:16 +0700
commitdd65b9ebb7acbf8a22132a5150766c74a96ccd3d (patch)
treecf88e57e5e76008a6a9a6ae58687d75bf0308c6f /system
parentd666e14f7fa880637e76d36fadd108d78100ba54 (diff)
downloadslackbuilds-dd65b9ebb7acbf8a22132a5150766c74a96ccd3d.tar.gz
slackbuilds-dd65b9ebb7acbf8a22132a5150766c74a96ccd3d.tar.xz
system/FunkLoad: Added (load web tester).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/FunkLoad/FunkLoad.SlackBuild82
-rw-r--r--system/FunkLoad/FunkLoad.info10
-rw-r--r--system/FunkLoad/README16
-rw-r--r--system/FunkLoad/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/system/FunkLoad/FunkLoad.SlackBuild b/system/FunkLoad/FunkLoad.SlackBuild
new file mode 100644
index 0000000000..14709f1f9e
--- /dev/null
+++ b/system/FunkLoad/FunkLoad.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for FunkLoad
+
+# Copyright 2018 Wigum
+# All rights reserved.
+#
+#DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+# Version 2, December 2004
+
+# Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>
+
+# Everyone is permitted to copy and distribute verbatim or modified
+# copies of this license document, and changing it is allowed as long
+# as the name is changed.
+
+# DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+# TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+# 0. You just DO WHAT THE FUCK YOU WANT TO.
+
+PRGNAM=FunkLoad
+VERSION=${VERSION:-1.17.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/FunkLoad/FunkLoad.info b/system/FunkLoad/FunkLoad.info
new file mode 100644
index 0000000000..7e1a69d251
--- /dev/null
+++ b/system/FunkLoad/FunkLoad.info
@@ -0,0 +1,10 @@
+PRGNAM="FunkLoad"
+VERSION="1.17.1"
+HOMEPAGE="https://github.com/nuxeo/FunkLoad"
+DOWNLOAD="https://github.com/nuxeo/FunkLoad/archive/1.17.1/FunkLoad-1.17.1.tar.gz"
+MD5SUM="fb17d0636d5fb62b59eacfa0537782ee"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="wigums"
+EMAIL="pioneer22675@gmail.com"
diff --git a/system/FunkLoad/README b/system/FunkLoad/README
new file mode 100644
index 0000000000..4e29999201
--- /dev/null
+++ b/system/FunkLoad/README
@@ -0,0 +1,16 @@
+FunkLoad is a functional and load web tester, written in Python, whose
+main use cases are:
+
+Functional testing of web projects, and thus regression testing as well.
+
+Performance testing: by loading the web application and monitoring your
+servers it helps you to pinpoint bottlenecks, giving a detailed report
+of performance measurement.
+
+Load testing tool to expose bugs that do not surface in cursory testing,
+like volume testing or longevity testing.
+
+Stress testing tool to overwhelm the web application resources and test
+the application recoverability.
+
+Writing web agents by scripting any web repetitive task.
diff --git a/system/FunkLoad/slack-desc b/system/FunkLoad/slack-desc
new file mode 100644
index 0000000000..b3bdd0effd
--- /dev/null
+++ b/system/FunkLoad/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+FunkLoad: FunkLoad (load web tester)
+FunkLoad:
+FunkLoad: Functional test are pure Python scripts using the pyUnit framework
+FunkLoad: like normal unit test. Python enable complex scenarios to handle real
+FunkLoad: world applications.
+FunkLoad:
+FunkLoad:
+FunkLoad:
+FunkLoad:
+FunkLoad:
+FunkLoad: