summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Niels Horn <niels.horn@gmail.com>2011-06-25 18:28:07 +0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:56:59 -0300
commitf316d2bc9f30c782ea3927fc12e935d280d5fcbb (patch)
tree9b215ad2e37af28692b2ccf37888bb8b1d681a98 /system
parent13845052c32cfa2bbd1404172618692a6fd92311 (diff)
downloadslackbuilds-f316d2bc9f30c782ea3927fc12e935d280d5fcbb.tar.gz
slackbuilds-f316d2bc9f30c782ea3927fc12e935d280d5fcbb.tar.xz
system/vhba-module: Updated for version 20110416.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/vhba-module/README3
-rw-r--r--system/vhba-module/slack-desc2
-rw-r--r--system/vhba-module/vhba-module.SlackBuild15
-rw-r--r--system/vhba-module/vhba-module.info6
-rw-r--r--system/vhba-module/vhba-module_v730_SCSI.patch32
-rw-r--r--system/vhba-module/vhba-module_v735_Werror.patch11
6 files changed, 10 insertions, 59 deletions
diff --git a/system/vhba-module/README b/system/vhba-module/README
index 34b895c552..2ad33d96ae 100644
--- a/system/vhba-module/README
+++ b/system/vhba-module/README
@@ -1,7 +1,8 @@
This is VHBA (Virtual SCSI Host Bus adapter), a Linux kernel module which
acts as a low-level SCSI driver and which provides the SCSI layer with a
virtual SCSI adapter which can have multiple virtual devices. It is part
-of the userspace-cdemu suite, a free GPL CD/DVD-ROM device emulator for linux.
+of the userspace-cdemu suite, a free GPL CD/DVD-ROM device emulator for
+linux.
NOTE:
The resulting package will be specific for the kernel it was built on.
diff --git a/system/vhba-module/slack-desc b/system/vhba-module/slack-desc
index ab38030776..dae1354ca5 100644
--- a/system/vhba-module/slack-desc
+++ b/system/vhba-module/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
vhba-module: vhba-module (virtual scsi host bus adapter module)
vhba-module:
vhba-module: This is VHBA (Virtual SCSI Host Bus adapter), a Linux kernel
diff --git a/system/vhba-module/vhba-module.SlackBuild b/system/vhba-module/vhba-module.SlackBuild
index 8f8e3d154e..6e4303688b 100644
--- a/system/vhba-module/vhba-module.SlackBuild
+++ b/system/vhba-module/vhba-module.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for vhba-module
# Copyright 2008-2009 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2010 Niels Horn <niels.horn@gmail.com>
+# Copyright 2010-2011 Niels Horn, Rio de Janeiro, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,11 +24,11 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Maintained as of version 20100822 by Niels Horn <niels.horn@gmail.com>
-# Revision date: 2011/03/17
+# Revision date: 2011/06/08
PRGNAM=vhba-module
-VERSION=${VERSION:-20100822}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20110416}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -58,13 +58,6 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Patch from upstream for kernels 2.6.37.x
-# (thanks to Melvin Xavier for pointing me to this)
-patch -p2 < $CWD/vhba-module_v730_SCSI.patch
-
-# Patch from upstream to stop building on warnings
-patch -p2 < $CWD/vhba-module_v735_Werror.patch
-
# Use -j1 to avoid problems if larger number of jobs is defined in MAKEFLAGS
make -j1 KERNELRELEASE=$KERNEL
diff --git a/system/vhba-module/vhba-module.info b/system/vhba-module/vhba-module.info
index a14a014b01..e4d9be1727 100644
--- a/system/vhba-module/vhba-module.info
+++ b/system/vhba-module/vhba-module.info
@@ -1,8 +1,8 @@
PRGNAM="vhba-module"
-VERSION="20100822"
+VERSION="20110416"
HOMEPAGE="http://cdemu.sourceforge.net/pkg_vhba.php"
-DOWNLOAD="http://downloads.sourceforge.net/cdemu/vhba-module-20100822.tar.gz"
-MD5SUM="1d2f06ae33c5d15b7c29e467e4658aa2"
+DOWNLOAD="http://downloads.sourceforge.net/cdemu/vhba-module-20110416.tar.gz"
+MD5SUM="2f91dd4ee8648da92d625221d4275b60"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"
diff --git a/system/vhba-module/vhba-module_v730_SCSI.patch b/system/vhba-module/vhba-module_v730_SCSI.patch
deleted file mode 100644
index 46cea328dd..0000000000
--- a/system/vhba-module/vhba-module_v730_SCSI.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- trunk/vhba-module/vhba.c 2010/08/15 20:11:18 691
-+++ trunk/vhba-module/vhba.c 2011/02/27 15:56:27 730
-@@ -363,7 +363,7 @@
- spin_unlock_irqrestore(&vhost->cmd_lock, flags);
- }
-
--static int vhba_queuecommand(struct scsi_cmnd *cmd, void (*done)(struct scsi_cmnd *))
-+static int vhba_queuecommand_lck(struct scsi_cmnd *cmd, void (*done)(struct scsi_cmnd *))
- {
- struct vhba_device *vdev;
- int retval;
-@@ -388,6 +388,12 @@
- return retval;
- }
-
-+#ifdef DEF_SCSI_QCMD
-+DEF_SCSI_QCMD(vhba_queuecommand)
-+#else
-+#define vhba_queuecommand vhba_queuecommand_lck
-+#endif
-+
- static int vhba_abort(struct scsi_cmnd *cmd)
- {
- struct vhba_device *vdev;
-@@ -796,7 +802,7 @@
- .poll = vhba_ctl_poll,
- .unlocked_ioctl = vhba_ctl_ioctl,
- #ifdef CONFIG_COMPAT
-- .compat_ioctl = vhba_ctl_compat_ioctl,
-+ .compat_ioctl = vhba_ctl_compat_ioctl,
- #endif
- };
diff --git a/system/vhba-module/vhba-module_v735_Werror.patch b/system/vhba-module/vhba-module_v735_Werror.patch
deleted file mode 100644
index 92096b3ac8..0000000000
--- a/system/vhba-module/vhba-module_v735_Werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- trunk/vhba-module/Makefile 2010/08/22 22:17:02 696
-+++ trunk/vhba-module/Makefile 2011/03/11 21:20:08 735
-@@ -1,7 +1,7 @@
- VHBA_VERSION = $(shell date +%Y%m%d)
- PACKAGE = vhba-module-$(VHBA_VERSION)
-
--EXTRA_CFLAGS += -DVHBA_VERSION=\"$(VHBA_VERSION)\" -I$(PWD)
-+EXTRA_CFLAGS += -DVHBA_VERSION=\"$(VHBA_VERSION)\" -I$(PWD) -Werror
-
- obj-m += vhba.o
-