summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdevelopment/Pivy/Pivy.SlackBuild74
-rw-r--r--development/Pivy/Pivy.info10
-rw-r--r--development/Pivy/README13
-rw-r--r--development/Pivy/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/development/Pivy/Pivy.SlackBuild b/development/Pivy/Pivy.SlackBuild
new file mode 100755
index 0000000000..0874b721f8
--- /dev/null
+++ b/development/Pivy/Pivy.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for Pivy
+
+# Originally written by Aleksandar Samardzic <asamardzic@gmail.com>
+# As of version hg_20100410 maintained by Niels Horn <niels.horn@gmail.com>
+# Revision date: 2010/04/14
+
+PRGNAM=Pivy
+VERSION=${VERSION:-hg_20100410}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+ ARCHQUADLET=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+ ARCHQUADLET=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ ARCHQUADLET=""
+elif [ "$ARCH" = "arm" ]; then
+ SLKCFLAGS="-O2 -march=armv4t"
+ LIBDIRSUFFIX=""
+ ARCHQUADLET="-gnueabi"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS HACKING LICENSE NEWS README THANKS \
+ docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/Pivy/Pivy.info b/development/Pivy/Pivy.info
new file mode 100644
index 0000000000..043f7cf22c
--- /dev/null
+++ b/development/Pivy/Pivy.info
@@ -0,0 +1,10 @@
+PRGNAM="Pivy"
+VERSION="hg_20100410"
+HOMEPAGE="http://pivy.coin3d.org/"
+DOWNLOAD="http://www.nielshorn.net/_download/Pivy-hg_20100410.tar.bz2"
+MD5SUM="ccafe7981ca890a5d8533d0b75894a1f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Niels Horn"
+EMAIL="niels.horn@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/development/Pivy/README b/development/Pivy/README
new file mode 100644
index 0000000000..13af559ea2
--- /dev/null
+++ b/development/Pivy/README
@@ -0,0 +1,13 @@
+Pivy is a Python binding for Coin where the interface is implemented using
+SWIG.
+
+Pivy allows:
+ * development of Coin applications in Python
+ * interactive modification of Coin programs from within the Python
+ interpreter at runtime
+ * incorporation of Scripting Nodes into the scene graph which are capable
+ of executing Python code and callback functions
+
+This script is tested using the Mercurial snapshot from 2010/04/10.
+
+Pivy requires Coin, available on SlackBuilds.org.
diff --git a/development/Pivy/slack-desc b/development/Pivy/slack-desc
new file mode 100644
index 0000000000..5a7539595a
--- /dev/null
+++ b/development/Pivy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+Pivy: Pivy (a Coin binding for Python)
+Pivy:
+Pivy: Pivy is an extension to the Python programming language,
+Pivy: wrapping Coin C++ scene graph library for usage from Python.
+Pivy:
+Pivy: Homepage: http://pivy.coin3d.org/
+Pivy:
+Pivy:
+Pivy:
+Pivy:
+Pivy: