summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/arm/README19
-rw-r--r--network/arm/arm.SlackBuild71
-rw-r--r--network/arm/arm.info10
-rw-r--r--network/arm/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/network/arm/README b/network/arm/README
new file mode 100644
index 0000000000..9524822e45
--- /dev/null
+++ b/network/arm/README
@@ -0,0 +1,19 @@
+The anonymizing relay monitor (arm) is a terminal status monitor for Tor
+relays, intended for command-line aficionados, ssh connections, and anyone
+stuck with a tty terminal. This works much like top does for system usage,
+providing real time statistics for:
+
+ - bandwidth, cpu, and memory usage
+ - relay's current configuration
+ - logged events
+ - connection details (ip, hostname, fingerprint, and consensus data)
+ - etc.
+
+This SlackBuild will also verify the package's PGP signature
+if the following conditions are met:
+
+ - You have GnuPG installed
+ - You have Damian Johnson's (the author) public PGP key (0x9ABBEEC6)
+ in your trustedkeys.gpg keyring
+ - You have downloaded the sig file from
+ http://www.atagar.com/arm/resources/arm-${VERSION}.tar.bz2.asc
diff --git a/network/arm/arm.SlackBuild b/network/arm/arm.SlackBuild
new file mode 100644
index 0000000000..334ce54003
--- /dev/null
+++ b/network/arm/arm.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for arm
+# Written by pyllyukko - pyllyukko AT maimed dot org
+
+PRGNAM=arm
+VERSION=${VERSION:-1.4.1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+ARCH=noarch
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+
+# The package can be verified with Damian Johnson's PGP key (0x9ABBEEC6).
+# If we have GPG installed, we try to verify the signature.
+if [ -x "/usr/bin/gpg" -a -x "/usr/bin/gpgv" ]
+then
+ set +e
+ # This will check if we have the correct key in our keyring.
+ # For the trustedkeys.gpg, see "man 1 gpgv".
+ /usr/bin/gpg --keyring trustedkeys.gpg --no-default-keyring --list-keys 0x9ABBEEC6 &>/dev/null
+ GPG_RET=${?}
+ # 2 means we don't have his key, 0 means we do.
+ set -e
+ # If we have the key and the signature file, we verify the package with GPG
+ if [ ${GPG_RET} -eq 0 -a \
+ -f "${CWD}/${PRGNAM}-${VERSION}.tar.bz2.asc" ]
+ then
+ /usr/bin/gpgv "${CWD}/${PRGNAM}-${VERSION}.tar.bz2.asc"
+ fi
+fi
+
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# prereq.py checks python version and for required packages
+python src/prereq.py
+python setup.py install --root=$PKG --docPath doc/${PRGNAM}-${VERSION}
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Move the man pages. setup.py handles the compressing.
+mv -v ${PKG}/usr/share/man ${PKG}/usr
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog LICENSE README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/arm/arm.info b/network/arm/arm.info
new file mode 100644
index 0000000000..bc410b920b
--- /dev/null
+++ b/network/arm/arm.info
@@ -0,0 +1,10 @@
+PRGNAM="arm"
+VERSION="1.4.1.3"
+HOMEPAGE="http://www.atagar.com/arm/"
+DOWNLOAD="http://www.atagar.com/arm/resources/arm-1.4.1.3.tar.bz2"
+MD5SUM="92fcd7b32892ecdecce9b8a91f0787e7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="pyllyukko"
+EMAIL="pyllyukko AT maimed dot org"
+APPROVED="Niels Horn"
diff --git a/network/arm/slack-desc b/network/arm/slack-desc
new file mode 100644
index 0000000000..aa9c900848
--- /dev/null
+++ b/network/arm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |---------handy-ruler--------------------------------------------------|
+arm: arm (The anonymizing relay monitor)
+arm:
+arm: The anonymizing relay monitor (arm) is a terminal status monitor for
+arm: Tor relays, intended for command-line aficionados, ssh connections,
+arm: and anyone stuck with a tty terminal. This works much like top does
+arm: for system usage, providing real time statistics for: bandwidth, cpu,
+arm: memory usage, relay's current configuration, logged events,
+arm: connection details (ip, hostname, fingerprint, and consensus data),
+arm: etc.
+arm:
+arm: Homepage: http://www.atagar.com/arm/