summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/ranger/README16
-rw-r--r--system/ranger/pkg-support.diff20
-rw-r--r--system/ranger/ranger.SlackBuild18
-rw-r--r--system/ranger/ranger.info6
4 files changed, 19 insertions, 41 deletions
diff --git a/system/ranger/README b/system/ranger/README
index fafda18d12..45dbeaba6d 100644
--- a/system/ranger/README
+++ b/system/ranger/README
@@ -1,16 +1,8 @@
-Ranger: A keeper, guardian, or soldier who ranges over a region to
-protect the area or enforce the law.
+Ranger (a curses file manager that uses vi/vim bindings)
-This is the filemanager Chuck Norris the Texas Ranger would use if he
-had a computer with a unix-like operating system. (He doesn't trust
-computers though and prefers to do the calculations himself.)
-
-After all, as a professional ranger, he needs a broad overview of his
-territory, and the multi-column display of ranger provides just that,
-rather than restricting you to the current directory only. You can
+A multi-column display allows viewing in a tree-like manner. You can
preview the content of the selected file or directory, copy or move
files around with the VIM-like commands dd and yy, execute predefined
-applications when opening a file, etc...
-
+applications when opening a file, etc...
Everything is fully customizable and written in Python (2.6 and 3.1
-compatible) using curses for the text-based user interface.
+compatible) using curses for the text-based user interface.
diff --git a/system/ranger/pkg-support.diff b/system/ranger/pkg-support.diff
deleted file mode 100644
index 90651de52d..0000000000
--- a/system/ranger/pkg-support.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur ranger-master.orig/Makefile ranger-master/Makefile
---- ranger-master.orig/Makefile 2010-04-25 23:41:15.000000000 +0100
-+++ ranger-master/Makefile 2010-04-26 03:42:48.000000000 +0100
-@@ -53,10 +53,12 @@
- false; \
- fi
- @echo "Installing..."
-- cp ranger.py $(PREFIX)/bin/ranger
-- cp -ruT ranger $(DEST)
-- chmod 755 $(PREFIX)/bin/ranger
-- chmod -R +rX $(DEST)
-+ mkdir -p $(DESTDIR)$(PREFIX)/bin
-+ mkdir -p $(DESTDIR)$(DEST)
-+ cp ranger.py $(DESTDIR)$(PREFIX)/bin/ranger
-+ cp -ruT ranger $(DESTDIR)$(DEST)
-+ chmod 755 $(DESTDIR)$(PREFIX)/bin/ranger
-+ chmod -R +rX $(DESTDIR)$(DEST)
- @echo '--------------------------------------'
- @echo 'Finished.'
- @echo 'If you use BASH or ZSH, you can activate an extra feature now:'
diff --git a/system/ranger/ranger.SlackBuild b/system/ranger/ranger.SlackBuild
index 7c195bf6c5..758d66402b 100644
--- a/system/ranger/ranger.SlackBuild
+++ b/system/ranger/ranger.SlackBuild
@@ -23,10 +23,11 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ranger
-VERSION=${VERSION:-git20100426}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCDIR=ranger-master
+
+SRCNAM=$PRGNAM-$VERSION-e74222ee
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -44,10 +45,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -60,8 +64,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $SRCDIR
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM.tar.gz
chown -R root:root .
find . \
@@ -70,9 +75,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p1 < $CWD/pkg-support.diff
+make install PREFIX=/usr DESTDIR=$PKG MANPREFIX="/man"
-make install PREFIX=/usr DESTDIR=$PKG
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/system/ranger/ranger.info b/system/ranger/ranger.info
index a56122cb6e..f45d319b82 100644
--- a/system/ranger/ranger.info
+++ b/system/ranger/ranger.info
@@ -1,8 +1,8 @@
PRGNAM="ranger"
-VERSION="git20100426"
+VERSION="1.1.0"
HOMEPAGE="https://savannah.nongnu.org/projects/ranger/"
-DOWNLOAD="http://www.davidwoodfall.co.uk/sources/ranger-git20100426.tar.gz"
-MD5SUM="d72e5708a2db70774c59d5f2e4ad03fb"
+DOWNLOAD="http://www.very-clever.com/download/nongnu/ranger/ranger-1.1.0-e74222ee.tar.gz"
+MD5SUM="3eddf90bc0583439085112ca4bf4ee95"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Woodfall"