summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pyserial/README5
-rw-r--r--python/pyserial/pyserial.SlackBuild61
-rw-r--r--python/pyserial/pyserial.info12
-rw-r--r--python/pyserial/slack-desc6
4 files changed, 60 insertions, 24 deletions
diff --git a/python/pyserial/README b/python/pyserial/README
index bc6ddf9364..ac75193d8a 100644
--- a/python/pyserial/README
+++ b/python/pyserial/README
@@ -1 +1,4 @@
-pyserial is a python module that encapsulates access to a serial port.
+This module encapsulates the access for the serial port. It provides
+backends for Python running on Windows, OSX, Linux, BSD (possibly any
+POSIX compliant system) and IronPython.
+The module named "serial" automatically selects the appropriate backend.
diff --git a/python/pyserial/pyserial.SlackBuild b/python/pyserial/pyserial.SlackBuild
index 4cd587c49c..3e0822f4c3 100644
--- a/python/pyserial/pyserial.SlackBuild
+++ b/python/pyserial/pyserial.SlackBuild
@@ -2,19 +2,36 @@
# Slackware build script for pyserial
-# Written by Grissiom <chaos.proton@gmail.com>
+# Originally written by Grissiom <chaos.proton@gmail.com>
# Updated to 2.5_rc2 by Dustin Schnee <schnee72{at}gmail{dot}com>
+# Copyright (c) 2017 Cristiano Urban, Gonars, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyserial
-VERSION=${VERSION:-2.6}
+VERSION=${VERSION:-3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRC_VERSION=$(printf $VERSION | tr _ -)
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -25,26 +42,42 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRC_VERSION
-tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
-cd $PRGNAM-$SRC_VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE.txt README.txt PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyserial/pyserial.info b/python/pyserial/pyserial.info
index bc9b06baaa..ad5a4508e8 100644
--- a/python/pyserial/pyserial.info
+++ b/python/pyserial/pyserial.info
@@ -1,10 +1,10 @@
PRGNAM="pyserial"
-VERSION="2.6"
-HOMEPAGE="http://pyserial.sourceforge.net/index.html"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyserial/pyserial-2.6.tar.gz"
-MD5SUM="cde799970b7c1ce1f7d6e9ceebe64c98"
+VERSION="3.3"
+HOMEPAGE="https://github.com/pyserial/pyserial"
+DOWNLOAD="https://github.com/pyserial/pyserial/archive/v3.3/pyserial-3.3.tar.gz"
+MD5SUM="af48f8f9b338c187f791d2f560f8b230"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Grissiom"
-EMAIL="chaos.proton@gmail.com"
+MAINTAINER="Cristiano Urban"
+EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/python/pyserial/slack-desc b/python/pyserial/slack-desc
index fcaab8fe16..3cd355f907 100644
--- a/python/pyserial/slack-desc
+++ b/python/pyserial/slack-desc
@@ -9,10 +9,10 @@
pyserial: pyserial (python module for accessing the serial port)
pyserial:
pyserial: This module encapsulates the access for the serial port. It provides
-pyserial: backends for Python running on Windows, Linux, BSD (possibly any POSIX
-pyserial: compliant system), Jython and IronPython (.NET and Mono).
+pyserial: backends for Python running on Windows, OSX, Linux, BSD (possibly any
+pyserial: POSIX compliant system) and IronPython.
pyserial:
-pyserial: Homepage: http://pyserial.sourceforge.net
+pyserial: Homepage: https://github.com/pyserial/pyserial
pyserial:
pyserial:
pyserial: