summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/zfec/README25
-rw-r--r--libraries/zfec/slack-desc19
-rw-r--r--libraries/zfec/zfec.SlackBuild76
-rw-r--r--libraries/zfec/zfec.info10
4 files changed, 130 insertions, 0 deletions
diff --git a/libraries/zfec/README b/libraries/zfec/README
new file mode 100644
index 0000000000..93f3d9a02b
--- /dev/null
+++ b/libraries/zfec/README
@@ -0,0 +1,25 @@
+This package implements an "erasure code", or "forward error correction code".
+
+You may use this package under the GNU General Public License, version 2 or,
+at your option, any later version. You may use this package under the
+Transitive Grace Period Public Licence, version 1.0. (You may choose to use
+this package under the terms of either licence, at your option.) See the file
+COPYING.GPL for the terms of the GNU General Public License, version 2. See
+the file COPYING.TGPPL.html for the terms of the Transitive Grace Period
+Public Licence, version 1.0.
+
+The most widely known example of an erasure code is the RAID-5 algorithm which
+makes it so that in the event of the loss of any one hard drive, the stored
+data can be completely recovered. The algorithm in the zfec package has a
+similar effect, but instead of recovering from the loss of only a single
+element, it can be parameterized to choose in advance the number of elements
+whose loss it can tolerate.
+
+This package is largely based on the old "fec" library by Luigi Rizzo et al.,
+which is a mature and optimized implementation of erasure coding. The zfec
+package makes several changes from the original "fec" package, including
+addition of the Python API, refactoring of the C API to support zero-copy
+operation, a few clean-ups and optimizations of the core code itself, and the
+addition of a command-line tool named "zfec".
+
+This package requires pysetuptools, pyutil and darcsver.
diff --git a/libraries/zfec/slack-desc b/libraries/zfec/slack-desc
new file mode 100644
index 0000000000..16626d69b7
--- /dev/null
+++ b/libraries/zfec/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+zfec: zfec (fast erasure codec)
+zfec:
+zfec: Fast, portable, programmable erasure coding a.k.a. "forward error
+zfec: correction": the generation of redundant blocks of information such
+zfec: that if some blocks are lost then the original data can be recovered
+zfec: from the remaining blocks. The zfec package includes command-line
+zfec: tools, C API, Python API, and Haskell API
+zfec:
+zfec: Homepage: http://allmydata.org/trac/zfec
+zfec:
+zfec:
diff --git a/libraries/zfec/zfec.SlackBuild b/libraries/zfec/zfec.SlackBuild
new file mode 100644
index 0000000000..31345df92d
--- /dev/null
+++ b/libraries/zfec/zfec.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for zfec.
+
+# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zfec
+VERSION=${VERSION:-1.4.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING.GPL COPYING.TGPPL.html README.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build || exit 1
+python setup.py install --root=$PKG || exit 1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/zfec/zfec.info b/libraries/zfec/zfec.info
new file mode 100644
index 0000000000..e6a974fbd3
--- /dev/null
+++ b/libraries/zfec/zfec.info
@@ -0,0 +1,10 @@
+PRGNAM="zfec"
+VERSION="1.4.6"
+HOMEPAGE="http://allmydata.org/trac/zfec"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zfec/zfec-1.4.6.tar.gz"
+MD5SUM="542957786c0b5de3ff76094349d0cf0d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"