summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/lives/lives.SlackBuild9
-rw-r--r--multimedia/lives/lives.info6
-rw-r--r--multimedia/lives/osc.patch13
-rw-r--r--multimedia/lives/pulseaudio.patch163
4 files changed, 101 insertions, 90 deletions
diff --git a/multimedia/lives/lives.SlackBuild b/multimedia/lives/lives.SlackBuild
index fc56435155..c58f300101 100644
--- a/multimedia/lives/lives.SlackBuild
+++ b/multimedia/lives/lives.SlackBuild
@@ -27,7 +27,7 @@
PRGNAM=lives
SRCNAM=LiVES
-VERSION=${VERSION:-2.2.8}
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,7 +74,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p0 < $CWD/pulseaudio.patch
+patch -p2 < $CWD/osc.patch
+autoreconf -if
# includes some multilib support
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -86,16 +88,13 @@ WEED_LIBS="-L/usr/lib${LIBDIRSUFFIX}" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --enable-static=no \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-# --docdir isn't working
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION/* $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/doc/
cp -a \
ABOUT-NLS AUTHORS BUGS COPYING ChangeLog FEATURES GETTING.STARTED INSTALL \
NEWS README \
diff --git a/multimedia/lives/lives.info b/multimedia/lives/lives.info
index 39e9002d7f..29465a4aa5 100644
--- a/multimedia/lives/lives.info
+++ b/multimedia/lives/lives.info
@@ -1,8 +1,8 @@
PRGNAM="lives"
-VERSION="2.2.8"
+VERSION="2.4.0"
HOMEPAGE="http://lives.sourceforge.net"
-DOWNLOAD="http://www.xs4all.nl/~salsaman/lives/current/LiVES-2.2.8.tar.bz2"
-MD5SUM="8440e2a2b6e83655dfc39c9fef5ee903"
+DOWNLOAD="http://www.xs4all.nl/~salsaman/lives/current/LiVES-2.4.0.tar.bz2"
+MD5SUM="1a4f2fd733a081b6c62ff0227157e3be"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jack2"
diff --git a/multimedia/lives/osc.patch b/multimedia/lives/osc.patch
new file mode 100644
index 0000000000..619c2af5a7
--- /dev/null
+++ b/multimedia/lives/osc.patch
@@ -0,0 +1,13 @@
+--- a/trunk/libOSC/sendOSC/Makefile.am
++++ b/trunk/libOSC/sendOSC/Makefile.am
+@@ -19,10 +19,10 @@
+
+ sendOSC_PROGRAMS = sendOSC
+
+-installdirs:
+- $(MKDIR_P) "$(DESTDIR)$(bindir)"
++
+
+ install-exec-local:
++ $(MKDIR_P) "$(DESTDIR)$(bindir)"
+ cp -f $(sendOSC) "$(DESTDIR)$(bindir)" && chmod a+rx "$(DESTDIR)$(bindir)/$(sendOSC)"
diff --git a/multimedia/lives/pulseaudio.patch b/multimedia/lives/pulseaudio.patch
index ff0a81aeb6..11ab979245 100644
--- a/multimedia/lives/pulseaudio.patch
+++ b/multimedia/lives/pulseaudio.patch
@@ -1,21 +1,23 @@
---- src/preferences.c.orig 2015-02-07 23:58:32.000000000 +0100
-+++ src/preferences.c 2015-02-22 21:04:58.229180250 +0100
-@@ -685,12 +685,6 @@ lives_toggle_button_get_active(LIVES_TOG
- jack_rec_audio_to_clip(-1,-1,RECA_EXTERNAL);
- }
+--- src/preferences.c.orig 2015-04-17 19:02:11.000000000 +0200
++++ src/preferences.c 2015-06-02 14:56:23.861483000 +0200
+@@ -441,14 +441,6 @@
+ }
+ #endif
+ }
+- if (prefs->audio_player==AUD_PLAYER_PULSE) {
+-#ifdef HAVE_PULSE_AUDIO
+- if (prefs->perm_audio_reader) {
+- // create reader connection now, if permanent
+- pulse_rec_audio_to_clip(-1,-1,RECA_EXTERNAL);
+- }
+-#endif
+- }
}
-- if (prefs->audio_player==AUD_PLAYER_PULSE) {
-- if (prefs->perm_audio_reader) {
-- // create reader connection now, if permanent
-- pulse_rec_audio_to_clip(-1,-1,RECA_EXTERNAL);
-- }
-- }
- }
- }
---- src/callbacks.c.orig 2015-02-08 15:17:58.000000000 +0100
-+++ src/callbacks.c 2015-02-22 21:13:44.839218263 +0100
-@@ -135,13 +135,6 @@ void lives_exit (void) {
+ } else if (!rec_ext_audio&&prefs->audio_src==AUDIO_SRC_EXT) {
+--- src/callbacks.c.orig 2015-04-17 18:58:35.000000000 +0200
++++ src/callbacks.c 2015-06-02 15:09:34.683508000 +0200
+@@ -147,13 +147,6 @@
mainw->current_file=-1;
if (!mainw->only_close) {
@@ -29,7 +31,7 @@
#ifdef ENABLE_JACK
pthread_mutex_lock(&mainw->abuf_mutex);
lives_jack_end();
-@@ -1005,12 +998,6 @@ void on_stop_clicked (LiVESMenuItem *men
+@@ -1022,12 +1015,6 @@
return;
}
#endif
@@ -41,42 +43,41 @@
-#endif
#ifndef IS_MINGW
- com=g_strdup_printf("%s stopsubsubs \"%s\" 2>/dev/null",prefs->backend_sync,cfile->handle);
-@@ -4016,20 +4003,6 @@ void on_record_perf_activate (LiVESMenuI
- }
+ com=lives_strdup_printf("%s stopsubsubs \"%s\" 2>/dev/null",prefs->backend_sync,cfile->handle);
+@@ -3981,19 +3968,6 @@
+ }
#endif
-#ifdef HAVE_PULSE_AUDIO
-- if (prefs->audio_player==AUD_PLAYER_PULSE) {
-- if (mainw->agen_key==0&&!mainw->agen_needs_reinit) {
-- pulse_rec_audio_to_clip(mainw->ascrap_file, -1, RECA_EXTERNAL);
-- mainw->pulsed_read->in_use=TRUE;
-- }
-- else {
-- if (mainw->pulsed!=NULL) {
-- pulse_rec_audio_to_clip(mainw->ascrap_file, -1, RECA_GENERATED);
-- mainw->pulsed_read->in_use=TRUE;
-- }
-- }
-- }
+- if (prefs->audio_player==AUD_PLAYER_PULSE) {
+- if (mainw->agen_key==0&&!mainw->agen_needs_reinit) {
+- pulse_rec_audio_to_clip(mainw->ascrap_file, -1, RECA_EXTERNAL);
+- mainw->pulsed_read->in_use=TRUE;
+- } else {
+- if (mainw->pulsed!=NULL) {
+- pulse_rec_audio_to_clip(mainw->ascrap_file, -1, RECA_GENERATED);
+- mainw->pulsed_read->in_use=TRUE;
+- }
+- }
+- }
-#endif
- }
- return;
+ }
+ return;
}
-@@ -4042,11 +4015,6 @@ void on_record_perf_activate (LiVESMenuI
- jack_get_rec_avals(mainw->jackd);
- }
+@@ -4006,11 +3980,6 @@
+ jack_get_rec_avals(mainw->jackd);
+ }
#endif
-#ifdef HAVE_PULSE_AUDIO
-- if (prefs->audio_player==AUD_PLAYER_PULSE&&mainw->pulsed!=NULL) {
-- pulse_get_rec_avals(mainw->pulsed);
-- }
--#endif
+- if (prefs->audio_player==AUD_PLAYER_PULSE&&mainw->pulsed!=NULL) {
+- pulse_get_rec_avals(mainw->pulsed);
+- }
+-#endif
}
return;
}
-@@ -7801,15 +7769,6 @@ void on_loop_cont_activate (LiVESMenuIte
- else if (mainw->jackd!=NULL) mainw->jackd->loop=AUDIO_LOOP_NONE;
+@@ -7377,14 +7346,6 @@
+ } else if (mainw->jackd!=NULL) mainw->jackd->loop=AUDIO_LOOP_NONE;
}
#endif
-#ifdef HAVE_PULSE_AUDIO
@@ -84,14 +85,13 @@
- if (mainw->pulsed!=NULL&&(mainw->loop_cont||mainw->whentostop==NEVER_STOP)) {
- if (mainw->ping_pong&&prefs->audio_opts&AUDIO_OPTS_FOLLOW_FPS) mainw->pulsed->loop=AUDIO_LOOP_PINGPONG;
- else mainw->pulsed->loop=AUDIO_LOOP_FORWARD;
-- }
-- else if (mainw->pulsed!=NULL) mainw->pulsed->loop=AUDIO_LOOP_NONE;
+- } else if (mainw->pulsed!=NULL) mainw->pulsed->loop=AUDIO_LOOP_NONE;
- }
-#endif
}
-@@ -7822,12 +7781,6 @@ void on_ping_pong_activate (LiVESMenuIte
+@@ -7397,12 +7358,6 @@
else mainw->jackd->loop=AUDIO_LOOP_FORWARD;
}
#endif
@@ -104,7 +104,7 @@
}
-@@ -7910,17 +7863,6 @@ void on_mute_activate (LiVESMenuItem *me
+@@ -7484,17 +7439,6 @@
}
}
#endif
@@ -113,7 +113,7 @@
- mainw->pulsed->mute=mainw->mute;
- if (mainw->pulsed->playing_file==mainw->current_file&&cfile->achans>0&&!mainw->is_rendering) {
- if (!pulse_audio_seek_bytes(mainw->pulsed, mainw->pulsed->seek_pos)) {
-- if (pulse_try_reconnect()) pulse_audio_seek_bytes(mainw->pulsed,mainw->pulsed->seek_pos);
+- if (pulse_try_reconnect()) pulse_audio_seek_bytes(mainw->pulsed,mainw->pulsed->seek_pos);
- }
- mainw->pulsed->in_use=TRUE;
- }
@@ -122,68 +122,68 @@
}
-@@ -9287,11 +9229,6 @@ boolean config_event (LiVESWidget *widge
- jack_driver_activate(mainw->jackd);
+@@ -9165,11 +9109,6 @@
+ jack_driver_activate(mainw->jackd);
}
#endif
-#ifdef HAVE_PULSE_AUDIO
- if (mainw->pulsed!=NULL) {
-- pulse_driver_activate(mainw->pulsed);
+- pulse_driver_activate(mainw->pulsed);
- }
-#endif
}
mainw->is_ready=TRUE;
if (palette->style&STYLE_1) widget_opts.apply_theme=TRUE;
-@@ -9406,8 +9343,7 @@ void on_effects_paused (LiVESButton *but
- d_print(_ ("paused..."));
+@@ -9283,8 +9222,7 @@
+ d_print(_("paused..."));
}
#ifdef RT_AUDIO
- if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use)
-- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed_read->in_use))
-+ if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
- lives_widget_hide(cfile->proc_ptr->stop_button);
+- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed_read->in_use))
++ if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
+ lives_widget_hide(cfile->proc_ptr->stop_button);
#endif
} else {
-@@ -9421,16 +9357,14 @@ void on_effects_paused (LiVESButton *but
- d_print(_ ("resumed..."));
+@@ -9298,16 +9236,14 @@
+ d_print(_("resumed..."));
}
#ifdef RT_AUDIO
- if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use)
-- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed_read->in_use))
-+ if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
- lives_widget_show(cfile->proc_ptr->stop_button);
+- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed_read->in_use))
++ if ((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
+ lives_widget_show(cfile->proc_ptr->stop_button);
#endif
}
if (!cfile->opening&&!mainw->internal_messaging
#ifdef RT_AUDIO
-- &&!((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use)
-- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed->in_use))
-+ &&!((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
+- &&!((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use)
+- ||(mainw->pulsed!=NULL&&mainw->pulsed_read!=NULL&&mainw->pulsed->in_use))
++ &&!((mainw->jackd!=NULL&&mainw->jackd_read!=NULL&&mainw->jackd_read->in_use))
#endif
- ) {
+ ) {
lives_system(com,FALSE);
-@@ -9709,19 +9643,6 @@ void changed_fps_during_pb (LiVESSpinBut
+@@ -9581,19 +9517,6 @@
}
}
#endif
-
-#ifdef HAVE_PULSE_AUDIO
- if (prefs->audio_player==AUD_PLAYER_PULSE&&mainw->pulsed!=NULL&&mainw->pulsed->playing_file==mainw->current_file&&
-- !(mainw->record&&!mainw->record_paused&&prefs->audio_src==AUDIO_SRC_EXT)) {
+- !(mainw->record&&!mainw->record_paused&&prefs->audio_src==AUDIO_SRC_EXT)) {
-
- mainw->pulsed->in_arate=cfile->arate*cfile->pb_fps/cfile->fps;
- if (mainw->agen_key==0&&!mainw->agen_needs_reinit&&!has_audio_filters(AF_TYPE_NONA)) {
-- mainw->rec_aclip=mainw->current_file;
-- mainw->rec_avel=cfile->pb_fps/cfile->fps;
-- mainw->rec_aseek=(double)mainw->pulsed->seek_pos/(double)(cfile->arate*cfile->achans*cfile->asampsize/8);
+- mainw->rec_aclip=mainw->current_file;
+- mainw->rec_avel=cfile->pb_fps/cfile->fps;
+- mainw->rec_aseek=(double)mainw->pulsed->seek_pos/(double)(cfile->arate*cfile->achans*cfile->asampsize/8);
- }
- }
-#endif
}
if (cfile->play_paused) {
-@@ -10234,14 +10155,6 @@ boolean freeze_callback (LiVESAccelGroup
+@@ -10100,14 +10023,6 @@
if (cfile->play_paused) jack_pb_stop();
else jack_pb_start();
#endif
@@ -195,28 +195,27 @@
- mainw->pulsed->is_paused=cfile->play_paused;
- }
-#endif
-
+
return TRUE;
}
-@@ -10274,17 +10187,6 @@ boolean show_sync_callback (LiVESAccelGr
+@@ -10137,16 +10052,6 @@
+ #else
+ return FALSE;
#endif
- }
-
+- }
+-
- if (prefs->audio_player==AUD_PLAYER_PULSE) {
-#ifdef HAVE_PULSE_AUDIO
- if (mainw->pulsed!=NULL&&mainw->pulsed->in_use) avsync=(double)mainw->pulsed->seek_pos/
-- cfile->arate/cfile->achans/cfile->asampsize*8;
+- cfile->arate/cfile->achans/cfile->asampsize*8;
- else return FALSE;
-#else
- return FALSE;
-#endif
-- }
-- else return FALSE;
--
- avsync-=(mainw->actual_frame-1.)/cfile->fps;
+ } else return FALSE;
- msg=g_strdup_printf(_("Audio is ahead of video by %.4f secs. at frame %d, with fps %.4f\n"),
-@@ -11518,12 +11420,6 @@ void on_recaudclip_ok_clicked (LiVESButt
+ avsync-=(mainw->actual_frame-1.)/cfile->fps;
+@@ -11386,12 +11291,6 @@
mainw->jackd_read->in_use=TRUE;
}
#endif