summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/dhcpy6d/README6
-rw-r--r--python/dhcpy6d/dhcpy6d.SlackBuild110
-rw-r--r--python/dhcpy6d/dhcpy6d.info10
-rw-r--r--python/dhcpy6d/doinst.sh27
-rw-r--r--python/dhcpy6d/slack-desc19
5 files changed, 172 insertions, 0 deletions
diff --git a/python/dhcpy6d/README b/python/dhcpy6d/README
new file mode 100644
index 0000000000..c54af0e843
--- /dev/null
+++ b/python/dhcpy6d/README
@@ -0,0 +1,6 @@
+Dhcpy6d delivers IPv6 addresses for DHCPv6 clients, which can be
+identified by DUID, hostname or MAC address as in the good old IPv4
+days. It allows easy dualstack transistion, addresses may be generated
+randomly, by range, by arbitrary ID or MAC address. Clients can get
+more than one address, leases and client configuration can be stored
+in databases and DNS can be updated dynamically.
diff --git a/python/dhcpy6d/dhcpy6d.SlackBuild b/python/dhcpy6d/dhcpy6d.SlackBuild
new file mode 100644
index 0000000000..889ad05d7b
--- /dev/null
+++ b/python/dhcpy6d/dhcpy6d.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/sh
+
+# Slackware build script for dhcpy6d
+
+# Copyright 2015 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=dhcpy6d
+VERSION=${VERSION:-0.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+if [ "$(grep ^dhcpy6d /etc/passwd)" = "" -o "$(grep ^dhcpy6d /etc/group)" = "" ] ; then
+ printf "\nYou must have a dhcpy6d user and group.\n\nExample:\n"
+ printf "\t# groupadd -g 313 dhcpy6d\n"
+ printf "\t# /usr/sbin/useradd -r -s /sbin/nologin -d /var/lib/dhcpy6d -M -u 313 -g dhcpy6d dhcpy6d\n\n"
+ exit 1
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/bin $PKG/usr/sbin
+
+mv $PKG/etc/dhcpy6d.conf $PKG/etc/dhcpy6d.conf.new
+
+mkdir -p $PKG/etc/rc.d
+cat redhat/init.d/dhcpy6d > $PKG/etc/rc.d/rc.dhcpy6d.new
+
+mkdir -p $PKG/etc/logrotate.d
+cat etc/logrotate.d/dhcpy6d > $PKG/etc/logrotate.d/dhcpy6d.new
+
+chown dhcpy6d:dhcpy6d $PKG/var/log/dhcpy6d.log
+
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mv $PKG/usr/share/doc $PKG/usr/doc
+mv $PKG/usr/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changelog README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/dhcpy6d/dhcpy6d.info b/python/dhcpy6d/dhcpy6d.info
new file mode 100644
index 0000000000..8e4f753eae
--- /dev/null
+++ b/python/dhcpy6d/dhcpy6d.info
@@ -0,0 +1,10 @@
+PRGNAM="dhcpy6d"
+VERSION="0.4.2"
+HOMEPAGE="https://dhcpy6d.ifw-dresden.de/"
+DOWNLOAD="https://dhcpy6d.ifw-dresden.de/files-dhcpy6d/stable/dhcpy6d-0.4.2.tar.gz"
+MD5SUM="dcc3e79436f3c59919167afbf6566ca1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"
diff --git a/python/dhcpy6d/doinst.sh b/python/dhcpy6d/doinst.sh
new file mode 100644
index 0000000000..b082aee50d
--- /dev/null
+++ b/python/dhcpy6d/doinst.sh
@@ -0,0 +1,27 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+preserve_perms() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+ fi
+ config $NEW
+}
+
+preserve_perms etc/rc.d/rc.dhcpy6d.new
+config etc/dhcpy6d.conf.new
+config etc/logrotate.d/dhcpy6d.new
diff --git a/python/dhcpy6d/slack-desc b/python/dhcpy6d/slack-desc
new file mode 100644
index 0000000000..213c98a6af
--- /dev/null
+++ b/python/dhcpy6d/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dhcpy6d: dhcpy6d (DHCPv6 server daemon)
+dhcpy6d:
+dhcpy6d: Dhcpy6d delivers IPv6 addresses for DHCPv6 clients, which can be
+dhcpy6d: identified by DUID, hostname or MAC address as in the good old IPv4
+dhcpy6d: days. It allows easy dualstack transistion, addresses may be generated
+dhcpy6d: randomly, by range, by arbitrary ID or MAC address. Clients can get
+dhcpy6d: more than one address, leases and client configuration can be stored
+dhcpy6d: in databases and DNS can be updated dynamically.
+dhcpy6d:
+dhcpy6d:
+dhcpy6d: