summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/rtmpdump/README5
-rw-r--r--multimedia/rtmpdump/rtmpdump-makefiles.patch48
-rw-r--r--multimedia/rtmpdump/rtmpdump.SlackBuild87
-rw-r--r--multimedia/rtmpdump/rtmpdump.info10
-rw-r--r--multimedia/rtmpdump/slack-desc19
5 files changed, 169 insertions, 0 deletions
diff --git a/multimedia/rtmpdump/README b/multimedia/rtmpdump/README
new file mode 100644
index 0000000000..2c133e819b
--- /dev/null
+++ b/multimedia/rtmpdump/README
@@ -0,0 +1,5 @@
+rtmpdump is a toolkit for RTMP streams.
+All forms of RTMP are supported, including rtmp://, rtmpt://,
+rtmpe://, rtmpte://, and rtmps://.
+This package contains the library, librtmp, and the binaries
+rtmpdump, rtmpgw, rtmpsrv and rtmpsuck.
diff --git a/multimedia/rtmpdump/rtmpdump-makefiles.patch b/multimedia/rtmpdump/rtmpdump-makefiles.patch
new file mode 100644
index 0000000000..a1bdb7761c
--- /dev/null
+++ b/multimedia/rtmpdump/rtmpdump-makefiles.patch
@@ -0,0 +1,48 @@
+diff -Naur rtmpdump-2.2e.orig/Makefile rtmpdump-2.2e/Makefile
+--- rtmpdump-2.2e.orig/Makefile 2010-05-29 09:42:20.000000000 +0200
++++ rtmpdump-2.2e/Makefile 2010-06-14 21:22:21.904425447 +0200
+@@ -57,7 +57,7 @@
+ cp rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT) $(SBINDIR)
+ cp rtmpdump.1 $(MANDIR)/man1
+ cp rtmpgw.8 $(MANDIR)/man8
+- @cd librtmp; $(MAKE) install $(MAKEFLAGS)
++ @cd librtmp; $(MAKE) install
+
+ clean:
+ rm -f *.o rtmpdump$(EXT) rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT)
+diff -Naur rtmpdump-2.2e.orig/librtmp/Makefile rtmpdump-2.2e/librtmp/Makefile
+--- rtmpdump-2.2e.orig/librtmp/Makefile 2010-05-29 09:42:20.000000000 +0200
++++ rtmpdump-2.2e/librtmp/Makefile 2010-06-14 21:23:12.932433342 +0200
+@@ -28,7 +28,7 @@
+ LIBDIR=$(DESTDIR)$(libdir)
+ MANDIR=$(DESTDIR)$(mandir)
+
+-all: librtmp.a
++all: librtmp.a librtmp.so librtmp.pc
+
+ clean:
+ rm -f *.o *.a
+@@ -36,6 +36,9 @@
+ librtmp.a: rtmp.o log.o amf.o hashswf.o parseurl.o
+ $(AR) rs $@ $?
+
++librtmp.so: rtmp.o log.o amf.o hashswf.o parseurl.o
++ $(CC) -shared -Wl,-soname,librtmp.so.2 -o librtmp.so.2.2 *.o
++
+ log.o: log.c log.h Makefile
+ rtmp.o: rtmp.c rtmp.h rtmp_sys.h handshake.h dh.h log.h amf.h Makefile
+ amf.o: amf.c amf.h bytes.h log.h Makefile
+@@ -46,9 +49,12 @@
+ sed -e "s;@prefix@;$(prefix);" -e "s;@VERSION@;$(VERSION);" \
+ -e "s;@CRYPTO_REQ@;$(CRYPTO_REQ);" librtmp.pc.in > $@
+
+-install: librtmp.a librtmp.pc
++install: librtmp.a librtmp.so librtmp.pc
+ -mkdir -p $(INCDIR) $(LIBDIR)/pkgconfig $(MANDIR)/man3
+ cp amf.h http.h log.h rtmp.h $(INCDIR)
+ cp librtmp.a $(LIBDIR)
++ ln -s librtmp.so.2.2 librtmp.so.2
++ ln -s librtmp.so.2.2 librtmp.so
++ cp -a librtmp.s* $(LIBDIR)
+ cp librtmp.pc $(LIBDIR)/pkgconfig
+ cp librtmp.3 $(MANDIR)/man3
diff --git a/multimedia/rtmpdump/rtmpdump.SlackBuild b/multimedia/rtmpdump/rtmpdump.SlackBuild
new file mode 100644
index 0000000000..ff7ad46864
--- /dev/null
+++ b/multimedia/rtmpdump/rtmpdump.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for rtmpdump
+
+# Written by Matteo Bernardini <matteo.bernardini {at} sns.it>
+# based on slackbuilds.org default autotools-template
+
+# Modified by SlackBuilds.org
+
+PRGNAM=rtmpdump
+VERSION=${VERSION:-2.2e}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# patch makefiles for shared library install
+patch -p1 < $CWD/rtmpdump-makefiles.patch
+
+XCFLAGS="$SLKCFLAGS" \
+make \
+ prefix=/usr \
+ libdir=/usr/lib$LIBDIRSUFFIX
+
+XCFLAGS="$SLKCFLAGS" \
+make \
+ prefix=/usr \
+ libdir=/usr/lib$LIBDIRSUFFIX \
+ DESTDIR=$PKG \
+ install
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/multimedia/rtmpdump/rtmpdump.info b/multimedia/rtmpdump/rtmpdump.info
new file mode 100644
index 0000000000..be3b792f70
--- /dev/null
+++ b/multimedia/rtmpdump/rtmpdump.info
@@ -0,0 +1,10 @@
+PRGNAM="rtmpdump"
+VERSION="2.2e"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+DOWNLOAD="http://rtmpdump.mplayerhq.hu/download/rtmpdump-2.2e.tar.gz"
+MD5SUM="10681c2fe41194a97d508d0e6bbfe74f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="matteo.bernardini {at} sns.it"
+APPROVED="pprkut"
diff --git a/multimedia/rtmpdump/slack-desc b/multimedia/rtmpdump/slack-desc
new file mode 100644
index 0000000000..5e4ca52453
--- /dev/null
+++ b/multimedia/rtmpdump/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+rtmpdump: rtmpdump (RTMP streams toolkit)
+rtmpdump:
+rtmpdump: rtmpdump is a toolkit for RTMP streams.
+rtmpdump: All forms of RTMP are supported, including rtmp://, rtmpt://,
+rtmpdump: rtmpe://, rtmpte://, and rtmps://.
+rtmpdump: This package contains the library, librtmp, and the binaries rtmpdump,
+rtmpdump: rtmpgw, rtmpsrv and rtmpsuck.
+rtmpdump:
+rtmpdump: Homepage: http://rtmpdump.mplayerhq.hu/
+rtmpdump:
+rtmpdump: