summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-twisted-web2/README17
-rw-r--r--python/python-twisted-web2/python-twisted-web2.SlackBuild83
-rw-r--r--python/python-twisted-web2/python-twisted-web2.info10
-rw-r--r--python/python-twisted-web2/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/python-twisted-web2/README b/python/python-twisted-web2/README
deleted file mode 100644
index bd04ddfb30..0000000000
--- a/python/python-twisted-web2/README
+++ /dev/null
@@ -1,17 +0,0 @@
-Twisted.Web2 is an experimental web server built with Twisted. Useful Web2
-functionality will be backported to TwistedWeb until TwistedWeb is as
-featureful as Web2, then Web2 will be abandoned.
-
-Improvements over Twisted.Web:
-* Streaming upload data
-* Separation of low level HTTP and high level request handling which allows
- it to run under other transports such as SCGI and CGI
-* IResource API improvements from Nevow
-* More versatile outgoing data streaming API
-* Correct header parsing
-* Full HTTP/1.1 support
-* Output filters (HTTP range support in a generic fashion, and gzip support)
-* Significantly better URI Rewriting when used behind a proxy such as Apache's
- mod_proxy
-
-Twisted Web2 is available under the MIT Free Software licence.
diff --git a/python/python-twisted-web2/python-twisted-web2.SlackBuild b/python/python-twisted-web2/python-twisted-web2.SlackBuild
deleted file mode 100644
index 9f85b086d6..0000000000
--- a/python/python-twisted-web2/python-twisted-web2.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/sh
-# Slackware build script for python-twisted-web2, based on python-twisted
-# SlackBuild by Marco Bonetti <sid77@slackware.it>
-#
-# Lionel Young <redtricycle@gmail.com>
-#
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-twisted-web2
-SRCNAM=TwistedWeb2
-VERSION=${VERSION:-8.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="LICENSE NEWS README doc/examples/ doc/howto/"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-
-python setup.py install --root=$PKG || exit 1
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-twisted-web2/python-twisted-web2.info b/python/python-twisted-web2/python-twisted-web2.info
deleted file mode 100644
index cdd39b27de..0000000000
--- a/python/python-twisted-web2/python-twisted-web2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-twisted-web2"
-VERSION="8.1.0"
-HOMEPAGE="http://twistedmatrix.com/"
-DOWNLOAD="http://twistedmatrix.com/Releases/Web2/8.1/TwistedWeb2-8.1.0.tar.bz2"
-MD5SUM="e34b48edf6fef075bd41ddbd215aed32"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-twisted"
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
diff --git a/python/python-twisted-web2/slack-desc b/python/python-twisted-web2/slack-desc
deleted file mode 100644
index f6fe66d918..0000000000
--- a/python/python-twisted-web2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-twisted-web2: python-twisted-web2 (Experimental Twisted web server)
-python-twisted-web2:
-python-twisted-web2: Twisted.Web2 is an experimental web server built with Twisted.
-python-twisted-web2: Useful Web2 functionality will be backported to TwistedWeb until
-python-twisted-web2: TwistedWeb is as featureful as Web2, then Web2 will be abandoned.
-python-twisted-web2:
-python-twisted-web2: Homepage: http://twistedmatrix.com
-python-twisted-web2:
-python-twisted-web2:
-python-twisted-web2:
-python-twisted-web2: