summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/weboob/README2
-rw-r--r--network/weboob/doinst.sh9
-rw-r--r--network/weboob/slack-desc19
-rw-r--r--network/weboob/weboob.SlackBuild77
-rw-r--r--network/weboob/weboob.info10
5 files changed, 0 insertions, 117 deletions
diff --git a/network/weboob/README b/network/weboob/README
deleted file mode 100644
index fa3f535370..0000000000
--- a/network/weboob/README
+++ /dev/null
@@ -1,2 +0,0 @@
-weboob (Web Out Of Browsers) provides several applications to
-interact with a lot of websites.
diff --git a/network/weboob/doinst.sh b/network/weboob/doinst.sh
deleted file mode 100644
index 65c7e2eeb9..0000000000
--- a/network/weboob/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/network/weboob/slack-desc b/network/weboob/slack-desc
deleted file mode 100644
index 2985003e0f..0000000000
--- a/network/weboob/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-weboob: weboob (applications to interact with websites)
-weboob:
-weboob: weboob (Web Out Of Browsers) provides several applications to
-weboob: interact with a lot of websites.
-weboob:
-weboob: Homepage: http://symlink.me/projects/weboob
-weboob:
-weboob:
-weboob:
-weboob:
-weboob:
diff --git a/network/weboob/weboob.SlackBuild b/network/weboob/weboob.SlackBuild
deleted file mode 100644
index 7652566c9d..0000000000
--- a/network/weboob/weboob.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for weboob
-
-# Copyright (C) 2011, Brice Lopez <brice@lopez.banh-bao.fr>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=weboob
-VERSION=${VERSION:-0.a}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-PYTHONPATH=$PKG/usr
-sed -i -e "s|share/man|man|g" setup.py
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog INSTALL MANIFEST.in README docs \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/weboob/weboob.info b/network/weboob/weboob.info
deleted file mode 100644
index 38feeabdd3..0000000000
--- a/network/weboob/weboob.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="weboob"
-VERSION="0.a"
-HOMEPAGE="http://weboob.org/"
-DOWNLOAD="https://symlink.me/attachments/download/165/weboob-0.a.tar.gz"
-MD5SUM="15568485fd2bea4c53b69a6edb8c7e45"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="PyYAML feedparser html2text lxml mechanize nose python-dateutil rtmpdump"
-MAINTAINER="Brandon Soonaye"
-EMAIL="brandonsoonaye@live.fr"